Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Splash, tem como explicarem melhor!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
zerocow2
n00b
n00b


Joined: 28 Apr 2005
Posts: 27

PostPosted: Mon Jul 04, 2005 9:35 pm    Post subject: Splash, tem como explicarem melhor! Reply with quote

Bem, eu tava vendo o topico do pilantra, a acabei vando esse artigo sobre o splash.

eu tentei colocar aki, mas não pega.

tem como alguem indicar um how-to ou expliar aki melhor como se faz.

e dizer qual o procedimento com o lilo (não uso ogrub não me pagando).
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7692
Location: Pelotas, BR

PostPosted: Mon Jul 04, 2005 9:59 pm    Post subject: Reply with quote

1. que tópico do Pilantra?
2. que artigo sobre splash?
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
zerocow2
n00b
n00b


Joined: 28 Apr 2005
Posts: 27

PostPosted: Mon Jul 04, 2005 10:21 pm    Post subject: Reply with quote

1 - O tópico 'Bootsplash do Gentoo 2005.0'
2 - Dentro do topico tem um how-to, mas eu axei esse.
http://gentoo-wiki.com/HOWTO_fbsplash

mas eu tentei e deu em nada, ficou pessimo, as msg's do console fivou sobre o slash, uma loucura, tem como alguem explicar isso melhor?

Edit: E sim, eu usei a opção quiet no lilo, mas mesmo asism ficou chei de msg, pois eram a msg do System-V, e não as do kernel.

por isso que ele tá uma bagaçeira só.

e tambem, as msg's aparecam de modo desorganizadas, com o fundo preto, e passava por cima do ema, horrivel.
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Tue Jul 05, 2005 3:02 pm    Post subject: Reply with quote

segue o wiki ha letra.... usa grub e' mais facil de usar no caso do gensplash e' bastante facil
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Fri Jul 08, 2005 11:43 am    Post subject: Reply with quote

Bom isso do fundo preto acho que é um bug do kernel 2.6.12 porque com o 2.6.11 não tenho esse problema.
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
zerocow2
n00b
n00b


Joined: 28 Apr 2005
Posts: 27

PostPosted: Fri Jul 08, 2005 9:03 pm    Post subject: Reply with quote

mas eu uso o kernel 2.6.10!

e o bug não é nas msgs do kernel, e sim nas msgs do System V.
Back to top
View user's profile Send private message
vixie-cron-gentoo
n00b
n00b


Joined: 10 Jul 2005
Posts: 7
Location: Belem-PA

PostPosted: Mon Jul 11, 2005 9:48 pm    Post subject: O mesmo ocorre aqui....Talvez seja o lilo.... Reply with quote

Eu uso o lilo e aqui acontentece problema identico....

Quando esta startando aparece estes problemas....de possicionamento da tela
sobre o splash....aqui usar quiet melhorou....(veja tambem o splash=silent).

So que quando vai exibir a imagem no começo...ela so aparece cortada....ou
melhor como um traço...

Dei uma lida no material do link...e talvez isso seja por que ao inciar, antes de carregar
o vesafb..a resolução de inicialização e preto e braco, por 640x480....

Bem não sei se isso acontece com o GRUB....alguem tem este mesmo problema?

Alguem sabe como sanar este problema com o lilo....aguardamos por ajuda...rss

Help.
_________________
Hi, guys
Back to top
View user's profile Send private message
zerocow2
n00b
n00b


Joined: 28 Apr 2005
Posts: 27

PostPosted: Tue Jul 12, 2005 7:26 am    Post subject: Reply with quote

por enquanto (ainda tou tentando resolver isso) eu estou usando o lilo com a opção splash=verbose

eu tô usando o vesafb-tng, mas eu tentei com o vesafb e não dá me nada, tamebm tentei o rivafb mas tambem não foi.

e sim, eu estou usando a opção quiet

eu dei um olahda e vi que nã o versão mais novo tem que usar a opção fadein, mas mesmo asism o problema ainda continua...

e o grub, eu não consigo instalar... mas mesmo assim, eu não queria recorrer ao grub (não gosto dele).
Back to top
View user's profile Send private message
anunakin
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2004
Posts: 101

PostPosted: Mon Aug 08, 2005 8:03 pm    Post subject: Reply with quote

Bom já usei bootsplash de todo os modos que pude:
Com kernel 2.6 com vários temas e até fiz uns 3 temas que postei no site do bootsplash, bom no kernel oficial do gento não vem mais com o patch para bootsplash agora é o patch para o splashutils que na verdade é um fork do bs (bootsplash), bom instalei recentemente o kernel 2.6.12-gentoo-r6, lá vai o meu método, o qual funcionou no kernel que vem no LiveCD do 2005.0 e em todos os outros aonde testei.
Fiz ateh um tutorial para bs com slackware: http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=894 , meio antigo já mas serve para entender como a coisa funciona...

1- Instale o splashutils
#ACCEPT_KEYWORDS="~x86" emerge splashutils

2- Instale o kernel
#emerge gentoo-sources

3- Compile o kernel
#genkernel --menuconfig all

Selecione as seguintes opções no menuconfig (não use o vesafb-tng):
Code:
<*> Support for frame buffer devices
.
.
<*>   VESA VGA graphics support
|              VESA driver type (vesafb)  --->
.
.
[*] Support for the framebuffer splash


4- Instalei aqui o tema da LiveCD 2005.1
#ACCEPT_KEYWORDS="~x86" emerge media-gfx/splash-themes-livecd

5- Configure o splashutils no arquivo /etc/conf.d/splash

6- No grub.conf deixe sua linha do kernel assim, sendo que vga=0x317 splash=silent CONSOLE=/dev/tty1 são os parametros requeridos pelo splashuitils:
Code:
kernel /boot/kernel-genkernel-x86-2.6.12-gentoo-r6 root=/dev/ram0 init=/linuxrc real_root=/dev/hda1 vga=0x317 splash=silent CONSOLE=/dev/tty1

_________________
Anunakin (Marcus Fazzi)
PHP/Java/C++ Developer
Sony PS3 JPN 60GB, with Gentoo Linux + HDD 160GB
Sony PS2 50001, with PS2Linux, HDD 80GB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum