Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Проблема с установкой
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
anonymouss
n00b
n00b


Joined: 30 Jun 2005
Posts: 27
Location: Russia, Tomsk

PostPosted: Thu Jun 30, 2005 2:18 am    Post subject: Проблема с установкой Reply with quote

Установил Gentoo 2005, но после первой загрузки Grub выдал следующее сообщение:
Code:

>>Mounting filesystems
mount: Mounting devfs on /dev failed: No such device
Error opening file: ".devfsd" No such file or directory
>>Determening root device...
>>Block device /dev/hda7 is not a valid root device...
>>The root block device is unspecified or not detected.
Please specify a device to boot


Содержание файла fstab:
Code:

/dev/boot       /boot    ext2     defaults,noatime   1 2
/dev/root       /           ext3     noatime               0 1
/dev/swap     none      swap    sw                       0 0
.....................
.....................


Для компилирования ядра использовал genkernel.
Как можно разрешить эту проблему?
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Thu Jun 30, 2005 5:16 am    Post subject: Reply with quote

попробовать собрать без genkernel
Back to top
View user's profile Send private message
Nelud
Apprentice
Apprentice


Joined: 08 Oct 2004
Posts: 271

PostPosted: Thu Jun 30, 2005 7:22 am    Post subject: Re: Проблема с установкой Reply with quote

anonymouss wrote:
Содержание файла fstab:
Quote:

/dev/boot /boot ext2 defaults,noatime 1 2
/dev/root / ext3 noatime 0 1
/dev/swap none swap sw 0 0
.....................
.....................

Как можно разрешить эту проблему?

Надо ещё раз внимательно перечитать handbook, в частности вот это раздел: 8. Configuring your System - Filesystem Information
Back to top
View user's profile Send private message
lend
n00b
n00b


Joined: 24 Jul 2004
Posts: 66

PostPosted: Thu Jun 30, 2005 7:30 am    Post subject: Re: Проблема с установкой Reply with quote

anonymouss wrote:
Установил Gentoo 2005, но после первой загрузки Grub выдал следующее сообщение:
Code:

>>Mounting filesystems
mount: Mounting devfs on /dev failed: No such device
Error opening file: ".devfsd" No such file or directory
>>Determening root device...
>>Block device /dev/hda7 is not a valid root device...
>>The root block device is unspecified or not detected.
Please specify a device to boot


Содержание файла fstab:
Code:

/dev/boot       /boot    ext2     defaults,noatime   1 2
/dev/root       /           ext3     noatime               0 1
/dev/swap     none      swap    sw                       0 0
.....................
.....................


Для компилирования ядра использовал genkernel.
Как можно разрешить эту проблему?
В fstab стоит писать имена девайсов, например /dev/hda1 или что там у вас. Для ясности стоит запостить сюда вывод команды
Code:
fstab /dev/hdXX
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Thu Jun 30, 2005 8:43 am    Post subject: Re: Проблема с установкой Reply with quote

Code:

/dev/root       /           ext3     noatime               0 1

:lol: по мне так наличие /dev/root говорит о том что пользователь root все-таки есть:lol:
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Thu Jun 30, 2005 9:03 am    Post subject: Reply with quote

Gentoo-2005 по умолчанию используется UDEV.Поэтому он и не может найти devfs. Нужно прописать конфиге загрузчика....
старый стал , тут помню - тут не помню, что то типа nodevfs- посмотри в доках по переходу на
UDEV.
Back to top
View user's profile Send private message
anonymouss
n00b
n00b


Joined: 30 Jun 2005
Posts: 27
Location: Russia, Tomsk

PostPosted: Thu Jun 30, 2005 5:12 pm    Post subject: Reply with quote

Всем спасибо, проблему разрешил - подправил fstab и grub.conf ( в строке c ...real_root=/dev/hda7 дописал udev).
Back to top
View user's profile Send private message
anonymouss
n00b
n00b


Joined: 30 Jun 2005
Posts: 27
Location: Russia, Tomsk

PostPosted: Fri Jul 01, 2005 2:39 am    Post subject: Reply with quote

Теперь появилась новая проблема - установка Х-ов.
Пытаюсь установить бинарники, через некоторое время выдает ошибку:
Code:

ERROR: x11-base/xorg-x11-6.8.2-r1 failed
Fuction build, Line 951, Exitcode 2
make World failed


Т.е. запрашивается соединение с интернетом? Если да, то можно ли какими-нибудь ключами указать, чтобы установка проходила без интернета?
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Fri Jul 01, 2005 2:55 am    Post subject: Reply with quote

Посмотри на предмет установки с ключем -k. При установке все бинарные пакеты не находятся или только
xorg?
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Fri Jul 01, 2005 5:35 am    Post subject: Reply with quote

Ему видимо надо более новую версию Xorg и/или с патчами. Если старый бинарник, то ключик не -k, а -K (package ONLY).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum