Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOW TO: Install Coldfusion MX 7 With Apache
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Amig
n00b
n00b


Joined: 13 Nov 2006
Posts: 1

PostPosted: Mon Nov 13, 2006 12:27 pm    Post subject: Reply with quote

Hi!

Would like to say thank you for this good how-to! it worked perfectly more or less.

i was using the newest installer from adobe. and in the new version i didnt need to edit the start file. so that was very nice!

And all those missing libs from graphics was easy to fix. i just emerged the libs the logs said was missing. so didnt need to get xorg or anything :)

But in the howto it says you need to "cp -r /opt/coldfusionmx7/cfdocs/ /var/www/localhost/htdocs/" , in the new version i cant find any folder that is named cfdocs.

is it the WEB-INF or webroot maybe? seems to work without it tho...

Thanks again :)
Back to top
View user's profile Send private message
incubator
Guru
Guru


Joined: 05 Jun 2003
Posts: 584
Location: Belgium

PostPosted: Sat Dec 02, 2006 11:47 am    Post subject: Reply with quote

confirmed, version 7.0.2 with the LD-ASSUME_KERNEL commented works fine :)
I thank everyone for their efforts in trying to get this to work, it helped me a lot!
_________________
Programming today is a race between Software Engineers striving to build bigger and better idiot-proof Programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
Back to top
View user's profile Send private message
frameRATE
Guru
Guru


Joined: 28 Apr 2003
Posts: 385
Location: Orange County California

PostPosted: Mon Jan 15, 2007 7:38 pm    Post subject: Reply with quote

I'm glad this tutorial still works for you guys, more or less. I'd like to get around to reupdating it, but work kept me insanely busy!

Keep adding tips and tricks here though, as it seems to be helping people!
_________________

Linux User | 364705

howto install coldfusion mx 7 under gentoo
Back to top
View user's profile Send private message
PaulBain
Apprentice
Apprentice


Joined: 14 Jun 2005
Posts: 159
Location: Coventry, UK

PostPosted: Tue Feb 13, 2007 5:06 pm    Post subject: Reply with quote

Hi guys,

I'm having some trouble with adding the connectors to apache.

When I try I get the following:

Code:

intradev bin # ./coldfusion wsconfig -v -bin -coldfusion -host intradev -server coldfusion -ws Apache -dir /etc/apache2
./coldfusion: line 237: break: only meaningful in a `for', `while', or `until' loop
Found JRun server coldfusion at 127.0.0.1:2920
Could not find file -coldfusion


I moved the -v -bin -coldfusion around incase that was the problem but it wasnt

I'm installing on apache2 with httpd.conf in /etc/apache2. I'm also using the script provided by blade. I had the same problem with the origonal.

Anybody got any ideas?

I also noticed /usr/sbin/apache2 -script /etc/init.d/apache2 no longer works. Maybe it is this version.
I'm installing from coldfusion-70-lin.bin

Thanks

Paul
Back to top
View user's profile Send private message
XioXouS
n00b
n00b


Joined: 01 Apr 2005
Posts: 59

PostPosted: Thu Jun 21, 2007 9:21 pm    Post subject: Update for Hardened Profiles Reply with quote

First, thanks for the how to - very useful.

Second, I did this on a Hardened install, so here are some changes in the various places and some updates for current Gentoo config styles.

1) To fix the "graphing error" you can use modular X. I only needed the following packages.
Code:
emerge -av x11-libs/libXtst x11-libs/libXp sys-libs/lib-compat


2) This was absolutely necessary:
Code:
# cp coldfusion-702-lin.bin coldfusion-702-lin.bak
# cat coldfusion-702-lin.bak | sed "s/export LD_ASSUME_KERNEL/#xport LD_ASSUME_KERNEL/" > coldfusion-702-lin.bin
# ./coldfusion-702-lin.bin


3) Java is one of those packages that doesn't play well with Pax. The installer uses its own JRE that it unpacks to a directory based on a PID (which is often random on Hardened machines). You can't edit the .bin too much or it won't unpack properly, so I ran ./coldfusion-702-lin.bin in one terminal and in another immediately ran
Code:
while true; do chpax -m /tmp/install.dir.*/Linux/resource/jre/bin/*; done
. Now the installer can run and you can go about your business. As stated in Step 4.

4) Step 5 was wholly unnecessary for me. Well, lib-compat was needed, but we did that in my Step 1.

5) Needed to add a chpax rule to /etc/conf.d/chpax for CF and it's JREs (Hardened only):

Code:
cf7="/opt/coldfusionmx7/runtime/{bin/cfmx7,jre/bin/java}"
MPROTECT_EXEMPT="${MPROTECT_EXEMPT} ${cf7}"


6) Here's a Gentoo style init script for coldfusion:
Code:

#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

opts="${opts} stats forcequit"

depend() {
        need net
        use mysql dns logger
        before apache2
        after sshd
}

start() {
        ebegin "Starting ColdFusionMX7"
        /opt/coldfusionmx7/bin/coldfusion start 1>/dev/null \
        && /opt/coldfusionmx7/verity/k2/_ilnx21/bin/k2adminstart 1>/dev/null \
        && while ! ( netstat -n -a | grep -q '8500' ); do sleep 1; done
        eend $?
}

stop() {
        ebegin "Stopping ColdFusionMX7"
        /opt/coldfusionmx7/bin/coldfusion stop 1>/dev/null \
        && /opt/coldfusionmx7/verity/k2/_ilnx21/bin/k2adminstop 1>/dev/null
        eend $?
}

stats() {
        cd /opt/coldfusionmx7/bin/ \
        && ./coldfusion status
        #eend $?
}

forcequit() {
        ebegin "Forcing ColdFusionMX7 to stop"
        stop > /dev/null 2>&1
        /opt/coldfusionmx7/bin/coldfusion stop
        /opt/coldfusionmx7/verity/k2/_ilnx21/bin/k2adminstop
        #eend $?
}


forcequite and stats are extra options I found useful.

7) Rather than that big nasty step in step 7 we can make use of Gentoo's modular Apache config style:

/etc/apache2/modules.d/71_coldfusionmx7.conf

Code:

<IfDefine CF7>
        # JRun Settings
        LoadModule jrun_module /opt/coldfusionmx7/runtime/lib/wsconfig/1/mod_jrun20.so
        <IfModule mod_jrun20.c>
            JRunConfig Verbose false
            JRunConfig Apialloc false
            JRunConfig Ssl false
            JRunConfig Ignoresuffixmap false
            JRunConfig Serverstore /opt/coldfusionmx7/runtime/lib/wsconfig/1/jrunserver.store
            JRunConfig Bootstrap 127.0.0.1:51011
            #JRunConfig Errorurl <optionally redirect to this URL on errors>
            #JRunConfig ProxyRetryInterval 600
            #JRunConfig ConnectTimeout 15
            #JRunConfig RecvTimeout 300
            #JRunConfig SendTimeout 15
            AddHandler jrun-handler .jsp .jws .cfm .cfml .cfc .cfr .cfswf
            AddDirectoryIndex index.cfm
        </IfModule>
</IfDefine>


Now if you want to have Apache handle CF, just add "-D CF7" to APACHE2_OPTS in /etc/conf.d/apache2.

8) You can also probably do without any changes to your apache confs. Perhaps an "Options +FollowSymLinks".

Code:
ln -s /opt/coldfusionmx7/wwwroot/cfide /var/www/localhost/html/cfide
ln -s /opt/coldfusionmx7/wwwroot/CFIDE /var/www/localhost/html/CFIDE
ln -s /opt/coldfusionmx7/wwwroot/cfdocs /var/www/localhost/html/cfdocs


Let me know if you have comments or questions.
Back to top
View user's profile Send private message
Feday
n00b
n00b


Joined: 08 Jan 2005
Posts: 5
Location: Amsterdam

PostPosted: Fri Jun 22, 2007 12:09 pm    Post subject: Reply with quote

Hi all,

I've just finished a second install using this post and like the first time it worked just fine. After taking some notes during the install, I've taken te liberty to add an updated version to the gentoo wiki.

Thanks to all,
Fed.

http://gentoo-wiki.com/HOWTO_Apache_with_Coldfusion_MX7
Back to top
View user's profile Send private message
JoshFed
n00b
n00b


Joined: 21 Jul 2003
Posts: 44
Location: Tacoma, WA USA

PostPosted: Tue Sep 18, 2007 1:22 pm    Post subject: Reply with quote

The boss has had enough of M$ IIS and so the migration begins. I've followed frameRATE's tutorial and I can get into the administration page on port 8500. I'm trying to get the apache connector connected? I get the following, wonderful error:

Code:
./coldfusion wsconfig -host titan.thebeachcompany.com -server coldfusion -ws Apache -dir /etc/apache2 -coldfusion -v -bin /usr/sbin/apache2 -script /etc/init.d/apache2
Apache web server is not supported on Linux


Coldfusion version: 7,0,2,142559
Gentoo: AMD64 2006.1
kernel: 2.6.19-gentoo-r5 #1 SMP
Back to top
View user's profile Send private message
frameRATE
Guru
Guru


Joined: 28 Apr 2003
Posts: 385
Location: Orange County California

PostPosted: Wed Jan 07, 2009 2:03 am    Post subject: Reply with quote

I'd like to install CFMX8 on my server again and update this tutorial. If I can find the time to do it (it's just a private dev box) I will and update things accordingly.

If anyone else is trying this, please post your success/failures here!
_________________

Linux User | 364705

howto install coldfusion mx 7 under gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum