Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Motor (engine) xine-lib não reproduz mais WMV (resolvido)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Jun 27, 2005 11:22 am    Post subject: Motor (engine) xine-lib não reproduz mais WMV (resolvido) Reply with quote

pessoal

Não sei po qual motivo, mas nas ultimas versoes que eu esotu utilizando, o WMV nao reproduz mais em hipotese alguma, isso seria reflexo das atuais patentes de software? ou seria mesmo um problema com minha compilação

Code:
*  media-libs/xine-lib
      Latest version available: 1.0.1-r3
      Latest version installed: 1.0.1-r3
      Size of downloaded files: 7,607 kB
      Homepage:    http://xine.sourceforge.net/
      Description: Core libraries for Xine movie player
      License:     GPL-



win32codecs
Code:
*  media-libs/win32codecs
      Latest version available: 20050216
      Latest version installed: 20050216
      Size of downloaded files: 12,580 kB
      Homepage:    http://www.mplayerhq.hu/
      Description: Win32 binary codecs for video and audio playback support
      License:     as-is


/etc/make.conf
Code:
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://ibiblio.org/pub/Linux/distribuitions/gentoo"
LINGUAS="pt_BR"
USE="mmx 3dnow alsa oss cmipci sse ac3 nvidia opengl ssl"
ALSA_CARDS="cmipci"
ALSA_TOOLS="ac3dec"
MAKEOPTS="-j2"




Detalhe o mplayer continua passando normalmente
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd


Last edited by domus-br on Tue Jun 28, 2005 10:18 am; edited 1 time in total
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Mon Jun 27, 2005 5:37 pm    Post subject: Reply with quote

Não sei, mas tive o mesmo problema. Para não ter que pensar muito, o mplayer ainda funciona.
_________________
Hello.
Back to top
View user's profile Send private message
Seabeast
n00b
n00b


Joined: 30 Oct 2004
Posts: 25

PostPosted: Tue Jun 28, 2005 1:16 am    Post subject: Reply with quote

Talvez seja esse o motivo: você tá usando uma versão masked do xine-lib (~x86). Tô meio sem tempo agora, mas você já deu uma olhada no bugzilla?
_________________
ROCK OVER LONDON
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Tue Jun 28, 2005 2:25 am    Post subject: Reply with quote

Seabeast wrote:
Talvez seja esse o motivo: você tá usando uma versão masked do xine-lib (~x86). Tô meio sem tempo agora, mas você já deu uma olhada no bugzilla?


eu parti para versao instavel, justamente na esperança de que o problema nao estava apenas na versao estavel, pois eu venho da versão estavel com o mesmo problema
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
Guzymuzy
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2004
Posts: 102
Location: Manaus - Brazil

PostPosted: Tue Jun 28, 2005 3:18 am    Post subject: Reply with quote

Code:
USE="win32codecs ffmpeg" emerge xine-lib




Eu uso a mesma versão do xine-lib que vc e o xine roda wmv perfeitamente.

Code:
guzymuzy gustavom # emerge -pv xine-lib

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-libs/xine-lib-1.0.1-r3  +X -a52 -aac -aalib +alsa (-altivec) +arts -cle266 -debug -directfb +dvd -dxr3 -esd -fbcon +ffmpeg -flac -gnome -i8x0 +ipv6 -libcaca +mad -mng +nls +nvidia +opengl +oss +png +samba +sdl -speex -theora -v4l +vcd -vidix +vorbis +win32codecs -xinerama +xv -xvmc 0 kB
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Tue Jun 28, 2005 10:18 am    Post subject: Reply with quote

Guzymuzy wrote:
Code:
USE="win32codecs ffmpeg" emerge xine-lib




Eu uso a mesma versão do xine-lib que vc e o xine roda wmv perfeitamente.

Code:
guzymuzy gustavom # emerge -pv xine-lib

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-libs/xine-lib-1.0.1-r3  +X -a52 -aac -aalib +alsa (-altivec) +arts -cle266 -debug -directfb +dvd -dxr3 -esd -fbcon +ffmpeg -flac -gnome -i8x0 +ipv6 -libcaca +mad -mng +nls +nvidia +opengl +oss +png +samba +sdl -speex -theora -v4l +vcd -vidix +vorbis +win32codecs -xinerama +xv -xvmc 0 kB


CARA! funcionou!!! obrigado

não sei por qual motivo desabilitaram o suporte do WMV, mas voltou tudo a normalidade (por enquanto) :)

abraço
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum