Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
My Ultra 10 is Dead
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Fri Jun 24, 2005 10:29 pm    Post subject: My Ultra 10 is Dead Reply with quote

Hi all. One of my Ultra 10 is dead. The symptom is like this: Suddenly the keyboard and mouse locked up for about 2-3 minutes, and then I gain control for another 1 minute, then again lock up for 2-3 minutes, and back to normal for another minute. I installed Gnome 2.10 lately and this happens when I tried to debug KDE kicker....

At first I thought that I could reboot the comp and get away with it, but it seems that the symptom keeps coming back. After a few times rebooting, the poor SPARC server doesn't even show up its logo when we first boot. The monitor is okay (it shows "Monitor is working" screen). But when the computer tried to show up the boot logo, it went all black. The computer is dead, it seems...

Uh... help?
Back to top
View user's profile Send private message
Magic Michael
n00b
n00b


Joined: 02 Aug 2004
Posts: 47
Location: Berlin (West) / Deutschland

PostPosted: Sat Jun 25, 2005 7:07 pm    Post subject: Reply with quote

Put Solaris onto a spare disc and run SunVTS for a couple of days ?
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Sat Jun 25, 2005 7:56 pm    Post subject: Reply with quote

Uhh... the machine didn't even boot.... When I turn on the computer (and the monitor, of course), it's just blank. No Sun logo, no "Initializing Memory", no nothing....
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Sat Jun 25, 2005 10:57 pm    Post subject: Reply with quote

Try using another power supply, since it's ATX you can just use any PC one you may have around to try. This proved to be some of a weak spot for other users too.
If it's not that you'll need some serial console of some kind to poke around the debug messages.
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Sun Jun 26, 2005 1:52 am    Post subject: Reply with quote

Thanks for replying for all...

The power supply is fine, it seems... The fan is whirling, I can see that the CD-ROM drive blinks a bit when I turn on the computer. However, there is no activity shown in the monitor whatsoever. I first thought that it was the monitor. So, I instinctively press "Stop-A" and then type in "boot cdrom" to boot to the Live CD. But, this doesn't work: The CD-ROM shows no blinking whatsoever. So, there are no booting taken place.

About the serial console, how can I do it? Is there a special console monitor or should I use another PC? Currently I have an x86-based PC with serial port. But I really don't know how to connect to SPARC's serial console...
Back to top
View user's profile Send private message
Magic Michael
n00b
n00b


Joined: 02 Aug 2004
Posts: 47
Location: Berlin (West) / Deutschland

PostPosted: Sun Jun 26, 2005 7:16 am    Post subject: Reply with quote

Unplug the Sun's monitor and keyboard, so it defaults to serial A as standard out (the DB25 one). Then, connect a nullmodem cable to serial A on one side and a PC with a running terminal software (9600,8,N,1) to the other side.
Then boot the Sun and you will hopefully see the POST. "show-post-results" (not sure about the "-") will give you a POST-summary.
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Mon Jun 27, 2005 5:12 pm    Post subject: Reply with quote

Okay, thanks for the help. I have an x86 PC right here next to it. What program can I use to connect to the Sun's serial port? Also, is default null-modem cable (like the one we use in PCs) enough?
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Mon Jun 27, 2005 5:27 pm    Post subject: Reply with quote

You can use minicom.
Null modem = crossover cable, for instance "modem" cable isn't crossover (won't work).
Basically a serial cable you'd use to connect two PCs together.
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Mon Jun 27, 2005 7:31 pm    Post subject: Reply with quote

Thanks all for the help. But I managed to swap the guts of my dead Ultra 10 with another identical Ultra 10. The funny thing is that: The previously dead Ultra 10 now shows up something. It shows the message:
IDPROM contents are invalid.

When I typed in ".idprom", the dates are all set to zeroes. I'm suspecting that this has something to do with the Kicker bug that I was debugging. Now, my questions are:
1. How can I set / reset the NVRAM or the dates to make the IDPROM contents valid again?
2. Should I change the NVRAM chip? If so, how? (Because I can't locate any NVRAM chip or any NVRAM battery just like the one in the PC).

Again, thanks :D

Edit: Also, for some reason, at every 2-3 minutes, error message "Keyboard error detected" is shown....
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Mon Jun 27, 2005 8:45 pm    Post subject: Reply with quote

When I fixed the checksum using mkpl, the machine b0rked again. Just like before. Showing nothing. :(
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum