Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dúvidas nao encontrada nos FAQs
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
filipe
n00b
n00b


Joined: 16 Jun 2005
Posts: 2

PostPosted: Thu Jun 16, 2005 8:23 pm    Post subject: Dúvidas nao encontrada nos FAQs Reply with quote

Olá,

Estou utilizando o Gentoo a pouco tempo e ainda não encontrei respota para algumas perguntas referentes ao funcionamento deste distro. São eles:

1. Pelo que pude entender, ao utilizar algo como emerge --update --deep world todos os pacotes serão atualizados para a última versão disponível certo? se a minha intenção não é atualizar para a última versão mas sim atualizar para a mesma versão mas com correçoões de segurança por exemplo, existe algum parâmetro extra?
É feito normalmente um "back-port" de correções de segurança?
Exemplo hipotético: Tenho o bash-2.05, saiu o bash-2.06 e o bash-3.0 mas nao quero atualizar a versão(3.xx) e sim apenas a sub-versão (2.xx) corrigida.

2. As atualizações não removem o pacote anterior por padrão? É necessário explicitamente fazer o unmerge após atualizar algum software?
Encontrei várias versões do automake, sendo que em nenhum momento instalei, atualizei o automake explicitamente.

comp01 root # equery list | grep automake
sys-devel/automake-1.5
sys-devel/automake-wrapper-1-r1
sys-devel/automake-1.8.5-r3
sys-devel/automake-1.6.3
sys-devel/automake-1.7.9-r1
sys-devel/automake-1.4_p6
sys-devel/automake-1.9.5

3. Todos os ebuilds disponíveis para o kernel são consideráveis estáveis?
Pergunto pois verifique o seguinte no changelos do pacote gentoo-source(http://www.gentoo.org/cgi-bin/viewcvs.cgi/*checkout*/sys-kernel/gentoo-sources/ChangeLog):

-------------
*gentoo-sources-2.6.11-r11 (12 Jun 2005)

12 Jun 2005; Daniel Drake <dsd@gentoo.org>
-gentoo-sources-2.6.11-r10.ebuild, +gentoo-sources-2.6.11-r11.ebuild:
Update to Linux 2.6.11.12 and add a keyboard resume fix
--------------

O gentoo-sources-2.6.11-r10.ebuild foi removido e adicionado o gentoo-sources-2.6.11-r11.ebuild mas nem por isso por exemplo o r9, o r8, o r7 foram excluidos.
São esses outros(r7, r6, ...) considerados livres de bugs de segurança?

É isso, agradeço aos Gurus de plantão.
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Thu Jun 16, 2005 10:40 pm    Post subject: Reply with quote

1 - Existe backport de patches caso a versão antiga existe num determinado profile, seja stable/unstable ou ppc, x96-64, etc. Dentro do mesmo profile acho qe não há.

2 - Sim, removem a versão anterior, excepto quando é necessário ter várias versões do mesmo pacote, o automake é uma delas. Para isso o Gentoo usa um sistema denominado de SLOT, basicamente instala em slots diferentes cada versão de software.

3 - Não. Os considerados estáveis têm a opção ACCEPT_KEYWORDS="arch" onde arch pode ser x86, ppc, etc. Se foram considerados unstable têm um ~ antes, por exemplo ACCEPT_KEYWORDS="~x86". A versão que instalas depende da configuração no make.conf.
Back to top
View user's profile Send private message
filipe
n00b
n00b


Joined: 16 Jun 2005
Posts: 2

PostPosted: Fri Jun 17, 2005 10:26 am    Post subject: Reply with quote

Obrigado RoadRunner, apenas uma pequena dúvida que ainda fiquei quanto ao Kernel.
Imaginos o kernel-2.6.11-r1(ACCEPT_KEYWORDS="xpto") como stable e surge uma problema de segurança onde esse pacote é afetado. Assim que sair o kernel-2.6.11-r2, o kernel-2.6.11-r1 é marcado como ACCEPT_KEYWORDS="~xpto"? Ou mascarado, enfim, se torna unstable :?:

Obrigado.
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Fri Jun 17, 2005 1:28 pm    Post subject: Reply with quote

Se isso acontever o kernel 2.6.11-r1 permanece na tree de Gentoo sem alterações e é lançado o 2.6.11-r2 para corrigir esses problemas. Ambos ficam com ACCEPT_KEYWORDS="xpto" e o portage irá instalar o mais recente. Neste caso a versão que terá ACCEPT_KEYWORDS="~xpto" será uma versão ainda não suficientemente testada, por exemplo um 2.6.12_pre1 ou qualquer coisa do estilo. Caso a versão mais recente do pacote seja estável aí nesse caso essa ebuild irá satisfazer tanto a versão stable como unstable.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum