Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TV tuner won't work in new kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
fog
n00b
n00b


Joined: 28 Sep 2003
Posts: 49

PostPosted: Thu Jun 16, 2005 12:29 am    Post subject: TV tuner won't work in new kernel Reply with quote

I've done some extensive system upgrades recently, and I'm hoping someone can help me figure out exactly what I did to break my TV tuner.

I've got a Hauppage TV tuner, and it's worked fine for quite some time. Recently, I upgraded my kernel (to 2.6.11-gentoo-r9), upgraded to X.org rather than XF86, and started using the nvidia drivers with TwinView. (I'd gone quite some time without using my second monitor.)

Starting xawtv gives me this error:

Quote:

This is xawtv-3.86, running on Linux/i686 (2.6.11-gentoo-r9)
dlopen: /usr/lib/xawtv/conv-mjpeg.so: undefined symbol: jpeg_resync_to_restart
xinerama 0: 1280x1024+0+0
xinerama 1: 1280x1024+1280+0
Xlib: extension "XVideo" missing on display ":0.0".
Xlib: extension "XVideo" missing on display ":0.0".
WARNING: Your X-Server has no DGA support.
can't open /dev/video0: No such device
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such device
v4l2: open /dev/video0: No such device
v4l: open /dev/video0: No such device
no video grabber device available


I've tried starting it with -noxv, or -nodga, or both, but it still won't work. This might be a simple fix: I just don't know a whole lot about X.

My /etc/X11/xorg.conf, in case it matters:
Quote:

Section "ServerFlags"
Option "Xinerama" "false"
EndSection

Section "Device"
#Identifier "nVidia Corporation NV11 [GeForce2 MX]"
Identifier "mx"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GeForce2 MX"
VideoRam 32768
Screen 0
Option "TwinView"
Option "MetaModes" "1280x1024,1280x1024; 1024x768,1024x768"
Option "TwinViewOrientation" "RightOf"
Option "SecondMonitorHorizSync" "30-85"
Option "SecondMonitorVertRefresh" "50-160"
# Option "RenderAccel"
# Option "AllowGLXWithComposite"
EndSection

Section "Monitor"
Identifier "m1"
# HorizSync 30-85
# VertRefresh 50-160
#Modeline "1600x1200" 145.98 1600 1704 1872 2144 1200 1201 1204 1238 -HSync +Vsync
EndSection

Section "Screen"
Identifier "left"
#Device "nVidia Corporation NV11 [GeForce2 MX]"
Device "mx"
Monitor "m1"
DefaultDepth 24
Option "NvAGP" "1"
Option "TwinView" "true"
Option "TwinViewOrientation" "RightOf"
Option "Xinerama" "on"
SubSection "Display"
Depth 24
# Modes "1600x1200" "1280x1024" "1280x960" "640x480"
Modes "1280x1024"
EndSubSection
EndSection

Section "Extensions"
# Option "Composite" "Enable"
Option "XVideo" "true"
EndSection


(I just tried adding the "Option XVideo" bit in a (fruitless) attempt to get it to work.)

The system does "see" the card, as this bit from phpsysinfo shows:
Quote:

0000:00:0d.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture
0000:00:0d.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture


I'm sure that, somewhere along the line, I broke something that's needed. But can someone steer me towards figuring out what it was?
Back to top
View user's profile Send private message
Galuvian
n00b
n00b


Joined: 16 Sep 2004
Posts: 30

PostPosted: Thu Jun 16, 2005 3:10 am    Post subject: Reply with quote

I use MythTV, don't know if xawtv has different requirements...

Make sure you still have BTTV in your new kernel.

Here's what's in my /usr/src/linux/.config

Quote:

CONFIG_VIDEO_BT848=m
CONFIG_VIDEO_BTCX=m


Hmm, looking at your error message again, I found this in my xorg.conf

Quote:

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Load "extmod"



Not sure if that helps, but hope it does.
Back to top
View user's profile Send private message
dryadcito
Apprentice
Apprentice


Joined: 08 Oct 2004
Posts: 170
Location: Spain

PostPosted: Thu Jun 16, 2005 6:31 am    Post subject: Reply with quote

Since the last baselayout upgrade my kernel modules don't load automatically, so I'm not able to use my webcam or tv tuner without loading them myself, and this could be your trouble. Look at your kernel config If you have bttv ( Devices->Multimedia->Video for Linux->BT848 ). If you have it marked as a module try

Code:

modprobe bttv


and then xawtv. If this works you have the same problem I had. Then, you have two choices

1. Put bttv in /etc/modules.autoload.d/kernel-2.6 ( assuming you are using kernel 2.6). This will work but you'll have to do so for some other modules ( like ide-cd if you have this as a module ) and perhaps you don't know which ones.
2. The easy way is coldplug. It'll load all modules for your hardware and you won't need to know their names or what are they needed for. Just do

Code:

emerge coldplug
rc-update add coldplug default
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum