Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg não inicia
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
walbon
n00b
n00b


Joined: 06 Jun 2005
Posts: 18

PostPosted: Mon Jun 13, 2005 12:33 pm    Post subject: Xorg não inicia Reply with quote

Utilizei as ferramentas
Xorg -configure
xorgcfg
xorgcfg -textmode
e nada adiantou, contiua a voltar o problema e o erro é relatado no arquivo Xorg.0.log desta forma abaixo:

Code:

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.8-gentoo-r4 i686 [ELF]
Current Operating System: Linux tux 2.6.11-gentoo-r3 #3 Sat Jun 11 14:15:16 Local time zone must be set--see zic manu i686
Build Date: 12 March 2005
   Before reporting problems, check http://wiki.X.Org
   to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jun 12 21:18:01 2005
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 39 of section InputDevice in file /etc/X11/xorg.conf
   "Device" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


E o arquivo gerado pelo Xorg -configure foi o seguinte:
Code:

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   RgbPath      "/usr/lib/X11/rgb"
   ModulePath   "/usr/lib/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/CID/"
   FontPath     "/usr/share/fonts/75dpi/"
   FontPath     "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
   Load  "extmod"
   Load  "dri"
   Load  "dbe"
   Load  "record"
   Load  "xtrap"
   Load  "glx"
   Load  "type1"
   Load  "freetype"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
    Device       "/dev/mouse"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "A2"                    # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "HWCursor"              # [<bool>]
        #Option     "SWCursor"              # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "Rotate"                # [<str>]
        #Option     "UseBIOS"               # [<bool>]
        #Option     "VideoRAM"              # <i>
        #Option     "ActiveDevice"          # [<str>]
        #Option     "LCDDualEdge"           # [<bool>]
        #Option     "BusWidth"              # [<str>]
        #Option     "Center"                # [<bool>]
        #Option     "PanelSize"             # [<str>]
        #Option     "TVDotCrawl"            # [<bool>]
        #Option     "TVType"                # [<str>]
        #Option     "TVOutput"              # [<str>]
        #Option     "TVVScan"               # [<str>]
        #Option     "TVHScale"              # [<str>]
        #Option     "TVEncoder"             # [<str>]
        #Option     "Refresh"               # <i>
        #Option     "DisableVQ"             # [<bool>]
        #Option     "NoDDCValue"            # [<bool>]
        #Option     "Cap0Deinterlace"       # [<str>]
        #Option     "Cap1Deinterlace"       # [<str>]
        #Option     "Cap0FieldSwap"         # [<bool>]
        #Option     "DRIXINERAMA"           # [<bool>]
   Identifier  "Card0"
   Driver      "via"
   VendorName  "Unknown Vendor"
   BoardName   "Unknown Board"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7692
Location: Pelotas, BR

PostPosted: Mon Jun 13, 2005 3:10 pm    Post subject: Reply with quote

Na linha 39, ao invés de Device "/dev/mouse"

deverias ter algo tipo:

Option "Device" "/dev/mouse"

ou

Option "Device" "/dev/input/mice"
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Pilantra
n00b
n00b


Joined: 12 Jun 2005
Posts: 44
Location: Maringá - PR

PostPosted: Tue Jun 14, 2005 1:05 pm    Post subject: Reply with quote

Eu tive o mesmo problema no inicio!!!

O correto no dispositivo do mouse eh:

/dev/psaux

Pode por isso que funciona blzinha!!!! Eu apanhei pra iniciar o X porque eu tava colocando /dev/mouse e depois que eu dei uma olhada no kernel eu vi que é psaux!!

Flw
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum