Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New Baselayout not working with wireless
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
wheelspin
n00b
n00b


Joined: 28 Jul 2003
Posts: 23
Location: Seacoast NH

PostPosted: Sat Jun 11, 2005 2:37 am    Post subject: New Baselayout not working with wireless Reply with quote

Okay, I've seen a couple of problems mentioned with wireless networking and tried the solutions (and many others), but after emerging the new baselayout, I cannot automatically start my wireless network. I can do it manually though.

When I run /etc/init.d/net.eth1 start from the command line I get this
Code:

gt40 conf.d # /etc/init.d/net.eth1 start
 * Caching service dependencies ...                                                                               [ ok ]
 * Starting eth1
 *   Configuring wireless network for eth1
 *   eth1 does not support scanning
 *   You either need to set a preferred_aps list in /etc/conf.d/wireless
 *      preferred_aps=( "ESSID1" "ESSID2" )
 *      and set associate_order_eth1="forcepreferred"
 *      or set associate_order_eth1="forcepreferredonly"
 *   or hardcode the ESSID to "any" and let the driver find an Access Point
 *      essid_eth1="any"
 *   or configure defaulting to Ad-Hoc when Managed fails
 *      adhoc_essid_eth1="WLAN"
 *   or hardcode the ESSID against the interface (not recommended)
 *      essid_eth1="ESSID"
 *   Failed to configure wireless for eth1                   

If I type the following commands, it works fine.

Code:
iwconfig eth1 enc 33333333333 essid myssid
ifconfig eth1 up
dhcpcd eth1


I put all the information into /etc/conf.d/wireless as directed. Then I saw a post that said the handbook had been updated with detailed information. In there it suggests putting the lines from wireless into net. I did that too. No worky. I've copied my WEP key and pasted it into the file and onto the command line in case my eyesight is failing or I'm typing wrong. So I've ruled that out. What else could be wrong?

Any help is greatly appreciated.
Back to top
View user's profile Send private message
ansient
Guru
Guru


Joined: 22 Jan 2005
Posts: 445
Location: Argentina

PostPosted: Sat Jun 11, 2005 2:43 am    Post subject: Reply with quote

please post your exact conf.d/wireless

see wireless.example
Back to top
View user's profile Send private message
wheelspin
n00b
n00b


Joined: 28 Jul 2003
Posts: 23
Location: Seacoast NH

PostPosted: Sat Jun 11, 2005 2:52 am    Post subject: Reply with quote

Here it is. Ain't much, but supposedly its enough...

Code:

modules=("iwconfig")            <-- This is in /etc/conf.d/net

key_Speeder="9191919191919191919191 enc open"
preferred_aps=( "Speeder" )
associate_order="preferredonly"
Back to top
View user's profile Send private message
drumz
Apprentice
Apprentice


Joined: 10 Nov 2002
Posts: 213

PostPosted: Sat Jun 11, 2005 12:12 pm    Post subject: Reply with quote

Ok, I've converted my hacked up method I used previously and now have my stuff working fine under the new baselayout. I'll post my setup below.

Hardware: Dell Inspiron laptop with a D-Link card (atheros chip) running super-g and using wpa_supplicant.

1. /etc/init.d: net.ath0 is a softlink to net.eth0 (ln -s net.eth0 net.ath0:
Code:
lrwxrwxrwx  1 root root     8 Jun  9 13:31 net.ath0 -> net.eth0


2. added net.ath0 to default run level (rc-update add net.ath0 default).

3. /etc/conf.d/net file. Note that for my card (d-link DWL-G650 I'm using the wpa_supplicant for wpa and the madwifi drivers). My card for my system is seen as 'ath0':
Code:
modules=( "wpa_supplicant" )
wpa_supplicant_ath0="-Dmadwifi"
config_ath0=( "192.168.1.11 netmask 255.255.255.0" )
routes_ath0=( "default gw 192.168.1.1" )


4. /etc/wpa_supplicant.conf. I've removed security related items (ssid, pre-shared key).
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
eapol_version=1
ap_scan=1
network={
        ssid="<your_ssid_goes_here>"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=CCMP TKIP WEP104 WEP40
        psk="<your_preshared_key_goes_here>"
        priority=2
}



This works like a charm on my laptop, hopefully you'll find what you need from this....
Back to top
View user's profile Send private message
jakubc
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2005
Posts: 138
Location: Prague <- Czech Republic <- Europe <- World...

PostPosted: Sat Jun 11, 2005 1:14 pm    Post subject: Reply with quote

hi,

if your interface really doesn't support scanning, then try to input this into /etc/conf.d/wireless:
Code:
essid_eth1="Speeder"

and then the rest of the setup... this should just give the card the essid, and the rest of the setup without it scanning for your preffered_ap

hope this helps!
_________________
Regards,
Jakub Cerny
Back to top
View user's profile Send private message
wheelspin
n00b
n00b


Joined: 28 Jul 2003
Posts: 23
Location: Seacoast NH

PostPosted: Sat Jun 11, 2005 3:40 pm    Post subject: Reply with quote

It helps a little bit, but I shouldn't have a problem with the card I'm using. The message about not being able to scan is incorrect. There is something going on here that is preventing this from working correctly. The current state of things say's it doesn't support setting keys. Huh? Like I said, I copied and pasted the key directly out of the file to the command line and it works fine without any mods. So that message too, is bs.

I played around with this a month or two ago when I was trying a new card in my laptop and couldn't get it to work then either. I got the other card working, but not my old Linksys. This is beginning to look like a bad spot because there seems to be a good number of people having problems like this. The only way they can get the wireless going is to do it manually. That just isn't right.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum