Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot emerge acrobat reader 7.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
zaknwfp
n00b
n00b


Joined: 05 Jun 2005
Posts: 5
Location: fargo nd

PostPosted: Sun Jun 05, 2005 11:05 pm    Post subject: cannot emerge acrobat reader 7.0 Reply with quote

For some reason I cannot emerge acrobat reader 7.0. I tried
# echo "app-text/acroread ~x86" >> /etc/portage/package.keywords
[color=darkred]# emerge acroread
[/color]

it installs acrobat 5.0. Then I tried
#echo "app-text/acroread-7.0 ~x86" >> /etc/portage/package.keywords
#emerge acroread-7.0

I get the

!!! Problem in app-text/acroread-7.0 dependencies.
!!! "Specific key requires an operator (app-text/acroread-7.0) (try adding an '=')"


then I edited package.keywords file to
=app-text/acroread ~x86
and then emerged but it gave the same error. Any idea on how to fix this?:(
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jun 05, 2005 11:08 pm    Post subject: Reply with quote

Hi,

try:

Code:
echo "app-text/acroread ~x86" >> /etc/portage/package.keywords


and try :

Code:
emerge -av ">=acroread-7.0"

_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'


Last edited by kernelsensei on Sun Jun 05, 2005 11:14 pm; edited 2 times in total
Back to top
View user's profile Send private message
zaknwfp
n00b
n00b


Joined: 05 Jun 2005
Posts: 5
Location: fargo nd

PostPosted: Sun Jun 05, 2005 11:12 pm    Post subject: Reply with quote

echo "=app-text/acroread-7.0 ~x86" >> /etc/portage/package.keywords

gives the same error.
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jun 05, 2005 11:15 pm    Post subject: Reply with quote

just modified my previous post, have a look ...
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
zaknwfp
n00b
n00b


Joined: 05 Jun 2005
Posts: 5
Location: fargo nd

PostPosted: Sun Jun 05, 2005 11:17 pm    Post subject: Reply with quote

This is what I get

!!! Problem in >=app-text/acroread-7.0 dependencies.
!!! "Specific key requires an operator (app-text/acroread-7.0) (try adding an '=')"
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jun 05, 2005 11:21 pm    Post subject: Reply with quote

zaknwfp wrote:
This is what I get

!!! Problem in >=app-text/acroread-7.0 dependencies.
!!! "Specific key requires an operator (app-text/acroread-7.0) (try adding an '=')"


hum, weird, could you post your /etc/portage/package.* files here please ? and maybe the output from emerge info

thanks.
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
radfoj
Guru
Guru


Joined: 31 Dec 2004
Posts: 490
Location: Tísek, Czech Republic

PostPosted: Sun Jun 05, 2005 11:24 pm    Post subject: Reply with quote

I have in package.keywords
Code:
app-text/acroread ~x86

Code:
 # emerge -av acroread

These are the packages that I would merge, in order:
Calculating dependencies ...done!
[ebuild   R   ] app-text/acroread-7.0.0.2-r1  -cjk -ldap -noplugin 0 kB
Total size of downloads: 0 kB
Back to top
View user's profile Send private message
zaknwfp
n00b
n00b


Joined: 05 Jun 2005
Posts: 5
Location: fargo nd

PostPosted: Sun Jun 05, 2005 11:29 pm    Post subject: Reply with quote

This is my /etc/package.keywords file
app-text/acroread-7.0 ~x86
=app-text/acroread-7.0 ~x86
app-text/acroread ~x86


and my emerge info generates this

Portage 2.0.50-r11 (default-x86-2004.2, gcc-3.3.4, glibc-2.3.3.20040420-r1,2.3.3.20040420-r0, 2.6.8-gentoo-r3)
=================================================================
System uname: 2.6.8-gentoo-r3 i686 Pentium III (Katmai)
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="YES"
CFLAGS="-O3 -march=pentium3 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo ftp://lug.mtu.edu/gentoo/source"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb bitmap-fonts crypt cups encode esd f77 foomaticdb gdbm gif gnome gpm gtk gtk2 imlib java javacomm javadoc javamail javascript jpeg kde libg++ libwww mad mikmod motif mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang spell ssl svga tcpd tetex truetype x86 xml2 xmms xprint xv zlib"
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jun 05, 2005 11:31 pm    Post subject: Reply with quote

clear your /etc/package.keywords and do :

Code:
echo "app-text/acroread ~x86" >> /etc/portage/package.keywords
emerge -av acroread

_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
zaknwfp
n00b
n00b


Joined: 05 Jun 2005
Posts: 5
Location: fargo nd

PostPosted: Sun Jun 05, 2005 11:38 pm    Post subject: Reply with quote

it installed acroread-5.09 and I cannot even start it. These are the first few lines after emerge
These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild U ] app-text/acroread-5.09-r1 [5.09] -cjk -noplugin 0 kB

Total size of downloads: 0 kB

Do you want me to merge these packages? [Yes/No] Y
>>> emerge (1 of 1) app-text/acroread-5.09-r1 to /
>>> md5 src_uri ;-) linux-509.tar.gz
Back to top
View user's profile Send private message
NetTrodon
n00b
n00b


Joined: 12 Dec 2004
Posts: 18
Location: Pachuca, Hidalgo. México

PostPosted: Mon Jun 06, 2005 11:07 pm    Post subject: Reply with quote

Try:
Code:
ACCEPT_KEYWORDS="~x86" emerge --verbose -a -f acroread
ACCEPT_KEYWORDS="~x86" emerge --verbose -a acroread

Then don't use the parameter "-f", with him first download all necesary files, but don't install.
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Jun 07, 2005 8:40 am    Post subject: Reply with quote

hum, you shouldn't do ACCEPT_KEYWORDS="~x86" emerge .... , use the /etc/portage/package.* files instead
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum