Joined: 12 May 2004
|Posted: Mon Jun 06, 2005 8:11 pm Post subject: [ GLSA 200506-04 ] Wordpress: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: Wordpress: Multiple vulnerabilities (GLSA 200506-04)
Date: June 06, 2005
Updated: May 22, 2006
Bug(s): #88926, #94512
Wordpress contains SQL injection and XSS vulnerabilities.
WordPress is a PHP and MySQL based content management and publishing
Vulnerable: < 188.8.131.52
Unaffected: >= 184.108.40.206
Architectures: All supported architectures
Due to a lack of input validation, WordPress is vulnerable to SQL
injection and XSS attacks.
An attacker could use the SQL injection vulnerabilities to gain
information from the database. Furthermore the cross-site scripting
issues give an attacker the ability to inject and execute malicious
script code or to steal cookie-based authentication credentials,
potentially compromising the victim's browser.
There is no known workaround at this time.
All Wordpress users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/wordpress-220.127.116.11"
Last edited by GLSA on Fri Feb 21, 2014 4:20 am; edited 7 times in total