Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] broken /opt/blackdown-jre-1.4.2.01/lib/...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Mon Jun 06, 2005 8:58 am    Post subject: [SOLVED] broken /opt/blackdown-jre-1.4.2.01/lib/... Reply with quote

Hi,

On a new PC Gentoo 2005.0 amd64, I am about to install kde 3.4.1 as complited all important install sequence. I made sure to run emerge -uD world so that I have my system updated.
I noticed that kde was offering some new USE flags I did not have implemented. So I made changes and then followed Gentoo "Adapting your Entire System to New USE Flags"
I did:
# emerge --update --deep --newuse world
# emerge --depclean
# revdep-rebuild

While revdep-rebuild runnig gave me this:
Code:
root # revdep-rebuild

Checking reverse dependencies...
Packages containing binaries and libraries broken by any package update,
will be recompiled.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /opt/blackdown-jre-1.4.2.01/lib/amd64/libjsoundalsa.so (requires libasound.so.2)
  broken /opt/blackdown-jdk-1.4.2.01/jre/lib/amd64/libjsoundalsa.so (requires libasound.so.2)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot --nodeps  =dev-java/blackdown-jdk-1.4.2.01-r2 =dev-java/blackdown-jre-1.4.2.01-r1
..........





 * Caching service dependencies...>>> dev-java/blackdown-jre-1.4.2.01-r1 merged.

>>> clean: No packages selected for removal.

>>> Auto-cleaning packages ...

>>> No outdated packages were found on your system.


 * GNU info directory index is up-to-date.

Build finished correctly. Removing temporary files... ..........
You can re-run revdep-rebuild to verify that all libraries and binaries
are fixed. If some inconsistency remains, it can be orphaned file, deep
dependency, binary package or specially evaluated library.


Now, what is it and do I have to be concerned?
Then I decided to run revdep-rebuild again, as suggested, and got the same.
What should I do?

Here is my java-config --list-available-vms
Code:
root # java-config --list-available-vms
[blackdown-jre-1.4.2.01] "Blackdown JRE 1.4.2.01" (/etc/env.d/java/20blackdown-jre-1.4.2.01)
[blackdown-jdk-1.4.2.01] "Blackdown JDK 1.4.2.01" (/etc/env.d/java/20blackdown-jdk-1.4.2.01) *


Please let me know. I am waiting for this answer to install kde (not knowing if this might interfeer with kde)

Thank you,
Spiro


Last edited by SAngeli on Tue Jun 07, 2005 3:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Tue Jun 07, 2005 3:47 pm    Post subject: Reply with quote

Hi,

here is the answer:

Quote:
Sorry, revdep-rebuild fails to work sanely with binary packages, like java.

*** This bug has been marked as a duplicate of 83852 ***


Is this critical or can I just ingore it? No, it´s completely safe to ignore.

I hope this helps.

Spiro
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Tue Jun 07, 2005 5:07 pm    Post subject: Reply with quote

If you install a new Java JDK (Sun or Blackdown), the only packages that need your attention are the ones that has -java USE flag in it OR the packages that require Java in the first place (like ant or log4j). That should be easy enough.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum