Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemas com nvidia-glx
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
dragobr
n00b
n00b


Joined: 03 Apr 2005
Posts: 11

PostPosted: Mon Jun 06, 2005 12:03 am    Post subject: problemas com nvidia-glx Reply with quote

Quando instalei meu gentoo há algum tempo, apenas dei emerge nvidia-kernel... hoje, ao tentar rodar o xcompmgr e vendo como ele ficava lento, fui tentar instalar o nvidia-glx...

dei emerge nvidia-glx.. opengl-update nvidia... tentei entrar no X, no screens found.. aqui está as ultimas linhas do log

Quote:
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xF9000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found


tentei dar emerge unmerge nvidia-glx nvidia-kernel e emerge nvidia-glx, e msma coisa..

se eu dou apenas emerge unmerge nvidia-glx, e deixo o nvidia-kernel, volta a funcionar...

aqui está meu xorg.conf (retirei boa parte dos comentários para ficar menor)

Quote:
# File generated by xorgconfig.

Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the font modules
Load "type1"
# Load "speedo"
Load "freetype"
# Load "xtt"

# This loads the GLX module
Load "glx"
# This loads the DRI module
# Load "dri"

EndSection

# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Type1/"
# FontPath "/usr/share/fonts/CID/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/local/"
# FontPath "/usr/share/fonts/Speedo/"
# FontPath "/usr/share/fonts/TrueType/"
# FontPath "/usr/share/fonts/freefont/"

# The module search path. The default path is shown here.

# ModulePath "/usr/X11R6/lib/modules"

EndSection

Section "ServerFlags"

EndSection

Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"


# Option "Protocol" "Xqueue"

Option "AutoRepeat" "500 30"

Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"

EndSection


Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/input/mice"

EndSection

Section "Monitor"

Identifier "Compaq"


HorizSync 31.5 - 64.3


VertRefresh 50-90

EndSection

Section "Device"
Identifier "Standard VGA"
VendorName "Unknown"
BoardName "Unknown"

Driver "vga"

EndSection

# Device configured by xorgconfig:

Section "Device"
Identifier "gf"
Driver "nvidia"
# unsupported card
#VideoRam 65536
# Insert Clocks lines here if appropriate
EndSection

Section "Screen"
Identifier "Screen 1"
Device "gf"
Monitor "Compaq"
DefaultDepth 24

Subsection "Display"
Depth 24
Modes "1280x1024"
ViewPort 0 0
EndSubsection
EndSection


Section "ServerLayout"


Identifier "Simple Layout"

Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection


alguém tm alguma dica? =/
Back to top
View user's profile Send private message
Operador Nabla
Apprentice
Apprentice


Joined: 06 Feb 2004
Posts: 176
Location: Salesópolis - SP - Brasil

PostPosted: Tue Jun 07, 2005 5:42 pm    Post subject: Reply with quote

É possível que o módulo do kernel para o driver nVIDIA não tenha sido carregado quando o sistema tentar iniciar o X (execute o comando lsmod e veja se ele está lá). Se for o caso, adicione a linha nvidia ao seu arquivo /etc/modules.autoload.d/2.6 (acho que o nome é esse, mas não estou me lembrando agora...) para que o módulo seja carregado automaticamente durante o boot (e execute modprobe nvidia se não quiser reiniciar o micro...).
Back to top
View user's profile Send private message
dragobr
n00b
n00b


Joined: 03 Apr 2005
Posts: 11

PostPosted: Fri Jun 10, 2005 12:58 pm    Post subject: Reply with quote

hmm desculpe n ter avisado.. dei modprobe, opengl-update, e td o que eu acho que deveria ter feito
Back to top
View user's profile Send private message
Operador Nabla
Apprentice
Apprentice


Joined: 06 Feb 2004
Posts: 176
Location: Salesópolis - SP - Brasil

PostPosted: Mon Jun 13, 2005 8:06 pm    Post subject: Reply with quote

Quando você tenta carregar o módulo manualmente (modprobe nvidia), ele carrega normalmente? (veja a saída do comando lsmod) Se não, aparece alguma mensagem de erro? (experimente executar insmod /caminho/para/o/modulo/nvidia.ko, pois ele costuma gerar mensagens de erro quando a coisa falha)

Outra coisa: acho que não tem nada a ver, mas estou estranhando o fato de a linha ModulePath do seu xorg.conf estar comentada...

Mais uma coisa: você citou o xcompmgr. Para poder utilizá-lo, você deve ter habilitar Composite Extensions no seu xorg.conf:
Code:
Section "Extensions"
    Option "Composite" "Enable"
EndSection


Para poder utilizar Composite junto com o driver GLX da nVIDIA, adicione a seguinte linha na sua seção Device referente à sua placa nVIDIA:
Code:
Option "AllowGLXWithComposite" "True"


Também é recomendado acidionar a seguinte linha na mesma seção:
Code:
Option "RenderAccel" "True"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum