Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how do i install fonts?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Sun Jun 05, 2005 12:21 pm    Post subject: how do i install fonts? Reply with quote

i just downloaded a font set (xfonts-artwiz-2.8.tar.gz). i have extracted the folder to /usr/share/fonts/. but the fonts failed to show on programme settings and xfontsel.

can someone please tell me how do i properly install fonts?
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jun 05, 2005 12:23 pm    Post subject: Reply with quote

hi,

why don't you emerge media-fonts/artwiz-fonts :?:

and for your problem, are you using xfs ? (X fonts Server)

to get more informations, have a look here : http://gentoo-wiki.com/HOWTO_Xorg_and_Fonts
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Sun Jun 05, 2005 12:33 pm    Post subject: Reply with quote

hi,

i have no idea if i am using xfs or not. how do i check?

EDIT: i tried emerging before, and ran into some problem. now i know why. i got an error because it was null/ instead of media-fonts/.

i have now emerged, and the fonts are still failing to show in xfontsel.

please help more.
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jun 05, 2005 12:37 pm    Post subject: Reply with quote

hatesalt wrote:
hi,

i have no idea if i am using xfs or not. how do i check?

i tried emerging, but i got this:
Code:
emerge -a xfonts-artwiz-2.8

These are the packages that I would merge, in order:

Calculating dependencies   

!!! Problem in null/xfonts-artwiz-2.8 dependencies.
!!! "Specific key requires an operator (null/xfonts-artwiz-2.8) (try adding an '=')" exceptions

i didn't know how what this meant, so i tried doing it manually; thinking all i have to do was drop it into the font folder after extracting. but as it appears, it didn't work that way.

i didn't know where i am suppose to add the '='.

please help.


the 2.8 version isn't in portage tree, try :

Code:
emerge -av artwiz-fonts
the version 2.4 is available .

if you want to install your fonts manually, do it and read the documentation I posted in my previous post (I guess that you haven't added the font dir in your xorg.conf)
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Pithlit
l33t
l33t


Joined: 27 Dec 2003
Posts: 887
Location: fuhen

PostPosted: Sun Jun 05, 2005 12:37 pm    Post subject: Reply with quote

Code:
# emerge artwiz-fonts
NO version numbers till you read emerge and portage manpages!
_________________
If someone solves a problem for you say thanks... and put [SOLVED] in the title!
Back to top
View user's profile Send private message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Sun Jun 05, 2005 12:41 pm    Post subject: Reply with quote

i noticed the mistake that i have made, so i tried to edit my message, but it appears you already responded to it.

here is my edited message once again in case you missed it:

Quote:
i have now emerged [media-fonts/artwiz-fonts], and the fonts are still failing to show in xfontsel.
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun Jun 05, 2005 12:44 pm    Post subject: Reply with quote

hatesalt wrote:
i noticed the mistake that i have made, so i tried to edit my message, but it appears you already responded to it.

here is my edited message once again in case you missed it:

Quote:
i have now emerged [media-fonts/artwiz-fonts], and the fonts are still failing to show in xfontsel.


try :
Code:
/etc/init.d/xfs restart
/etc/init.d/xdm restart


Warning : /etc/init.d/xdm restart will restart your X server, save your session before doing that (in console)
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Sun Jun 05, 2005 1:05 pm    Post subject: Reply with quote

still not working... :(

i have edited /etc/X11/xorg.conf:

Code:
Section "Files"
        RgbPath      "/usr/lib/X11/rgb"
        ModulePath   "/usr/lib/modules"
        FontPath     "/usr/share/fonts/misc:unscaled"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/CID/"
        FontPath     "/usr/share/fonts/75dpi:unscaled"
        FontPath     "/usr/share/fonts/100dpi:unscaled"
        FontPath     "/usr/share/fonts/artwitz"
        FontPath     "/usr/share/fonts/unifont"
EndSection

but still doesn't show on xfontsel. what am i doing wrong?
Back to top
View user's profile Send private message
Pithlit
l33t
l33t


Joined: 27 Dec 2003
Posts: 887
Location: fuhen

PostPosted: Sun Jun 05, 2005 1:34 pm    Post subject: Reply with quote

Quote:
FontPath "/usr/share/fonts/artwitz"
It's artwiz, not artwitz :P fix, retry, report. We'll get this sorted out.
_________________
If someone solves a problem for you say thanks... and put [SOLVED] in the title!
Back to top
View user's profile Send private message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Sun Jun 05, 2005 9:00 pm    Post subject: Reply with quote

worked! thanks everyone!

btw, if i wanted to add just a single artwiz font, do i have to re-emerge the package or can i just dump the file into the artwiz folder?
Back to top
View user's profile Send private message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Mon Jun 06, 2005 12:15 am    Post subject: Reply with quote

i got some issues... the fonts are now showing in xfontsel. but not in firefox, gaim, and gtk-chtheme. how do i get them to show on these programmes?
Back to top
View user's profile Send private message
Pithlit
l33t
l33t


Joined: 27 Dec 2003
Posts: 887
Location: fuhen

PostPosted: Mon Jun 06, 2005 1:29 am    Post subject: Reply with quote

No offense but... I just have to ask: Did you by any chance use the search function? Cos... you'd find a couple nice threads about fonts in xorg, firefox and whatever other app you're using. But more importantly (aside form the font guide on gentoo wiki) there's a great Howto written by solka which you can read here. The howto also contains the link to the Gentoo Wiki guide.
_________________
If someone solves a problem for you say thanks... and put [SOLVED] in the title!
Back to top
View user's profile Send private message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Mon Jun 06, 2005 3:50 am    Post subject: Reply with quote

yes, i did, i typed in 'xorg font' in the forums, and got a long list of results. i read the titles, and nothing matches what i was trying to solve.

the closest i have come across is this:
https://forums.gentoo.org/viewtopic-t-317293-highlight-font+xorg+artwiz.html

that user was only trying to get it to show on xfontsel, which i have gone passed that part. but it wouldn't show on programmes like firefox, gaim, and gtk-chtheme.

if you know the exact topic i am suppose to be reading, please post it.

using this guide: http://gentoo-wiki.com/HOWTO_Xorg_and_Fonts#Mozilla_Firefox_and_Thunderbird

i ran into problems. i was stuck on this part
Code:
~/.mozilla/firefox/default.xxx/.

the file doesn't exist. there is no default.xxx file, but there is a *.default file. which was empty when i opened it.

then i tried the alternative on the guide:

Code:
Throughout the about:config dialog, or in the user.js file you have to insert the following lines as shown below:

and it didn't work either, because the first result i tried to filter 'user_pref' is not even in about:config.

then i looked at the date of the guide, and noticed it was almost a year outdated.
Quote:
This page was last modified 17:02, 4 Jun 2005.

and on the top of the page, it says
Quote:

This HOWTO is out-of-date. Please help to update it.


also, i did this:

Code:
fc-cache -fv
fc-cache: "/usr/X11R6/lib/X11/fonts/Type1": caching, 29 fonts, 0 dirs
fc-cache: "/usr/share/fonts": caching, 0 fonts, 17 dirs
fc-cache: "/usr/share/fonts/CID": caching, 0 fonts, 0 dirs
fc-cache: "/usr/share/fonts/TTF": caching, 24 fonts, 0 dirs
fc-cache: "/usr/share/fonts/ukr": caching, 0 fonts, 0 dirs
fc-cache: "/usr/share/fonts/misc": caching, 55 fonts, 0 dirs
fc-cache: "/usr/share/fonts/util": caching, 0 fonts, 0 dirs
fc-cache: "/usr/share/fonts/default": caching, 0 fonts, 1 dirs
fc-cache: "/usr/share/fonts/default/ghostscript": caching, 35 fonts, 0 dirs
fc-cache: "/usr/share/fonts/75dpi": caching, 398 fonts, 0 dirs
fc-cache: "/usr/share/fonts/Type1": caching, 29 fonts, 0 dirs
fc-cache: "/usr/share/fonts/local": caching, 0 fonts, 0 dirs
fc-cache: "/usr/share/fonts/encodings": caching, 0 fonts, 1 dirs
fc-cache: "/usr/share/fonts/encodings/large": caching, 0 fonts, 0 dirs
fc-cache: "/usr/share/fonts/arphicfonts": caching, 4 fonts, 0 dirs
fc-cache: "/usr/share/fonts/firefly": caching, 0 fonts, 0 dirs
fc-cache: "/usr/share/fonts/artwiz": caching, 0 fonts, 0 dirs
fc-cache: "/usr/share/fonts/unifont": caching, 2 fonts, 0 dirs
fc-cache: "/usr/share/fonts/100dpi": caching, 398 fonts, 0 dirs
fc-cache: "/usr/share/fonts/corefonts": caching, 30 fonts, 0 dirs
fc-cache: "/usr/share/fonts/cyrillic": caching, 0 fonts, 0 dirs
fc-cache: "/usr/local/share/fonts": skipping, no such directory
fc-cache: "/usr/X11R6/lib/X11/fonts/75dpi": caching, 398 fonts, 0 dirs
fc-cache: "/usr/X11R6/lib/X11/fonts/100dpi": caching, 398 fonts, 0 dirs
fc-cache: "/root/.fonts": skipping, no such directory
fc-cache: succeeded

it shows on xfontsel, but the above says 'fc-cache: "/usr/share/fonts/artwiz": caching, 0 fonts, 0 dirs' from here, i don't know what to do.

please help.
Back to top
View user's profile Send private message
Pithlit
l33t
l33t


Joined: 27 Dec 2003
Posts: 887
Location: fuhen

PostPosted: Mon Jun 06, 2005 4:02 am    Post subject: Reply with quote

*sigh* You're not supposed to follow the guides to the letter. The "default.xxx" (btw... it's not a file) is a folder containing your default users settings and is usualy composed of a bunch of letters and numbers followed by ".default" (or whatever the name you chose for your profile). In my case it's "qzyfh4gk.user" in yours it might be "8u67gd8k.default".
_________________
If someone solves a problem for you say thanks... and put [SOLVED] in the title!
Back to top
View user's profile Send private message
hatesalt
n00b
n00b


Joined: 21 May 2005
Posts: 22

PostPosted: Mon Jun 06, 2005 4:31 am    Post subject: Reply with quote

Code:
user_pref("font.default", "sans-serif");
user_pref("font.language.group", "ko");
user_pref("font.minimum-size.x-western", 0);
user_pref("font.name.monospace.ko", "Clean");
user_pref("font.name.monospace.x-unicode", "AR PL SungtiL GB");
user_pref("font.name.monospace.x-user-def", "Clean");
user_pref("font.name.monospace.x-western", "Clean");
user_pref("font.name.monospace.zh-CN", "AR PL SungtiL GB");
user_pref("font.name.monospace.zh-HK", "Clean");
user_pref("font.name.monospace.zh-TW", "Clean");
user_pref("font.name.sans-serif.ko", "Clean");
user_pref("font.name.sans-serif.x-unicode", "AR PL SungtiL GB");
user_pref("font.name.sans-serif.x-user-def", "Clean");
user_pref("font.name.sans-serif.x-western", "Clean");
user_pref("font.name.sans-serif.zh-CN", "AR PL SungtiL GB");
user_pref("font.name.sans-serif.zh-HK", "Clean");
user_pref("font.name.sans-serif.zh-TW", "Clean");
user_pref("font.name.serif.ko", "Clean");
user_pref("font.name.serif.x-unicode", "AR PL SungtiL GB");
user_pref("font.name.serif.x-user-def", "Clean");
user_pref("font.name.serif.x-western", "Clean");
user_pref("font.name.serif.zh-CN", "AR PL SungtiL GB");
user_pref("font.name.serif.zh-HK", "Clean");
user_pref("font.name.serif.zh-TW", "Clean");
user_pref("font.size.fixed.x-user-def", 9);
user_pref("font.size.variable.x-user-def", 9);
user_pref("font.size.variable.x-western", 12);
user_pref ("font.FreeType2.enable", true);
user_pref ("font.freetype2.shared-library", "libfreetype.so.6");
user_pref ("font.FreeType2.autohinted", true);
user_pref ("font.FreeType2.unhinted", true);
user_pref ("font.antialias.min",        0);
user_pref ("font.embedded_bitmaps.max", 1000000);
user_pref ("font.scale.tt_bitmap.dark_text.min", 0);
user_pref ("font.scale.tt_bitmap.dark_text.gain", "0.0");
user_pref ("font.directory.truetype.1",
"/usr/share/fonts/ttf-bitstream-vera");
user_pref ("font.directory.truetype.2", "/usr/share/fonts/TTF");
user_pref ("font.directory.truetype.3", "/usr/share/fonts/corefonts");
user_pref ("font.directory.truetype.4", "/usr/share/fonts/freefont");
user_pref ("font.FreeType2.printing", true);
user_pref ("font.directory.artwiz)", "/usr/share/fonts/artwiz");
user_pref ("font.artwiz.printing", true);


still:

Code:
fc-cache -fv
fc-cache: "/usr/share/fonts/artwiz": caching, 0 fonts, 0 dirs
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum