Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't emerge kde
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
quangdog
n00b
n00b


Joined: 26 May 2002
Posts: 5

PostPosted: Mon May 27, 2002 2:55 pm    Post subject: can't emerge kde Reply with quote

(Ugh, I haven't used lynx to browse the web for such a long time, this hurts my eyes....but, on to my question)
When I issue this command: emerge --pretend kde
I get this error: !!! Error: couldn't find match for =x11-libs/qt-3* in kde-base/arts-1.0.1

What's wrong?
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Mon May 27, 2002 4:48 pm    Post subject: Maybe the ebuild file is wrong? Reply with quote

That's odd. I would have thought it should be x11-libs/qt, not x11-libs/qt-3 (which isn't valid). Have a look at /usr/portage/kde-base/arts/arts-1.0.1.ebuild in a text editor. There should be a line saying
Code:
need-qt 3.0.3

If it does say that anyway, perhaps you could try temporarily removing the line, so that it doesn't check the dependency. As long as you have at least qt 3.0.3 emerged anyway, hopefully it will work.

Also, try moving the whole /usr/portage/kde-base/arts directory somewhere else, and running emerge rsync to rebuild the directory.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum