Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Виснет gentoo при работе в иксах.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Fri Jun 03, 2005 1:08 pm    Post subject: Виснет gentoo при работе в иксах. Reply with quote

Вообщем такое дело, сижу в иксах, wm fluxbox-0.9.13-r1, запускаю фаирфокс, все путем. Вродь все работает, все пучком. Короче хотел почитать с squid.opennet.ru про аудентификацию сквида. Открылся фак в фаирфоксе, прокручиваю вниз, система умирает на каком-то конкретном пункте. Или лажу по сайтам с смсами, то же самое, начинаю делать прокрутку и тут бац и все висим. На клаву не реагирует, но мышка по экрану ездеет. Музыка играет. Вообщем странно все это. Такое наблюдается еще при открытии kooldock, например.

Вот мое оборудование: Туалатин 1.2, Gentoo 2005.0, firefox 1.0.4, xorg-x11-6.8.2-r1.
У меня вот есть предположение, что это может быть из-за флагов оптимизации. Вот вывод emerge --info:
Code:

serg_sk@Elvenhome ~ $ sudo emerge --info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.10 i686)
=================================================================
System uname: 2.6.10 i686 Intel(R) Celeron(TM) CPU                1200MHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May 12 2005, 09:59:13)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer -mmmx -msse -m32"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=pentium3 -O2 -pipe -fomit-frame-pointer -mmmx -msse -m32"
DISTDIR="/home/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LINGUAS="ru ua"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm avi berkdb bitmap-fonts bonobo cdr crypt curl emboss encode esd fam foomaticdb fortran gdbm gif gnome gpm gtk gtk2 gtkhtml imagemagick imlib ipv6 jpeg kde libg++ libwww mad mikmod mmx motif mp3 mpeg mtrr ncurses nls nptl nptlonly ogg oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang spell sse ssl svga tcpd tiff truetype truetype-fonts type1-fonts vorbis xine xml xml2 xmms xv zlib linguas_ru linguas_ua userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY


Кто что посоветует?
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Fri Jun 03, 2005 4:18 pm    Post subject: Reply with quote

Видеокарточка какая?
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Fri Jun 03, 2005 5:06 pm    Post subject: Reply with quote

GeForce 2 MX400. С ней вродь все норм, даже 3D я настроил. Хм... а может дрова попробовать откатить?
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Fri Jun 03, 2005 5:19 pm    Post subject: Reply with quote

Подозреваю драйвера, если у тебя не установлен transparency,composite ....
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Fri Jun 03, 2005 5:45 pm    Post subject: Reply with quote

doonkel wrote:
Подозреваю драйвера, если у тебя не установлен transparency,composite ....

С ними, сразу виснет :) Сейчас обновляю дрова, потом попробую откатить. О результатах доложу.
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Fri Jun 03, 2005 6:30 pm    Post subject: Reply with quote

откат и обновление ничего не дали.
Вот еще интересный момент, после opengl-update xorg-x11 иксы вообще не запускаются, ругаются на отсутсвие GLX. А при opengl-update nvidia, иксы запускаются, но получаю те же глюки.

P.S. Я даже в ET гамаюсь, и все норм. Странно это все.
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Fri Jun 03, 2005 6:37 pm    Post subject: Reply with quote

Проблемма решилась зарамливанием следующего:
Code:
#        Option     "NvAGP" "2"
#       Option      "HWCursor" "true"
#        Option      "RenderAccel" "true"
#        Option      "MultisampleCompatibility" "true"

С чем конкретно связано, пока не разобрался, пока времени особо нет. Потом на досуге потыкаю.
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Sat Jun 04, 2005 6:35 am    Post subject: Reply with quote

ты знаешь, у меня точно такая же проблема, подозреваю, только уверенно виснет только FF
было подозрение на java, потому как он мог долгое время работать, а вис (как мне показалось) при скроллинге на сайтах с j-script, например, на ЛОРе я уж и пересобирал его и так и этак
а началось, вроде бы, после того как поставил бОльшую оптимизацию для gcc

виснет, гад, до сих пор, причём с такими же симптомами - мыша ездит, а всё мёртвое, как валпапер прямо
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Sat Jun 04, 2005 9:03 am    Post subject: Reply with quote

fank wrote:
ты знаешь, у меня точно такая же проблема, подозреваю, только уверенно виснет только FF
было подозрение на java, потому как он мог долгое время работать, а вис (как мне показалось) при скроллинге на сайтах с j-script, например, на ЛОРе я уж и пересобирал его и так и этак
а началось, вроде бы, после того как поставил бОльшую оптимизацию для gcc

виснет, гад, до сих пор, причём с такими же симптомами - мыша ездит, а всё мёртвое, как валпапер прямо

У меня жавы отродясь небыло, так что это не она. :) Вот оптимизация, может быть, и карточку свою потыкай.
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum