Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200505-19 ] gxine: Format string vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu May 26, 2005 11:36 am    Post subject: [ GLSA 200505-19 ] gxine: Format string vulnerability Reply with quote

Gentoo Linux Security Advisory

Title: gxine: Format string vulnerability (GLSA 200505-19)
Severity: normal
Exploitable: remote
Date: May 26, 2005
Bug(s): #93532
ID: 200505-19

Synopsis


A format string vulnerability in gxine could allow a remote attacker to
execute arbitrary code.


Background


gxine is a GTK+ and xine-lib based media player.


Affected Packages

Package: media-video/gxine
Vulnerable: < 0.4.4
Unaffected: >= 0.3.3-r2 < 0.3.4
Unaffected: >= 0.4.1-r1 < 0.4.2
Unaffected: >= 0.4.4
Architectures: All supported architectures


Description


Exworm discovered that gxine insecurely implements formatted
printing in the hostname decoding function.


Impact


A remote attacker could entice a user to open a carefully crafted
file with gxine, possibly leading to the execution of arbitrary code.


Workaround


There is no known workaround at this time.


Resolution


All gxine users should upgrade to the latest available version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose media-video/gxine


References

CAN-2005-1692
Bugtraq ID 13707
Original Advisory


Last edited by GLSA on Tue Apr 19, 2011 4:19 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum