Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cups-1.1.23-r3 b0rked - [solved - sort of]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1184
Location: Motown

PostPosted: Sun May 22, 2005 2:54 pm    Post subject: cups-1.1.23-r3 b0rked - [solved - sort of] Reply with quote

bug filed
_________________
WYSIWYG - What You See Is What You Grep


Last edited by darkphader on Tue May 24, 2005 3:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Germany

PostPosted: Sun May 22, 2005 4:44 pm    Post subject: Reply with quote

Excuse me, what is this thread about?
_________________
KDE
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1184
Location: Motown

PostPosted: Sun May 22, 2005 5:02 pm    Post subject: Reply with quote

About a b0rked ebuild.
Basically a heads up to not install or upgrade to the ebuild in the subject.
Plus a note that a bug has been filed in case anyone is concerned or wants to know more.
Is there something not clear about the post?
_________________
WYSIWYG - What You See Is What You Grep
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Germany

PostPosted: Sun May 22, 2005 5:28 pm    Post subject: Reply with quote

darkphader wrote:
Is there something not clear about the post?

Hehe, yes. First you didn't mention *what* is wrong with the ebuild. Second you didn't link the bug.
_________________
KDE
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1184
Location: Motown

PostPosted: Sun May 22, 2005 5:31 pm    Post subject: Reply with quote

Printing breaks, mime.types is empty, unpacking error as well:
>>> Unpacking pdftops.pl to /var/tmp/portage/cups-1.1.23-r3/work
unpack pdftops.pl: file format not recognized. Ignoring.

And the RDEPEND of xpdf is all wrong - prevents CUPS from being installed
without X which is not desired for a server.

https://bugs.gentoo.org/show_bug.cgi?id=93553
_________________
WYSIWYG - What You See Is What You Grep
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1184
Location: Motown

PostPosted: Tue May 24, 2005 3:13 pm    Post subject: solved - sort of Reply with quote

Printing issues solved.
But it (1.1.23-r3) still requires an alternate pdftops, a replacement for the official cups pdftops filter, which requires xpdf which with a -motif use flag no longer needs X but still will cause
    media-libs/t1lib
    media-fonts/gnu-gs-fonts-std
    app-text/ghostscript
    media-libs/freetype
    app-text/xpdf
to be installed on your server.

I can't quite see the logic in this.
_________________
WYSIWYG - What You See Is What You Grep
Back to top
View user's profile Send private message
Lawless
l33t
l33t


Joined: 03 Nov 2003
Posts: 638
Location: Germany

PostPosted: Tue Jun 07, 2005 4:31 am    Post subject: Reply with quote

1.1.23-r4 still wants xpdf (and the whole x server)
I would be happy if somebody could change that.
I can remove xpdf from the ebuild and install cups but after new sync portage wants to install x again.
So please...
_________________
Kernel panic: I have no root and I want to scream
Back to top
View user's profile Send private message
mattsk
n00b
n00b


Joined: 11 Apr 2003
Posts: 46
Location: Newcastle, Australia

PostPosted: Mon Jul 18, 2005 11:18 am    Post subject: Reply with quote

I was able to get rid of it by adding -sdl to my USE variables (along with -X -gtk -gnome -qt -alsa -qtmt -pdflib -truetype -dga -gpm). Sadly, I'm not sure which of the rest of those is also necessary for convincing cups to not install X for me. (Same situation - I'm running a headless server so don't want X on it at all). But untitl I added -sdl to the mix, it kept trying to install X.

The wierd thing is I think it might have been someothing in mysql somewhere that wanted to use sdl (the simple direct media layer). This is because every time I typed in 'emerge -uDp cups' it would end up updpating mysql as well.

I hope this helps somebody.
_________________
-- Matt Sk (etc)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum