Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema com a lig. internet gentoo router [Solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Dabubble
n00b
n00b


Joined: 03 Jul 2003
Posts: 19
Location: Coimbra - Portugal

PostPosted: Sun May 15, 2005 9:44 pm    Post subject: Problema com a lig. internet gentoo router [Solved] Reply with quote

Viva!

Ja ha uns bons meses que a minha gentoo box estava a funcionar como router sem problemas em minha casa.

A semana passada a rede netcabo foi-se abaixo e quando recuperou deixei de conseguir aceder a internet.

Nem mesmo no proprio router funciona. O que e estranho e que o cable modem regista, a box recebe o ip por dhcp mas depois simplemente nao da para navegar.

No entanto estao sempre a chegar e a partir pacotes da eth1 (a interface ligada ao cable modem), definitivamente nao percebo, ate porque ligando um pc em windows funciona logo, o que nao e nada normal.


Alguem pode dar uma ajuda?????

Obrigado


Last edited by Dabubble on Mon May 16, 2005 3:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Sun May 15, 2005 11:13 pm    Post subject: Reply with quote

Bom, nãio estarás a barrar o DHCp da netcabo ou o nameserver deles ? Será que tens ai alguma regra de firewall esquesita ?

tens o ip_forward activo a 1 ?
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
Dabubble
n00b
n00b


Joined: 03 Jul 2003
Posts: 19
Location: Coimbra - Portugal

PostPosted: Sun May 15, 2005 11:46 pm    Post subject: Reply with quote

A minha firewall estava bem configurada, dei iptables este semestre e ate percebo alguma cena daquilo (afinal fucnionou durante uns 100 dias) mesmo assim desliguei a maior parte das features firewall so deixei as NAT.

sim o ip_forward esta a 1, mas mesmo que nao estivesse isso nao faria com que eu nao tivesse net na propria box.

o que e estranho e que esta tudo como dantes so que agora nao funciona.


ai ai...
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Mon May 16, 2005 1:05 am    Post subject: Reply with quote

Olá.

Se quizeres fazer uns testes para confirmar se o problema é da rede ou da configuração do firewal, aconselho-te a baixares a firewall e tentares ligar. Se funcionar o problema é do firewall, se não é de nível mais baixo. Se a máquina obtêm um ip do servidor de DHCP da netcabo, confirma a tabela de routing. Tenta fazer um ping e um traceroute a um ip conhecido - serve para testar se o problema não é de resolução de nomes.
Para poder ajudar mais, preciso de mais detalhes e de saber o resultado dos testes.
Boa sorte.
Back to top
View user's profile Send private message
Dabubble
n00b
n00b


Joined: 03 Jul 2003
Posts: 19
Location: Coimbra - Portugal

PostPosted: Mon May 16, 2005 3:15 am    Post subject: Reply with quote

Depois de analisar o que pediste (mesmo um ping por ip nao funcionou) lembrei-me de dar mais uma vista de olhos as regras do iptables e descobri o problema.

Para poupar processamento em vez de estar a usat o target -j MASQUERADE estava a usar o -SNAT --to-source $EXTIP o que aconteceu foi que o ip guardado pelo script do gentoo era antigo e ele estava portanto a alterar a fonte dos pacotes de saida para outro ip que nao o meu, este problema ainda nao me tinha acontecido devido aos longos leases de IP's dinamicos da netcabo.

Espero que isto sirva para alguem com um problema identico.


...E obrigado pela ajuda.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum