Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge xfree FAILS !!! HELP
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

PostPosted: Tue May 21, 2002 4:41 pm    Post subject: emerge xfree FAILS !!! HELP Reply with quote

emerge xfree fails!

I tried twice (2+ hours to compile each time) and it fails at the same point every time.


+ mkdir -p /var/tmp/portage/xfree-4.2.0-r9/image//usr/X11R6/include/X11/Xft
+ install -c -m 0444 Xft.h /var/tmp/portage/xfree-4.2.0-r9/image//usr/X11R6/include/X11/Xft
+ install -c -m 0444 XftFreetype.h /var/tmp/portage/xfree-4.2.0-r9/image//usr/X11R6/include/X11/Xft
+ install -c -m 0444 XftConfig /var/tmp/portage/xfree-4.2.0-r9/image//usr/X11R6/include/X11/XftConfig
+ mkdir -p /var/tmp/portage/xfree-4.2.0-r9/image//etc/X11
cp: 'XftConfig': Argument list too long
make[3]: *** [install] Error 1
make[3]: Leaving directory 'var/tmp/portage/xfree-4.2.0-r9/work/xc/lib/Xft'
make[2]: *** [install] Error 2
make [2]: Leaving directory 'var/tmp/portage/xfree-4.2.0-r9/work/xc/lib'
make[1]: *** [install] Error 2
make[1]: Leaving directory 'var/tmp/portage/xfree-4.2.0-r9/work/xc'
make: *** [install] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_install, Line 2, Exitcode 2
!!! (no error message)

!!! emerge aborting on /usr/portage/x11-base/xfree/xfree-4.2.0-r9.ebuild .

Anybody, Please help!!!
Back to top

PostPosted: Tue May 21, 2002 11:02 pm    Post subject: Any suggestions PLEASE. I'm really stuck!!! Reply with quote

I'm still stuck. I've tried 2 more times. Same result every time.

Are there any suggestions?????

Please HELP!!!!
Back to top

PostPosted: Wed May 22, 2002 5:43 am    Post subject: STILL NO X !!!! ARRRRRRGGGGGG Reply with quote

I've emerged 5 more times (literal !!!!) still fails at the same point.

I looked up the message "Argument list too large" in google and was lead to a recompile of the kernel after changing the source (increase MAX_ARG_PAGES from 32 to 64.

Did that. Still the same error.

I'm out of ideas. ANYBODY PLEASE HELP, what should I try next?

What kind of debugs or lists should I try to do?

I tried emerge -d but got no other error messages that I could see.

Should I give up?
Back to top

PostPosted: Wed May 22, 2002 5:50 pm    Post subject: Still no response from anybody! Any suggestions would help! Reply with quote

OK here is what has happened next.

When the emerge xfree fails, I cd to '/var/tmp/portage/xfree-4.2.0-r9/work/xc/lib/Xft

I then issue "make install" and it fails with the same "Argument list too long" message.

Drawing at straws here - So I decide to update bash (Ive previously recompiled my kernel - see last post)

After updating bash I reboot. Then I try the emerge again. It fails again.

I go back to '/var/tmp/....' and I issue the "make install" it doesnt fail!!

HMMMMM. After updating bash the make install does not fail.

To try it out I cd to 'var/tmp/portage/xfree-4.2.0-r9/work/xc/' and I issue make, and 90 minutes later I issue make install. NO ERROR!!!!

I then issue make install.doc. NO ERROR!!!

So now with the recompiled BASH. I can manually compile xfree. But it is still not correct as I look at the .emerge script and it does a lot of stuff (copies and links and other stuff).

So what next? Why does a manual make/make install work (with the xfree that emerge downloads), but the make/make install issued from emerge still fail?

So next I emerge portage (I think that that is where emerge itself lives) to recompile it.

I have re-booted, and I am in process of emerge xfree again. I'll know in about 90 minutes if it works or fails.

In the meantime. PLEASE give me some other suggestions on what I should try!!!!!!!!!
Back to top

PostPosted: Wed May 22, 2002 6:39 pm    Post subject: I give up Reply with quote

It failed again.

I give up.
Back to top
Tux's lil' helper
Tux's lil' helper

Joined: 18 May 2002
Posts: 100

PostPosted: Wed May 22, 2002 6:55 pm    Post subject: Reply with quote

You could maybe look at the build scripts and see if it is doing any copying or moving there. If so, it may be using a wildcard, which could create the too long arg list. You could maybe get around it by having it copy/move less at a time, or maybe doing it with some type of iteration thru the list of files to be copied/moved.
this space for rent
Back to top
View user's profile Send private message

PostPosted: Thu May 23, 2002 5:23 am    Post subject: Success !!! But I had to start from scratch Reply with quote

I'm back again.

I gave up. But I thought about all the time I had invested (several days now) and I decided to try once again.

This time I decided to start from scratch. So I fdisk'd my drive and started again with the gentoo boot disk that I burned.

Something must have gone wrong with my first installation. It's very likely I choose some strange kernel option that caused all of my problems. But I sure don't know what it was.

Well, this time after the initial load and bootstrap, and emerge of the system, I am able to emerge xfree.


So now I'm off to bed while my laptop chugs along with a big emerge of gdm gnome mozilla evolution gimp cups gimp-print-cups java...

If I wake up with an error message I'm frisbee'n the gentoo disk and going back to the duck.

I hope that's not the case because I selected gentoo after the latest 8.2 version of the duck trashed my gnome desktop.
Back to top

PostPosted: Sat May 25, 2002 3:12 am    Post subject: XFree fails Reply with quote

The problem is due to broken fileutils-4.1.8-r2.ebuild when compiled with USE="acl" flag. Temporary workaround is to disable -acl flag. This problem also breaks db package as well and many others ebuilds using long argument to the 'cp' command. Could someone please file a bug report - I am not registered with the site.[/b]
Back to top

Joined: 08 May 2002
Posts: 980

PostPosted: Sat May 25, 2002 7:50 am    Post subject: Reply with quote

The gentoo bugzilla is open for all.
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message

Joined: 24 May 2002
Posts: 21

PostPosted: Sun May 26, 2002 8:21 pm    Post subject: Similar problem... Reply with quote

This is not so much a response but a side question.
I am having a similar issue, or at least I think I am.
You can see the details at :
I have not been able to install Xfree no matter how many times I attempt to Emerge it.
It seems to drop out with ./exports/lib/, not found (try using -rpath or -rpath-link)
After this line there are a series of undefined references.
And then finally failure etc.

Any thoughts?
I have yet to rebuild from scratch as I was hoping to not have to do that, but see that seemed to have worked for some.

Let me know if anyone has any suggestions.


Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum