Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache mpm-prefork - How can I enable this use flag? SOLVED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
sthneed
n00b
n00b


Joined: 07 Jul 2004
Posts: 8

PostPosted: Sun May 15, 2005 1:49 pm    Post subject: Apache mpm-prefork - How can I enable this use flag? SOLVED Reply with quote

I am trying to emerge apache-2.0.54 with mod_php-5.0.3

Apachce compiles OK but mod_php fails with message:

The module you are trying to install (mod_php)
will only work with one of the following MPMs:
prefork
...
Please re-install apache with the correct mpm-* USE flag

I've tried to do that but I can't get the mpm-prefork USE flag to show up when I try to re emerge apache

cat /usr/portage/profiles/use.local.desc | grep mpm-prefork
gives:

net-www/apache:mpm-prefork - Adds support for the prefork Apache MPM

so I know it's there, but

emerge -pv ">=apache-2.0.54"

gives

Calculating dependencies  ...done!
[ebuild R ] net-www/apache-2.0.54-r4 +berkdb -debug -doc +gdbm +ipv6 -ldap +ssl -static -threads 0 kB

=> no mpm-prefork USE flag.


I tried adding the mpm-prefork USE flag on the command line and in /etc/make.conf but I still don't see the flag when do emerge -p.

It shows up in emerge info but is not passed to apache.

emerge info :

Total size of downloads: 0 kB
Gentoo Base System version 1.4.16
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.4.3, glibc-2.3.4.20041102-r1, 2.6.11-gentoo-r8 i686)
=================================================================
System uname: 2.6.11-gentoo-r8 i686 AMD Duron(tm) processor
Python: dev-lang/python-2.3.5 [2.3.5 (#1, May 13 2005, 11:22:00)]
dev-lang/python: 2.3.5
sys-apps/sandbox: [Not Present]
sys-devel/autoconf: 2.59-r6, 2.13
sys-devel/automake: 1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils: 2.15.92.0.2-r7
sys-devel/libtool: 1.5.16
virtual/os-headers: 2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=i686 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=i686 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi aim alsa apache2 apm arts audiofile avi bash-completion berkdb bitmap-fonts bonobo bzlib calendar caps cdparanoia cdr crypt cups curl curlwrappers dba divx4linux dvd dvdr dvdread emboss encode esd expat fam fastcgi flac flash foomaticdb fortran ftp gb gd gdbm gif gmp gnome gnustep gpm gtk gtk2 gtkhtml guile icq imagemagick imap imlib innodb ipv6 java javascript jpeg kde lesstif libg++ libwww mad mikmod motif mozilla mp3 mpeg mpm-prefork msn mysql ncurses nls odbc offensive ogg oggvorbis opengl oss pam pcre pdflib perl php png posix python qt quicktime readline ruby samba sdl spell ssl svga tcpd tidy tiff tokenizer truetype truetype-fonts type1-fonts usb v4l vhosts videos vorbis win32codecs wmf x86 xine xinerama xml xml2 xmms xpm xv xvid yahoo zlib userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY


I found this post on another forum:

https://forums.gentoo.org/viewtopic-t-336257-highlight-mpmprefork.html

which shows the use flags I want but I can't get them to work for me.

I tried emerge sync and emerge -R portage => no success.
I tried changing compilers with gcc-config => no success.

Any help would be appreciated.

- sam


Last edited by sthneed on Mon May 16, 2005 1:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
aetherane
n00b
n00b


Joined: 15 May 2005
Posts: 3

PostPosted: Sun May 15, 2005 4:59 pm    Post subject: Reply with quote

I am having the same problem. I added prefork to my use in /etc/make.conf, and emerged apache. Now when i try to emerge mod_php-5.04 it says that I need to build apache with event, metuxmpm,peruser,worker,threadpool
Back to top
View user's profile Send private message
ndarlow
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2004
Posts: 89

PostPosted: Sun May 15, 2005 5:19 pm    Post subject: Reply with quote

You might try the following, it works for me with apache-2.0.54 and mod_php-5.0.3:

net-www/apache -threads mpm-prefork
dev-php/mod_php -berkdb -gdbm -threads bcmath calendar ctype kerberos memlimit posix session sharedmem tokenizer xsl
dev-php/php -berkdb -gdbm -threads bcmath calendar ctype kerberos memlimit posix session sharedmem tokenizer xsl

I believe the important flag is -threads and, of course, mpm-prefork for apache2.

Regards,
Neil Darlow
Back to top
View user's profile Send private message
sthneed
n00b
n00b


Joined: 07 Jul 2004
Posts: 8

PostPosted: Sun May 15, 2005 7:47 pm    Post subject: Reply with quote

Thanks, but it still doesn't work.

My problem is that I can't get apache to take the mpm-prefork use flag.

even if I do

USE="mpm-prefork" emerge -pv apache

I still get:

[ebuild R ] net-www/apache-2.0.54-r4 +berkdb -debug -doc +gdbm +ipv6 -ldap +ssl -static -threads 0 kB

the use flag just doesn't show up.

I tried to modify the ebuild but it caused a security violation because it changed the file size.

I may try to learn more about making ebuilds and try that again. Also I may try a manual compile to see if apache will take the --mpm-prefork flag that way.

I was just hoping someone could bail me out with a quick fix.

- sam

I
Back to top
View user's profile Send private message
aetherane
n00b
n00b


Joined: 15 May 2005
Posts: 3

PostPosted: Sun May 15, 2005 8:00 pm    Post subject: Reply with quote

Hmm looking on the gentoo-portage site shows me:
Code:
2.0.54-r5     ~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86
apache2 debug doc ldap mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker no-suexec ssl static-modules threads
2.0.54-r4    alpha ~amd64 ~arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86
berkdb gdbm ldap threads ipv6 doc static ssl debug
2.0.54-r3    ~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86
apache2 debug doc ldap mpm-leader mpm-peruser mpm-prefork mpm-threadpool mpm-worker no-suexec ssl static-modules threads

So, i'm thinking that r4 wasn't complete. -- will try upgrading to r5. When I emerge r5, it says mpm-prefork is highly experimental (probably why it wasn't in the r4 release which was more of a general release)
Back to top
View user's profile Send private message
ndarlow
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2004
Posts: 89

PostPosted: Sun May 15, 2005 8:24 pm    Post subject: Reply with quote

I'm currently using apache-2.0.54-r5. I'm pretty sure that I went through -r4 with mpm-prefork enabled.

I find it odd that prefork should be labelled experimental. It is, after all, the obvious choice for direct upgrade from apache-1.3.x.

Regards,
Neil Darlow
Back to top
View user's profile Send private message
aetherane
n00b
n00b


Joined: 15 May 2005
Posts: 3

PostPosted: Sun May 15, 2005 8:45 pm    Post subject: Reply with quote

Well, now that i'm on r5 it built. :D
Back to top
View user's profile Send private message
sthneed
n00b
n00b


Joined: 07 Jul 2004
Posts: 8

PostPosted: Mon May 16, 2005 1:42 pm    Post subject: Reply with quote

yep, worked for me when I did:

emerge "=apache-2.0.54-r1" mod_php

I guess -r4 was just crippled.

BTW, what's the link to the gentoo portage site?

- sam
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum