Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AmaroK and projectM [Solved... kind of]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sun May 15, 2005 6:51 am    Post subject: AmaroK and projectM [Solved... kind of] Reply with quote

Hello,

I saw a page on amaroK's WIKI about adding projectM to amaroK's visualisations. ProjectM is the linux implementation of the famous Milkdrop visualization for WinAMP. I found the ebuild for projectM in the bugzilla and emerged it. Unfortunately, no new visualizations became availiable :(

Did anyone achieve success in adding projectM visualizations to amaroK?
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734


Last edited by blaster999 on Sun Jul 24, 2005 7:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
hds
Advocate
Advocate


Joined: 21 Aug 2004
Posts: 2629
Location: Sprockhoevel [GER]

PostPosted: Sun May 15, 2005 9:44 am    Post subject: Reply with quote

are amaroKs "normal" visualisations working? if they dont work either, you need a recent version of libvisual.
media-libs/libvisual ~x86
media-plugins/libvisual-plugins ~x86
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sun May 15, 2005 9:53 am    Post subject: Reply with quote

hds,

Thanks for your reply. I already have the latest libvisual and libvisual-plugins, and in amaroK I have some visualizations, which work OK. Unfortunately, none of them reminds milkdrop. I tried to compile the latest projectM from source by hand (aka "Break the portage") - still amaroK doesn't see it. The funniest thing is that the test program that comes with projectM works just fine.

BTW, as I understand you succeeded in adding projectM's visualizations to amaroK. Could you tell what exactly steps did you perform?
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
hds
Advocate
Advocate


Joined: 21 Aug 2004
Posts: 2629
Location: Sprockhoevel [GER]

PostPosted: Sun May 15, 2005 10:10 am    Post subject: Reply with quote

blaster999 wrote:

BTW, as I understand you succeeded in adding projectM's visualizations to amaroK

no, i didnt have any visualizations at all, until i realized i need the most recent (~x86) libvisuals.

//edit: the wiki mentions you have to install projectM prior to libvisual, so maybe you re-emerge libvisual?
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sun May 15, 2005 10:21 am    Post subject: Reply with quote

I reemerged libvisual and libvisual-plugins, still I have only those default visualizations that come with libvisual :(

I've read on amaroK irc cahnnel that many gentooists had problems getting projectM to work with amaroK.
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
hds
Advocate
Advocate


Joined: 21 Aug 2004
Posts: 2629
Location: Sprockhoevel [GER]

PostPosted: Sun May 15, 2005 10:31 am    Post subject: Reply with quote

blaster999 wrote:
I reemerged libvisual and libvisual-plugins, still I have only those default visualizations that come with libvisual :(

what happens if you try to install libvisual manually? check with ./configure --help if there might be a configure option for projectM. perhaps the gentoo ebuild doesnt honor that flag (yet)?

//edit: just checked, no - there is no flag in libvisual.
anyway, i am getting to this in a few days.. like some eye candy as well )
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sun May 15, 2005 10:44 am    Post subject: Reply with quote

Ok, I'll wait and pray that you suceed in getting amaroK work with projectM :)
Thanks for help
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
hds
Advocate
Advocate


Joined: 21 Aug 2004
Posts: 2629
Location: Sprockhoevel [GER]

PostPosted: Sun May 15, 2005 10:50 am    Post subject: Reply with quote

oh, btw.. you are using a recent version of amaroK? perhaps this doesnt work with older versions at all..
i am using unstable headbranch here.. meanwhile you need to have subversion emerged to check this out.

OTOH you could have a look at the amaroK forum.. i am in there as well (same nick) ;)
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sun Jun 26, 2005 9:42 am    Post subject: Reply with quote

Hello hds,

I've installed amaroK 1.3 beta, still no luck with projectM :( The funniest thing is that the builtin demo works. It's not fair :(

Have you had any success in enabling projectM support in amaroK?
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Fri Jul 22, 2005 11:29 am    Post subject: Reply with quote

Hello hds,

I think I know the problem. When I compile the libvisual plugin, it writes
Code:

...
checking GL/gl.h usability... yes
checking GL/gl.h presence... yes
checking for GL/gl.h... yes
checking GL/glx.h usability... yes
checking GL/glx.h presence... yes
checking for GL/glx.h... yes
checking for glBegin in -lGL... no
...


but after that

Code:

checking whether to build lv_projectm plugin... yes
configure: WARNING: *** No OpenGL found.
projectm plugin will not be built.


I've NO idea how to fight with that issue though...
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
Noyan
Apprentice
Apprentice


Joined: 24 Mar 2005
Posts: 212

PostPosted: Fri Jul 22, 2005 4:41 pm    Post subject: Reply with quote

add opengl to ur USE

"configure: WARNING: *** No OpenGL found. "


and be sure u have working opengl.configure: WARNING: *** No OpenGL found.
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Fri Jul 22, 2005 6:27 pm    Post subject: Reply with quote

Noyan,

I compile projectM from sources (as the only ebuild is old and broken). There are strange issues with the configure script - it can't find the X headers, so I have to point to them via commandline option.
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
Noyan
Apprentice
Apprentice


Joined: 24 Mar 2005
Posts: 212

PostPosted: Fri Jul 22, 2005 7:14 pm    Post subject: Reply with quote

blaster999 wrote:
Noyan,

I compile projectM from sources (as the only ebuild is old and broken). There are strange issues with the configure script - it can't find the X headers, so I have to point to them via commandline option.




can u send me a link to source?

and i said compile libvisual with opengl flag.Not projectM
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sat Jul 23, 2005 7:15 am    Post subject: Reply with quote

Sources are located here: http://sourceforge.net/project/showfiles.php?group_id=104201
The official web site: http://xmms-projectm.sourceforge.net

BTW

Code:

emerge -av libvisual

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-libs/libvisual-0.2.0  -static 0 kB

libvisual doesn't have opengl USE flag
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
fRIOUX
n00b
n00b


Joined: 13 Jul 2005
Posts: 21

PostPosted: Sat Jul 23, 2005 10:48 am    Post subject: Reply with quote

Hey,
I just downloaded the source (.97) and got it to work first try, but I took a different route than you did...
Try to compile the Xmms compatible version and then enable the amarok-xmms viz stuff (+xmms) when you compile amarok. It should work perfectly. It did for me. (Dude! This is freaking gorgeous!)
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sun Jul 24, 2005 7:30 am    Post subject: Reply with quote

fRIOUX,

Thanks!!! It works! Incredible!

You rule!
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum