Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Slowdowns with CD-Rom
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
EhobaX
n00b
n00b


Joined: 12 May 2002
Posts: 25
Location: DC

PostPosted: Sun May 26, 2002 4:58 pm    Post subject: Slowdowns with CD-Rom Reply with quote

Hi,

It seems that everytime my system uses my CD-Rom there is a noticeable slowdown in performance. i.e. Mouse movement becomes choppy, typing in a xterm becomes sluggish. It's a 40x CD-Rom and works fab in other distros of Linux (Mandrake 8.2, Redhat 7.2). I was wondering if there was some way I could tweak the performance so that it would start acting normal again! I'd really hate to ditch this distro just because of hardware. :p

Thanks!
Back to top
View user's profile Send private message
mb
Guru
Guru


Joined: 25 Apr 2002
Posts: 355
Location: Hessen | .de

PostPosted: Tue May 28, 2002 7:47 am    Post subject: Reply with quote

sounds like no dma support...

check
Code:
hdparm -d1 /dev/hd?

where "?" is your cdrom device... you also should do the same with your ide harddisks...

you *may* enable dma support in kernel... but hdparm will tell you..


#mb
Back to top
View user's profile Send private message
EhobaX
n00b
n00b


Joined: 12 May 2002
Posts: 25
Location: DC

PostPosted: Tue May 28, 2002 12:25 pm    Post subject: Hrmm. Reply with quote

On bootup I think the CD-Rom uses PIO. I'm not 100% sure since I'm at work right now. :(

Can I put hdparm for my CD-Rom in /etc/rc.local to have it use DMA? I've done it with my HD already and have seen a marginal increase. If that's not an option, where the bloody hells is it in the menuconfig? :)
Back to top
View user's profile Send private message
mb
Guru
Guru


Joined: 25 Apr 2002
Posts: 355
Location: Hessen | .de

PostPosted: Tue May 28, 2002 1:30 pm    Post subject: Reply with quote

yep... there must be a file called local.start somewhere in /etc

if you have done this for your HD, dma support seems to be in the kernel... otherwise

ATA/IDE/MFM/RLL support -> IDE, ATA and ATAPI Block devices -> Generic PCI bus-master DMA support [*]


#mb
Back to top
View user's profile Send private message
EhobaX
n00b
n00b


Joined: 12 May 2002
Posts: 25
Location: DC

PostPosted: Tue May 28, 2002 3:18 pm    Post subject: Reply with quote

Thanks mb,

I'll get cracking on that when I get some time. Work is going to kill me this week. :p
Back to top
View user's profile Send private message
EhobaX
n00b
n00b


Joined: 12 May 2002
Posts: 25
Location: DC

PostPosted: Thu May 30, 2002 3:25 am    Post subject: Reply with quote

Ok. I recompiled the kernel just to see if everything was installed correctly. I've got that option that mb suggested, but my CD-Rom is still sucking wind in Gentoo.

I did hdparm -c 1 -d 1 /dev/cdrom/cdrom0 and everything seemed peachy.

When I do hdparm -tT /dev/cdrom/cdrom0 my output is:

Code:
Time buffer cache reads:  128 MB in 0.90 seconds = 141.18 MB/s
Time buffered disk reads:  64 MB in 19.90 seconds = 3.22 MB/s


I don't know about the rest of you but that sucks for the seconds one! I've tried using hdparm -X to change the modes, but I can only set it up to mdma2. It doesn't like udma and spits out this error message:

Code:
setting xfermode to 65 (UltraDMA mode 1)
HDIO_DRIVE_CMD(setxfermode) failed:  input/output error


Does anyone know how to resolve this? Like I said before, it works like a champ in other distros. I just can't seem to understand it. :p


Last edited by EhobaX on Thu May 30, 2002 12:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Thu May 30, 2002 8:17 am    Post subject: Reply with quote

yeah i feel your pain...i ahve the same issue adn have posted about it but necver did find anything to do...my drive is seen as udma4 and i get pretty piss poor performance...ripping a cd is kinda funny...i bought a tdk 40x cdrw the other day and on the box it says rip and audio track in 5 seconds...lol...i dont think so


/dev/hda:

Model=Pioneer DVD-ROM ATAPIModel DVD-106S 010, FwRev=E1.09, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=13395, BuffSize=64kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: sdma0 sdma1 sdma2 mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 *udma4
AdvancedPM=no
Drive Supports : Reserved : ATA-1 ATA-2 ATA-3 ATA-4 ATA-5

then i set dma and 32bit mode

/dev/hda:
setting 32-bit I/O support flag to 1
setting using_dma to 1 (on)
I/O support = 1 (32-bit)
using_dma = 1 (on)

and ended up with this

/dev/hda:
Timing buffer-cache reads: 128 MB in 0.56 seconds =228.57 MB/sec
Timing buffered disk reads: 64 MB in 21.42 seconds = 2.99 MB/sec
Back to top
View user's profile Send private message
EhobaX
n00b
n00b


Joined: 12 May 2002
Posts: 25
Location: DC

PostPosted: Thu May 30, 2002 3:02 pm    Post subject: Reply with quote

Bah! I should just go back into the menuconfig and check everything that includes IDE and DMA support. Either that, I'm going back to Mandrake. It was pretty user friendly, and I can trim down the bloat by not installing the packages and recompiling the kernel.
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Thu May 30, 2002 9:26 pm    Post subject: Reply with quote

do you remember what hdparm was giving you when you ran mandrake?....for the cdrom or dvd you were using on it then...i am getting the same performance from a similar dvd player under freebsd...but that and gentoo are all i ahve installed right now

edit: looking over menuconfig again like you suggested i came across the Ignore word93 Validation bits option under the IDE/ATA/MFM/RLL support section....i dont know if this would help or not but i might recompile and see if it does...although it might create issues...lol
Back to top
View user's profile Send private message
lx
Veteran
Veteran


Joined: 28 May 2002
Posts: 1012
Location: Netherlands

PostPosted: Thu May 30, 2002 10:26 pm    Post subject: Reply with quote

rommel wrote:
...ripping a cd is kinda funny...i bought a tdk 40x cdrw the other day and on the box it says rip and audio track in 5 seconds...lol...i dont think so

Ripping of audio is different frow 40x reading a cdrom, look for example at
http://www.feurio.com/English/cd_roms/frame_list_ide_speed.html
Some are beter than others, also in audio error recovery plextor is one of the best out there, you might want to get one with c2error correction, then you can also check if the read audio in burst mode is actually correct. (readcd in linux supports this but mixes the audio with this data after every sector).

:( Well if I miss anything about Window$ it is feurio, luckely I have wine.
_________________
"Remember there's a big difference between kneeling down and bending over.", Frank Zappa
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Fri May 31, 2002 2:59 am    Post subject: Reply with quote

lol...you could have saved yourself the post,i am not a genius but i think thazt much i understand...but the quote on the box is still the same brainiac...lol...now do you know how to solve the problem that originally started this post?
Back to top
View user's profile Send private message
EhobaX
n00b
n00b


Joined: 12 May 2002
Posts: 25
Location: DC

PostPosted: Fri May 31, 2002 1:55 pm    Post subject: Reply with quote

LOL. I installed Mandrake and got the same performance using hdparm. However, I checked the options when i used make menuconfig for it and it had just about EVERY option checked in the IDE/DMA options. BUT, I don't get the ghetto slowdown of my CD-Rom when running proggies from the CD.

I don't know if I'm going to have time to install Gentoo anymore since I'm going to be losing my broadband this weekend due to a move. DAMN THE PHONE COMPANIES! Oh well. I might be able to whore one of my friends fat pipe later down the road. If you get fast performance after your recompile rommel, I'd like to know. :)
Back to top
View user's profile Send private message
gboyce
n00b
n00b


Joined: 18 Apr 2002
Posts: 22
Location: Lynn, MA

PostPosted: Fri May 31, 2002 3:10 pm    Post subject: Check your kernel Reply with quote

If your IDE devices keep going into PIO mode, check your kernel configuration options.

Under IDE settings, there's an option called "Enable DMA only for disks". The wording of this is a little tricky. It sounds as if you should enable this option if you always want your harddrive to be in DMA mode, but it actually means that DMA should only be enabled on disks, not other IDE devices.

If you have this option enabled, you'll experiance problems like you're reporting.
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1140
Location: Williamsburg Virginia

PostPosted: Sat Jun 01, 2002 3:19 am    Post subject: Reply with quote

lol...that sucks about you loosing your connection...god i fukin hate dialup...and i dont think i would give up gentoo...i am running freebsd too....thats really similar but gentoo is more cutting edge and IT HAS NVIDIA DRIVERS..well all linux does but you know.

gboyce its not that...i never select that option...but thanks for the suggestion...newaz...well nothing in my system suffers from this other then riping is a bit slow....but like dvd play back and even burning isnt too bad...suppose it will never be like windows but i can always hope...lol

ciao
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum