Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdevelop crashes after upgrade to KDE 3.0.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mkb137
n00b
n00b


Joined: 13 May 2002
Posts: 33
Location: Calgary, Canada

PostPosted: Sun May 26, 2002 2:16 pm    Post subject: kdevelop crashes after upgrade to KDE 3.0.1 Reply with quote

I just "emerged --update world" which included an upgrade to KDE3.0.1 and a few miscellaneous files. After the update, KDevelop now crashes on "Autoconf and automake". Other things (configure, make, etc.) work OK. A rebuild of KDevelop and Autoconf didn't fix the problem. Here's the output from the crash handler "backtrace":

from /usr/qt/3/lib/libqt-mt.so.3
#23 0x40d8e364 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#24 0x409fc995 in KApplication::notify () from /usr/kde/3/lib/libkdecore.so.4
#25 0x40d3b073 in qt_set_socket_handler () from /usr/qt/3/lib/libqt-mt.so.3
#26 0x40d3b837 in QApplication::processNextEvent ()
from /usr/qt/3/lib/libqt-mt.so.3
#27 0x40d8f965 in QApplication::enter_loop () from /usr/qt/3/lib/libqt-mt.so.3
#28 0x40d3b0e6 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#29 0x0811d399 in CToolClass::writeToolConfig ()
#30 0x4138c3c1 in __libc_start_main () from /lib/libc.so.6

Any ideas?
Back to top
View user's profile Send private message
mvo
n00b
n00b


Joined: 16 Apr 2002
Posts: 49
Location: Frankfurt/Germany

PostPosted: Sun May 26, 2002 7:44 pm    Post subject: Reply with quote

I have the same problem.
I think it's a problem with the new autoconf 2.53. If you run autoconf from comandline, you get errors like this:

configure.in:117: error: m4_popdef: undefined macro: AC_Dest
../autoconf/status.m4:831: AC_CONFIG_FILES is expanded from...
configure.in:117: the top level

I fixed this by manually editing configure.in (create a new project and compare the last lines of an old configure.in with a new one to see how), but after that other things are broken :(.
Back to top
View user's profile Send private message
mkb137
n00b
n00b


Joined: 13 May 2002
Posts: 33
Location: Calgary, Canada

PostPosted: Mon May 27, 2002 9:37 pm    Post subject: Reply with quote

Yeah, you're right. Masking the 2.53 Autoconfs, unmerging autoconf, then re-emerging it (as a 2.52 version) makes it work again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum