Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ATI Driver prolbems (No OpenGL)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shredder
n00b
n00b


Joined: 22 Nov 2004
Posts: 47

PostPosted: Sat Jul 23, 2005 2:51 pm    Post subject: ATI Driver prolbems (No OpenGL) Reply with quote

Hi,

i changed my good working, but old, GeForce card to a not so good working ATI Radeon 9800. I followed this howto: http://gentoo-wiki.com/HOWTO_ATI_Drivers. Everything seemed to work but this is the output from fglrxinfo
Code:
fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
No ATI in neither the renderer or vendor string.
Since UseInternalAGPGART "yes" does not work, on my computer, iam loading loading the following modules:
Code:
agpgart
sis-agp
fglrx
But iam not sure if sis-agp is the right one, when i run dmesg | grep agp (to find out which -agp driver to run) i get the following output:
Code:
# dmesg | grep agp
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected SiS 646 chipset
agpgart: AGP aperture is 64M @ 0xe0000000
Is sis-agp the right -agp module for me?

I also ran
Code:
# cat /var/log/Xorg.0.log | grep \(EE\)
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(EE) Error loading keymap /usr/lib/X11/xkb/compiled/server-0.xkm
To see if there was any interesting errors in the log, and there seems to be a problem with agp ;)

Tell me if you want to look att x-config or know anything else, iam running a P4 btw.
Back to top
View user's profile Send private message
Noyan
Apprentice
Apprentice


Joined: 24 Mar 2005
Posts: 212

PostPosted: Sat Jul 23, 2005 3:08 pm    Post subject: Reply with quote

$uname -a,


(cuz 2.6.12 ati-drivers broken.)
Back to top
View user's profile Send private message
shredder
n00b
n00b


Joined: 22 Nov 2004
Posts: 47

PostPosted: Sat Jul 23, 2005 3:19 pm    Post subject: Reply with quote

Well iam using 2.6.12-r4 (Gentoo-sources) and i think i read that there is kernel patches included inte the ati-driver(From portage) and when i emerged ati-driver it did apply some kernel pathces.
But maybe i got it all wrong and have to wait.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum