Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Корректное удаление ethernet-интерфеса...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Plastikman14
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 137

PostPosted: Fri May 06, 2005 3:14 pm    Post subject: Корректное удаление ethernet-интерф Reply with quote

Приветствую всех! Вытащил за ненадобностью из компа 2-ю сетевую карту. Но при загрузке система ругается, что интерфейс не обнаружен. Как правильно его удалить, чтобы система перестала его видеть...Спасибо.
Back to top
View user's profile Send private message
hermes_jr
l33t
l33t


Joined: 26 Feb 2004
Posts: 701
Location: Moscow, Russia

PostPosted: Fri May 06, 2005 3:22 pm    Post subject: Reply with quote

Гы, на поведение виндов смахивает :)
По идее если ненужные модули из /etc/modules.autoload.d/kernel-2.X удалены и из /etc/conf.d/net убрано всё, что связано с этим интерфейсом, то больше о нём система вспомнить не должна.
А какое именно ругательство она произносит? Может просто в конфиге какойнить проги осталось что-то связанное с несуществующим интерфейсом, например iptables при старте не может прописать правила или ещё что-то.
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Fri May 06, 2005 11:34 pm    Post subject: Reply with quote

Думаю дело просто в том, что запускается /etc/init.d/net.ethX и ругается, что интерфейса нет. Просто rc-update del net.ethX. Покажи хотя бы примерно ошибку.
Back to top
View user's profile Send private message
Plastikman14
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 137

PostPosted: Sat May 07, 2005 9:22 pm    Post subject: Reply with quote

YD wrote:
Думаю дело просто в том, что запускается /etc/init.d/net.ethX и ругается, что интерфейса нет. Просто rc-update del net.ethX. Покажи хотя бы примерно ошибку.



root@tux plastikman # /etc/init.d/net.eth1 start
* Please make sure that /etc/conf.d/net has $ifconfig_eth1 set
* (or $iface_eth1 for old-style configuration)

Сдаётся мне, что ты прав... Благодарю.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum