Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200505-02 ] Oops!: Remote code execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu May 05, 2005 10:49 pm    Post subject: [ GLSA 200505-02 ] Oops!: Remote code execution Reply with quote

Gentoo Linux Security Advisory

Title: Oops!: Remote code execution (GLSA 200505-02)
Severity: high
Exploitable: remote
Date: May 05, 2005
Bug(s): #91303
ID: 200505-02

Synopsis

The Oops! proxy server contains a remotely exploitable format string vulnerability, which could potentially lead to the execution of arbitrary code.

Background

Oops! is an advanced, multithreaded caching web proxy.

Affected Packages

Package: net-proxy/oops
Vulnerable: < 1.5.24_pre20050503
Unaffected: >= 1.5.24_pre20050503
Architectures: All supported architectures


Description

A format string flaw has been detected in the my_xlog() function of the Oops! proxy, which is called by the passwd_mysql and passwd_pgsql module's auth() functions.

Impact

A remote attacker could send a specially crafted HTTP request to the Oops! proxy, potentially triggering this vulnerability and leading to the execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All Oops! users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-proxy/oops-1.5.24_pre20050503"


References

CAN-2005-1121


Last edited by GLSA on Sun May 07, 2006 4:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum