Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PHP 5 когда решат проблему??? ХАЧУ PHP5 :-(
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Tue May 03, 2005 10:05 am    Post subject: PHP 5 когда решат проблему??? ХАЧУ PHP Reply with quote

Сабж. Блин - нужен PHP5, а делать ему unmask не хочется - не секьюрно... По-русски в чем там трабла-то?
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Tue May 03, 2005 10:17 am    Post subject: Reply with quote

Слишком свеженький, не набрал критической массы, чтобы стать хотя бы ~x86.
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Tue May 03, 2005 10:33 am    Post subject: Reply with quote

Да нее, там какие-то траблы с апачей были .... Работал ж нормально и работает (кое-где у меня).
Back to top
View user's profile Send private message
ManJak
Guru
Guru


Joined: 18 Dec 2004
Posts: 561
Location: St. Petersburg, Russia

PostPosted: Tue May 03, 2005 8:24 pm    Post subject: Reply with quote

Поймите меня правильно, против Генту ничего не имею против (самому нравится).

Но, помоему это развращает =))))

Когда под фрей жил, нифига не думал, что в портах нет =))))))))))))))))
Собрал ручками и вперед =)))))))))))))))))))))))

Это просто мысль в слух, т.к. сам грешен

https://bugs.gentoo.org/show_bug.cgi?id=88811

И Жду ebuild =)
(Хотя, временно собрал, в сторонке)
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Wed May 04, 2005 6:32 am    Post subject: Reply with quote

аналогично - собрал - но мучает вопрос - а вдруг ......
Back to top
View user's profile Send private message
Balancer
Guru
Guru


Joined: 04 Jun 2004
Posts: 465

PostPosted: Fri May 06, 2005 6:58 pm    Post subject: Reply with quote

PHP5 успешно работает на "боевом" сервере (до 200 запросов в секунду в пике) уже несколько месяцев. При чём не только как mod_php в apache2, но и как fcgi под lighttpd.
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Thu May 12, 2005 6:57 am    Post subject: Reply with quote

Ну дело за малым - сделать его анмаск ;)
Back to top
View user's profile Send private message
WI
n00b
n00b


Joined: 27 Jan 2005
Posts: 53

PostPosted: Thu May 12, 2005 11:16 am    Post subject: Re: PHP 5 когда решат проблему??? ХАЧУ Reply with quote

rusxakep wrote:
Сабж. Блин - нужен PHP5, а делать ему unmask не хочется - не секьюрно... По-русски в чем там трабла-то?


ИМХО Вы путаете секьюрность ("годен для меня") с тривиальной маской пакета ("годен для гентоо"). Маски - последнее что меня интересует в работоспособном пакете. Тем паче что и в немаскированных пакетах дыры находят.

Боишься - не делай, сделал - не бойся :)
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Thu May 12, 2005 1:07 pm    Post subject: Reply with quote

Мне кажется просто так - пакет не маскят. Ладно - вопрос исчерпан, мне кажется.
Back to top
View user's profile Send private message
hlroad
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 105

PostPosted: Wed May 18, 2005 7:49 am    Post subject: Reply with quote

Для тех, кто в танке. Обычно когда пакет маскируют, то указывают причину. Если вы таки на emerge "наедете" - он вам её опишет.

Code:

# emerge -pv =mod_php-5*

These are the packages that I would merge, in order:

!!! All ebuilds that could satisfy "=mod_php-5*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-php/mod_php-5.0.4 (masked by: package.mask, ~x86 keyword)
# Stuart Herbert <stuart@gentoo.org> (12th march 2005)
# automatically activates ZTS mode when any threaded MPMs are installed,
# even if mpm_prefork is the default

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.

Code:

# emerge -pv =php-5*

These are the packages that I would merge, in order:

Calculating dependencies
!!! All ebuilds that could satisfy "=php-5*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-php/php-5.0.3-r1 (masked by: ~x86 keyword)
- dev-php/php-5.0.2-r1 (masked by: ~x86 keyword)
- dev-php/php-5.0.0 (masked by: -x86 keyword)
- dev-php/php-5.0.1 (masked by: ~x86 keyword)
- dev-php/php-5.0.2 (masked by: ~x86 keyword)
- dev-php/php-5.0.3 (masked by: ~x86 keyword)
- dev-php/php-5.0.0-r1 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.

Видно, что всё просто: php-5 (который CGI) просто не оттестирован пока, mod_php-5 собирается криво с точки зрения авторов gentoo. Если про проблему знать (собрать php с ZTS или выключить все MPM, кроме mpm_prefork), то всё работать будет, но подкладывать такую свинью всем пользователям Gentoo они пока не решаются. У меня - работает уже давно.

Добавление: зайдя сюды хлопнул себя по лбу: ведь пакет нельзя объявить стабильным пока хоть что-нибудь, от чего он зависит нестабильно! А PHP тянет с собой тучу зависимостей - почти 50 пакетов... И пока все они не будут объявлены стабильными "кина не будет".
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Wed May 18, 2005 11:18 am    Post subject: Reply with quote

То есть - правильно я понял. Что при сборке апача надо указывать только mpm-prefork, а остальные mpm в -.
А что за ZTS?
Back to top
View user's profile Send private message
hlroad
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 105

PostPosted: Wed May 18, 2005 6:27 pm    Post subject: Reply with quote

rusxakep wrote:
То есть - правильно я понял. Что при сборке апача надо указывать только mpm-prefork, а остальные mpm в -.
А что за ZTS?

Zend Thread Safety: экспериментальный режим для multithreaded серверов (в частности для всех MPM кроме mpm-prefork). С ним несовметима изрядная часть extension'ов и, главное, если собрать mod_php с ZTS, а php - без ZTS (или наоборот), то PEAR будет использовать затруднительно.
Back to top
View user's profile Send private message
ksv
n00b
n00b


Joined: 18 May 2005
Posts: 6
Location: Minsk, Belarus

PostPosted: Mon May 23, 2005 2:06 pm    Post subject: Reply with quote

Подскажите, как решить проблему. Я новичек в gentoo.
На домашний дервер хочу поставить PHP5 (в основном ради библиотеки tidy для парсинга HTML, эта библиотечка идет начиная с 5й версии).

Пытаюсь ставить mod_php 5.0.4, а он гад требует Apache 1.3 и пытается его установить. Но мне то нужен для apache2! Как его переучить?

И еще вопрос. В документации по php 5 сказано, что его надо компилировать с флажком --with-tidy. Как это грамотно сделать в gentoo?

И последнее: в php5 написано, что лучше ставить mysql Версии 4.1.x, т.к. для него реализован новый интерфейс.
Поставил 4.1.12 без проблем (требования безопасности позволяют ставить любые masked пакеты). Ожидают ли какие-нибудь проблемы при компиляции php5 для работы с mysql 4.1.x? Как это грамотно сделать? Нужны ли какие-нибудь use флаги, или все будет сделано по-дефолту?
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Mon May 23, 2005 2:39 pm    Post subject: Reply with quote

ksv wrote:
Но мне то нужен для apache2! Как его переучить?

Установить флажок apache2.

ksv wrote:
И еще вопрос. В документации по php 5 сказано, что его надо компилировать с флажком --with-tidy. Как это грамотно сделать в gentoo?

Используй emerge -pv mod_php, чтобы посмотреть все возможные флаги, которые понимает 5-ый mod_php.
Тебе также стоит прочитать man emerge portage. Да, mod_php и просто php в gentoo не одно и тоже, это надо иметь ввиду.

Что касается проблем --- не ожидаются. Если нарвешся на что-нить, приходи. Только новый топик заводи для своей проблемы.
Back to top
View user's profile Send private message
hlroad
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 105

PostPosted: Mon May 23, 2005 2:45 pm    Post subject: Reply with quote

ksv wrote:
Пытаюсь ставить mod_php 5.0.4, а он гад требует Apache 1.3 и пытается его установить. Но мне то нужен для apache2! Как его переучить?

USE="apache2"

ksv wrote:

И еще вопрос. В документации по php 5 сказано, что его надо компилировать с флажком --with-tidy. Как это грамотно сделать в gentoo?

USE=tidy

ksv wrote:

И последнее: в php5 написано, что лучше ставить mysql Версии 4.1.x, т.к. для него реализован новый интерфейс.
Поставил 4.1.12 без проблем (требования безопасности позволяют ставить любые masked пакеты). Ожидают ли какие-нибудь проблемы при компиляции php5 для работы с mysql 4.1.x? Как это грамотно сделать? Нужны ли какие-нибудь use флаги, или все будет сделано по-дефолту?

Если ты про mysqli, то увы... Ничего не будет сделано по дефоту: в большом форуме как раз сейчас обсуждается куда напильник прикладывать чтобы mysqli получить. Чего вдруг народ так возжаждал mysqli ? Полгода никому не нужен был - тут на тебе. Может и мне поставить попробовать...
Back to top
View user's profile Send private message
hlroad
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 105

PostPosted: Mon May 23, 2005 2:48 pm    Post subject: Reply with quote

viy wrote:
Что касается проблем --- не ожидаются. Если нарвешся на что-нить, приходи. Только новый топик заводи для своей проблемы.
Ну если правка нескольких файлов включая ebuild'ы и eclass'ы - это не проблема, то что тогда проблема ??? Я на это так посмотрел грустно и пока собрал без mysqli ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum