Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with thundbird and local SASL->Postfix server
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
dgrant
Apprentice
Apprentice


Joined: 28 May 2003
Posts: 158
Location: Vancouver, BC, Canada

PostPosted: Sun May 01, 2005 5:22 am    Post subject: Problems with thundbird and local SASL->Postfix server Reply with quote

Hi,

I am trying to set up a mail setup as follows:

Sending:
Email Client->Cyrus-SASL->Postfix ->Internet

Receiving:
Internet->Postfix->Procmail->Courier-IMAP->Email Client

I followed the instructions at http://gentoo-wiki.com/HOWTO_Email_System_for_the_Home_Network.

-Receiving seems to be working just fine so far.

Sending mail works with sylpheed and kmail. But it doesn't work with thunderbird. I haven't figured out if it is just a Thunderbird issue or a server issue, even though everything seems to point at a thunderbird issue right now.

My sylpheed account settings are:
Send tab:
SMTP authentication (SMTP AUTH): checked
Authentication method: automatic
SSL tab:
Send (SMTP): Use STARTTLS command to start SSL session

My Kmail account settings are:
General tab:
Server requires authentication: checked
Security tab:
Encryption: TLS
Authentication Method: PLAIN

My thunderbird smtp settings are:
port: 25
use username and password: checked
use secure connection: TLS is checked

With thunderbird I get the following error when sending:

Apr 30 22:06:43 sonata postfix/smtpd[22798]: SSL3 alert read:fatal:bad certificate
Apr 30 22:06:43 sonata postfix/smtpd[22798]: SSL_accept:failed in SSLv3 read client certificate A
Apr 30 22:06:43 sonata postfix/smtpd[22798]: SSL_accept error from sonata[127.0.0.1]: 0
Apr 30 22:06:43 sonata postfix/smtpd[22798]: 22798:error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate:s3_pkt.c:1052:SSL alert number 42:

With KMail and Sylpheed, sending messages through my local smtp server works. They both ask me for a password too, but thunderbird doesn't.

I might try creating a brand new profile, to see if that helps. Or I might try the most recent version of Mozilla Mail.

David
Back to top
View user's profile Send private message
Cybersorcerer
Apprentice
Apprentice


Joined: 30 Mar 2004
Posts: 193
Location: somewhere over the rainbow

PostPosted: Sun Aug 21, 2005 4:54 pm    Post subject: Thunderbird postfix TLS Reply with quote

Hi dgrant,

did you ever resolve this ? Have the same issue with the latest thunderbird version.
_________________
greetings

Cybersorcerer
--
Too old to die young

Dell Precision M90, Intel Centrino Duo T2700 @ 2.33GHz running Jackass! 2006.2
Back to top
View user's profile Send private message
sander2
n00b
n00b


Joined: 21 Dec 2003
Posts: 21

PostPosted: Wed Sep 28, 2005 1:25 am    Post subject: Reply with quote

hi!

i have the same problem.. any more ideas?

thanks!
Back to top
View user's profile Send private message
dgrant
Apprentice
Apprentice


Joined: 28 May 2003
Posts: 158
Location: Vancouver, BC, Canada

PostPosted: Wed Sep 28, 2005 2:50 am    Post subject: Reply with quote

I still haven't found a solution. My only solution for now is to use anything other than Thunderbird. KMail and sylpheed-claws work, as well as Evolution.
Back to top
View user's profile Send private message
dgrant
Apprentice
Apprentice


Joined: 28 May 2003
Posts: 158
Location: Vancouver, BC, Canada

PostPosted: Wed Sep 28, 2005 2:50 am    Post subject: Reply with quote

KMail is a great client by the way. It's actually made me start liking KDE!
Back to top
View user's profile Send private message
sander2
n00b
n00b


Joined: 21 Dec 2003
Posts: 21

PostPosted: Wed Sep 28, 2005 2:52 am    Post subject: it magic! =) Reply with quote

:D

i found a solution:

go to thunderbird tools->options->advanced->manage certificates

click on Import and import the /etc/ssl/postfix/server.crt manually.

after that i got asked for the password when sending a mail (that didnt happen before) and sending works now!

it seems to be a bug with thunderbird. tomorrow i will try configuring kmail.

good night!
Back to top
View user's profile Send private message
sander2
n00b
n00b


Joined: 21 Dec 2003
Posts: 21

PostPosted: Wed Sep 28, 2005 2:54 am    Post subject: Reply with quote

dgrant wrote:
KMail is a great client by the way. It's actually made me start liking KDE!


me loves kmail (and kde) too! but IMHO thunderbird is the best mailclient for windows. :D
Back to top
View user's profile Send private message
dgrant
Apprentice
Apprentice


Joined: 28 May 2003
Posts: 158
Location: Vancouver, BC, Canada

PostPosted: Wed Sep 28, 2005 5:09 am    Post subject: Reply with quote

Actually I lied, I use Thunderbird at work (on Windows).

I agree, Thunderbird is the best IMAP client for Winblows.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum