Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
slow usb storage device
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
skunk
l33t
l33t


Joined: 28 May 2003
Posts: 646
Location: granada, spain

PostPosted: Wed Apr 27, 2005 2:12 pm    Post subject: slow usb storage device Reply with quote

hello!

my new iriver ifp-899 flash mp3 player (recently flashed with lastest ums firmware) which should be usb2 compliant isn't recognized as such by the kernel:
Code:
usb 2-1: new full speed USB device using ohci_hcd and address 2
usb 2-1: not running at top speed; connect to a high speed hub
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
ohci_hcd 0000:0d:00.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
  Vendor: iriver    Model: MassStorage Disc  Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sda: 2048001 512-byte hdwr sectors (1049 MB)
sda: Write Protect is off
sda: Mode Sense: 45 00 00 08
sda: assuming drive cache: write through
SCSI device sda: 2048001 512-byte hdwr sectors (1049 MB)
sda: Write Protect is off
sda: Mode Sense: 45 00 00 08
sda: assuming drive cache: write through
 /dev/scsi/host1/bus0/target0/lun0:
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi1, channel 0, id 0, lun 0,  type 0
usb-storage: device scan complete

Code:
T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=4102 ProdID=1108 Rev= 0.01
S:  Manufacturer=iRiver Limited.
S:  Product=iRiver Internet Audio Player IFP-800
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms

as you can see it uses the ohci_hcd instead of the ehci_hcd kernel module...
i've tried to remove the ohci_hcd module, but then the player isn't detected at all...
my dvd burner instead is correctly recognized as a high speed device.
is there a way to force it as a high speed device?

thank you!

ps: no, i don't have CONFIG_BLK_DEV_UB enabled
Back to top
View user's profile Send private message
viperlin
Veteran
Veteran


Joined: 15 Apr 2003
Posts: 1318
Location: UK

PostPosted: Mon Jan 09, 2006 2:30 am    Post subject: Reply with quote

ever find a cure? iHP120 still going slow here, just recently got pissed at it again and wonder if its fixable....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum