Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200504-14 ] monkeyd: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Fri Apr 15, 2005 4:42 pm    Post subject: [ GLSA 200504-14 ] monkeyd: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: monkeyd: Multiple vulnerabilities (GLSA 200504-14)
Severity: high
Exploitable: remote
Date: April 15, 2005
Updated: May 22, 2006
Bug(s): #87916
ID: 200504-14

Synopsis

Format string and Denial of Service vulnerabilities have been discovered in the monkeyd HTTP server, potentially resulting in the execution of arbitrary code.

Background

monkeyd is a fast, efficient, small and easy to configure web server for Linux.

Affected Packages

Package: www-servers/monkeyd
Vulnerable: < 0.9.1
Unaffected: >= 0.9.1
Architectures: All supported architectures


Description

Tavis Ormandy of the Gentoo Linux Security Audit Team discovered a double expansion error in monkeyd, resulting in a format string vulnerability. Ciaran McCreesh of Gentoo Linux discovered a Denial of Service vulnerability, a syntax error caused monkeyd to zero out unallocated memory should a zero byte file be requested.

Impact

The format string vulnerability could allow an attacker to send a specially crafted request to the monkeyd server, resulting in the execution of arbitrary code with the permissions of the user running monkeyd. The DoS vulnerability could allow an attacker to disrupt the operation of the web server, should a zero byte file be accessible.

Workaround

There is no known workaround at this time.

Resolution

All monkeyd users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/monkeyd-0.9.1"


References

CVE-2005-1122
CVE-2005-1123


Last edited by GLSA on Mon May 22, 2006 4:18 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum