Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB Flash проблема с монтированием
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Jekpol
Apprentice
Apprentice


Joined: 20 Feb 2004
Posts: 198

PostPosted: Thu Apr 14, 2005 11:10 am    Post subject: USB Flash проблема с монтированием Reply with quote

Есть проблема с монтированием флэшки. При вставленной флэшке появляется устройство /dev/sda, но нет sda1. Только если сделать команду mount -t vfat /dev/sda /mnt/flash (ругнется), а после mount -t vfat /dev/sda1 /mnt/flash только тогда появляется /dev/sda1 и монтируется. В чем могут быть грабли?
_________________
Главное не результат, а процесс.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Thu Apr 14, 2005 11:12 am    Post subject: Reply with quote

Хм... Может в hotplug дело?
Ты ведь на udev?
Back to top
View user's profile Send private message
Jekpol
Apprentice
Apprentice


Joined: 20 Feb 2004
Posts: 198

PostPosted: Thu Apr 14, 2005 11:14 am    Post subject: Reply with quote

Нет не на udev, стоит coldplug - загружается по boot
_________________
Главное не результат, а процесс.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Thu Apr 14, 2005 11:17 am    Post subject: Reply with quote

Мм...
hotplug у тебя точно есть (идет как зависимость для coldplug). Могу предположить, что его надо через /etc/init.d/hotplug start запускать (ну и rc-update add ...). Однозначно не скажу --- udev сам автоматом hotplug запускает при старте, у меня подобных проблем не бывает...
Back to top
View user's profile Send private message
Jekpol
Apprentice
Apprentice


Joined: 20 Feb 2004
Posts: 198

PostPosted: Thu Apr 14, 2005 11:23 am    Post subject: Reply with quote

Так в том то и дело, что устройство определяется правильно когда воткнешь, почему /dev/sda1 автоматом не добавляется?
_________________
Главное не результат, а процесс.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Thu Apr 14, 2005 11:27 am    Post subject: Reply with quote

Ну, за создание устройств отвечает devfsd в твоем случае (я полагаю что ты на нем живешь).
К сожалению детальней сказать, как его настроить я не могу --- не знаю. Попробуй сам поковырять конфиги.

Вот небольшое описание, посмотри.
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Thu Apr 14, 2005 12:12 pm    Post subject: Reply with quote

переходи на udev :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum