Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gtk+2.0.9 configure error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
_SkeLeToN_
Guru
Guru


Joined: 12 Sep 2002
Posts: 506
Location: Montreal,Canada

PostPosted: Wed Dec 04, 2002 6:37 am    Post subject: Gtk+2.0.9 configure error Reply with quote

Hi I recently emerge sync and found out there is a new gtk+ pacakge available. My problem is when I try to update to the version 2.0.9 I get an error on the configure part.

Code:

checking for x86 platform... yes
checking compiler support for MMX... yes
checking for freetype-config... /usr/bin/freetype-config
checking for FT_New_Face in -lfreetype... yes
checking For sufficiently new FreeType (at least 2.0.1)... yes
checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for XRenderFindFormat in -lXrender... yes
checking for XftFontOpen in -lXft... yes
checking X11/Xft/XftFreetype.h usability... no
checking X11/Xft/XftFreetype.h presence... no
checking for X11/Xft/XftFreetype.h... no
configure: error: pangoxft Pango backend found, but Xft not found

!!! ERROR: x11-libs/gtk+-2.0.9 failed.
!!! Function econf, Line 11, Exitcode 1
!!! econf failed


So I remember I change the Xft.h for an older version and maybe this is my problem. I unmerge xft-2.0 and re-emerge xft-2.0 and try back with the same result.

I did a search of XftFreetype.h and it found only this place
Code:

root@Atlas:~# locate XftFreetype.h
locate: warning: database `/var/spool/locate/locatedb' is more than 8 days old
/root/.Xft/XftFreetype.h


Any idea ?
Back to top
View user's profile Send private message
Device
n00b
n00b


Joined: 04 Dec 2002
Posts: 5

PostPosted: Wed Dec 04, 2002 9:44 am    Post subject: Reply with quote

what version do you have pango? pango-1.0.5?
i had got same error when i try upgrade gtk+
re-emerge xft and upgrade pango 1.1.x
Back to top
View user's profile Send private message
jjj
n00b
n00b


Joined: 03 Dec 2002
Posts: 23

PostPosted: Wed Dec 04, 2002 12:42 pm    Post subject: Reply with quote

hello,

I have the same problem as you and I reinstall XFree, then after some hours, I re-emerge gtk and it was ok ..
Back to top
View user's profile Send private message
_SkeLeToN_
Guru
Guru


Joined: 12 Sep 2002
Posts: 506
Location: Montreal,Canada

PostPosted: Thu Dec 05, 2002 3:04 am    Post subject: Reply with quote

Well I was able to emerge pango 1.1.x but now emerge want to go back to 1.0.5 of pango package before updating gtk+-2.0.9....


This is really odd ....
Back to top
View user's profile Send private message
Device
n00b
n00b


Joined: 04 Dec 2002
Posts: 5

PostPosted: Thu Dec 05, 2002 11:01 am    Post subject: Reply with quote

remove comment of pango from /usr/portage/profiles/package.mask
Back to top
View user's profile Send private message
BeetleJuice
n00b
n00b


Joined: 29 Apr 2002
Posts: 67
Location: Austria

PostPosted: Thu Dec 05, 2002 1:08 pm    Post subject: XftFreetype.h ... Reply with quote

I also have this annoying problem.
For some reason these header files in /usrX11/include/X11/Xft disappread. Now i had to rebuild pango without freetype-xft, which f*cked up all gtk-apps using pangoxft.

So my question: what packages in order do i have to emerge to get these damn header files? i re-emerged freetype2, xft, fontconfig etc., maybe it has something to do with xfree-4.2.1-r1?

thx
Back to top
View user's profile Send private message
_SkeLeToN_
Guru
Guru


Joined: 12 Sep 2002
Posts: 506
Location: Montreal,Canada

PostPosted: Thu Dec 05, 2002 3:53 pm    Post subject: Reply with quote

Device wrote:
remove comment of pango from /usr/portage/profiles/package.mask


Well it is uncomment ... I did emerge sync which overwrite the package.mask anyways and it still want to go back to 1.0.5

right now its like this in my package.mask
Code:

>=x11-libs/pango-1.1


I also have ACCEPT_KEYWORD comment in my make.conf ...

They really need to fix those problem ... they broke so much package with xft-2 anyways any idea ???

ps: I remember you can inject a package so emerge will stop asking for older version but in my case is it worth to try ??? I never inject a pacakge so not just also the right procedure ...
Back to top
View user's profile Send private message
BeetleJuice
n00b
n00b


Joined: 29 Apr 2002
Posts: 67
Location: Austria

PostPosted: Thu Dec 05, 2002 3:58 pm    Post subject: Reply with quote

Well I solved my little prob.

First unmerge xft2, its evil ;)
Then i re-emerged xfree 4.2.1-r1 which contained the Xft.h and XftFreetype.h.

You dont need pango1.1 for gtk-2.0.9, i used pango-1.0.5 and gtk-2.0.9 compiled fine.

emerging xft2 will overwrite the Xft.h from Xfree/freetype, so make a backup of these if you need them.
Back to top
View user's profile Send private message
_SkeLeToN_
Guru
Guru


Joined: 12 Sep 2002
Posts: 506
Location: Montreal,Canada

PostPosted: Thu Dec 05, 2002 6:56 pm    Post subject: Reply with quote

Thanks BettleJuice. I had to re emerge xfree to get the xft.h and the XftFreetype.h to compile gtk+ correctly .... I made a backup of those 2 files and re emerge xft2 ...

Thanks again
Back to top
View user's profile Send private message
Mnemia
Guru
Guru


Joined: 17 May 2002
Posts: 476

PostPosted: Fri Dec 06, 2002 6:27 am    Post subject: Reply with quote

I REALLY wish the freetype2 stuff would settle down. I'd be willing to recompile every GTK+ app I have if it would just work correctly in everything. Freetype2 seems to be a MAJOR improvement in text quality in the few places I've got it to work, so I wish it would work in everything. Am I correct in assuming that this will not really be possible until X 4.3 comes out in early January?
Back to top
View user's profile Send private message
KiTaSuMbA
Guru
Guru


Joined: 28 Jun 2002
Posts: 430
Location: Naples Italy

PostPosted: Fri Dec 06, 2002 11:57 pm    Post subject: Reply with quote

Code:
checking for pango_context_new in -lpango-1.0... no
configure: error:
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information see http://www.pango.org

!!! ERROR: x11-libs/gtk+-2.0.9 failed.
!!! Function econf, Line 11, Exitcode 1
!!! econf failed



argghhhh!!!!!
Now I've done it!
So is the only way to use xft2 and still upgrade gtk+ to
1)unmerge xft2
2)ricompile xfree
3)ricompile pango
4) upgrade gtk+
5)riemerge xft2
6)ricompile xfree with xft2
???
Damn! This is absurd... and HELL NO, I'm not going to spend the whole night playing around like that.
Unless I find the original .h files somewhere, back-up mine, put the originals in the dir, upgrade gtk+, back up those .h and put back mine... right?
Given that I do find these headers, would that work? As you can see my error is somewhat different although it still occurs on the same econf function
_________________
Need to flame people LIVE on IRC? Join #gentoo-otw on freenode!
Back to top
View user's profile Send private message
Mnemia
Guru
Guru


Joined: 17 May 2002
Posts: 476

PostPosted: Sat Dec 07, 2002 3:23 am    Post subject: Reply with quote

Yeah, i had a hell of a time getting it to work. Will this all be fixed automagically when the next major revision (4.3) of X is released? I sure hope so, because it's a royal pain right now. xft2 is wonderful when it works. But it's sure difficult to get it set up so it works on most things...
Back to top
View user's profile Send private message
foser
Retired Dev
Retired Dev


Joined: 28 Oct 2002
Posts: 154

PostPosted: Sat Dec 07, 2002 11:37 am    Post subject: Reply with quote

recompile xfree with xft2 ? you guys have obviously no idea what you're playing with (no offense). Anyway way i moved xft2 for gnome into testing, so if you want it get gnome-2.0.3-r1 .
_________________
Gentoo Gnome Desktop team
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum