Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TIP] fluxbox + utf8
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Thu Apr 07, 2005 12:05 pm    Post subject: [TIP] fluxbox + utf8 Reply with quote

Probabilmente lo sapete già però forse a qualcuno sarà utile..avete presente che se usate fluxbox con utf8 ci mette ore ad avviarsi?

questa patch risolve il problema
Code:

diff -ur fluxbox-0.9.12.orig/src/FbTk/Font.cc fluxbox-0.9.12/src/FbTk/Font.cc
--- fluxbox-0.9.12.orig/src/FbTk/Font.cc        2004-11-19 14:01:39.000000000 +0200
+++ fluxbox-0.9.12/src/FbTk/Font.cc     2004-12-24 19:19:46.015735856 +0200
@@ -293,7 +293,7 @@
     // create the right font implementation
     // antialias is prio 1
 #ifdef USE_XFT
-    if (antialias) {
+    if (antialias || m_utf8mode) {
         m_fontimp.reset(new XftFontImp(0, m_utf8mode));
     }
 #endif //USE_XFT


e così si applica:

bisogna salvare il codice in un file...flux_patch.diff, per esempio

poi si lancia
Code:

ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild unpack


nella dir /var/tmp/portage/fluxbox-0.9.12-r1/work/fluxbox-0.9.12/ e lanciare il comando

Code:
cat /dove_hai_messo_il_file_.diff/flux_patch.diff | patch -p1


poi
Code:

ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild compile

ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild install

e infine
Code:

ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild qmerge

_________________
fletto i muscoli...e sono nel vuoto


Last edited by Josuke on Thu Apr 07, 2005 1:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
ataraxic
n00b
n00b


Joined: 26 Sep 2004
Posts: 74
Location: Brescia

PostPosted: Thu Apr 07, 2005 12:08 pm    Post subject: Reply with quote

Interessante!

Scusa, ma come la applico questa patch?!:oops:
_________________
Le religioni sono come le lucciole: per brillare hanno bisogno del buio


Last edited by ataraxic on Thu Apr 07, 2005 6:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4295
Location: Venice Island, European Union

PostPosted: Thu Apr 07, 2005 12:51 pm    Post subject: Re: [TIP] fluxbox + utf8 Reply with quote

Josuke wrote:
Probabilmente lo sapete già però forse a qualcuno sarà utile..avete presente che se usate fluxbox con utf8 ci mette ore ad avviarsi?

Da me non ci mette ore ad avviarsi è iper istantaneo....
_________________
www.minimalblue.com
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Thu Apr 07, 2005 12:56 pm    Post subject: Reply with quote

e hai utf8? strano..forse nell'ultima versione di fluxbox hanno sistemato il problema
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Thu Apr 07, 2005 1:00 pm    Post subject: Reply with quote

ataraxic wrote:
Interessante!

Scusa, ma come la apolico questa patch?!:oops:


beh salvi il codice in un file...che so flux_patch.diff

poi lanci ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild unpack

vai nella dir /var/tmp/portage/fluxbox-0.9.12-r1/work/fluxbox-0.9.12/ e lanci il comando
cat /dove_hai_messo_il_file_.diff/flux_patch.diff | patch -p1

poi lanci ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild compile

ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild install e infine

ebuild /usr/portage/x11-wm/fluxbox/fluxbox-0.9.12-r1.ebuild qmerge
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4295
Location: Venice Island, European Union

PostPosted: Thu Apr 07, 2005 1:01 pm    Post subject: Reply with quote

Non è meglio mettersi l'ebuild in overlay e modificarlo per fargli prendere la patch? :roll:
_________________
www.minimalblue.com
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Thu Apr 07, 2005 1:19 pm    Post subject: Reply with quote

beh come uno vuole...io per provarla ho fatto così..ed ha funzionato...quindi si ora si potrebbe cambiare l'ebuild per fargli prendere la patch e metterlo in overlay....ma toglimi la curiosità di prima...a te parte senza problemi anche senza applicare la patch?
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Thu Apr 07, 2005 1:43 pm    Post subject: Reply with quote

@Josuke: hai volgia di mettere la procedura al primo post cosi' lo aggiungo ai post utilissimi?
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Thu Apr 07, 2005 1:49 pm    Post subject: Reply with quote

fatto
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Thu Apr 07, 2005 1:53 pm    Post subject: Reply with quote

Josuke wrote:
fatto

Aggiunto ai post utilissimi sezione howto
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ataraxic
n00b
n00b


Joined: 26 Sep 2004
Posts: 74
Location: Brescia

PostPosted: Thu Apr 07, 2005 2:36 pm    Post subject: Reply with quote

Scusate la domanda stupida, ma è da poco che sono passato a fluxbox (prima usavo kde): come faccio a impostare UTF8 (a prescindere dalla patch!!) ??!:?
_________________
Le religioni sono come le lucciole: per brillare hanno bisogno del buio
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Thu Apr 07, 2005 4:00 pm    Post subject: Reply with quote

prova a guardare questo post:

https://forums.gentoo.org/viewtopic-t-298829-highlight-utf8.html
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
ataraxic
n00b
n00b


Joined: 26 Sep 2004
Posts: 74
Location: Brescia

PostPosted: Thu Apr 07, 2005 6:43 pm    Post subject: Reply with quote

Ti ringrazio Josuke!!!

Ho seguito l'howto e in effetti fluxbox non si caricava; poi ho applicato la tua patch e tutto è ricominciato a volare!!:wink:

@lavish:
lavish wrote:
Da me non ci mette ore ad avviarsi è iper istantaneo....

Come hai fatto??! Sono curioso...
_________________
Le religioni sono come le lucciole: per brillare hanno bisogno del buio
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4295
Location: Venice Island, European Union

PostPosted: Thu Apr 07, 2005 7:37 pm    Post subject: Reply with quote

scusate ragazzi, devo controllare un paio di cose.. forse mi sono sbagliato io. Domani edito questo messaggio e vi faccio sapere ;)
_________________
www.minimalblue.com
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Fri Apr 08, 2005 9:10 am    Post subject: Reply with quote

ad alcuni (me incluso) il problema della lentezza di fluxbox si risolve compilandolo con la flag +disablexmb.
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Fri Apr 08, 2005 10:06 am    Post subject: Reply with quote

si il post sembra questo https://forums.gentoo.org/viewtopic-t-310870-highlight-disablexmb.html

ma penso che in questo caso il problema della lentezza non sia utf8..non saprei
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum