Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no sound in games[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
zombics
n00b
n00b


Joined: 28 Feb 2005
Posts: 30
Location: israel

PostPosted: Mon Mar 14, 2005 8:44 pm    Post subject: no sound in games[solved] Reply with quote

i tryed the sound on ET and tux raver.
in ET
this is the sound output:
Code:

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------
Sound memory manager started
Sys_LoadDll(/home/zombics/.etwolf/etmain/ui.mp.i386.so)...
Sys_LoadDll(/home/zombics/.etwolf/etmain/ui.mp.i386.so) failed:
"/home/zombics/.etwolf/etmain/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/opt/enemy-territory/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at  0x5f750bfc
Sys_LoadDll(ui) succeeded!
Found high quality video and fast CPU
--- Common Initialization Complete ---

and in tux racer this is tthe error:
Code:

%%% tuxracer warning: FAILED to load music file music/start1-jt.it: Unrecognized music format
%%% tuxracer warning: FAILED to load music file music/options1-jt.it: Unrecognized music format
%%% tuxracer warning: FAILED to load music file music/race1-jt.it: Unrecognized music format
%%% tuxracer warning: FAILED to load music file music/wonrace1-jt.it: Unrecognized music format


Last edited by zombics on Mon Mar 14, 2005 10:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
zombics
n00b
n00b


Joined: 28 Feb 2005
Posts: 30
Location: israel

PostPosted: Mon Mar 14, 2005 10:19 pm    Post subject: Reply with quote

o i just forgot to enter emu 32 bit in my kernel...
that did the trick
Back to top
View user's profile Send private message
silverfix
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2003
Posts: 146
Location: born: Foggia - now: Bari

PostPosted: Tue Jul 26, 2005 3:11 pm    Post subject: Reply with quote

i've the same problem, but the option emu 32bit in the alsa configuration section is in gray and it isn't activate. What i need to enable ?


sorry for my real bad english :oops:
_________________
SilverFix - a happy Linux user!
Back to top
View user's profile Send private message
tcfelker
n00b
n00b


Joined: 24 Jun 2003
Posts: 46

PostPosted: Wed Jul 27, 2005 3:07 am    Post subject: Reply with quote

Maybe you need to enable support for 32-bit binaries in the kernel as a whole.
Back to top
View user's profile Send private message
movrev
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2004
Posts: 114
Location: Berkeley, CA - USA

PostPosted: Sun Jul 31, 2005 3:34 am    Post subject: Reply with quote

Code:

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------


I have this message when starting the game and I could never make sound work. Sound does work for xmms and other games, such as UT2004. Any ideas why?
_________________
Shuttle SN25P - FN25 mobo nForce 4 - AMD Athlon 64 3500+ - nVidia GeForce 6800 - Maxtor 200Gb - 2x1024 Mb Corsair XMS RAM
Back to top
View user's profile Send private message
whig
l33t
l33t


Joined: 27 Nov 2004
Posts: 970
Location: New Zealand

PostPosted: Sun Jul 31, 2005 8:06 am    Post subject: Reply with quote

movrev wrote:
Code:

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------


I have this message when starting the game and I could never make sound work. Sound does work for xmms and other games, such as UT2004. Any ideas why?

Is that a split between 64 and 32 bit apps? Are you using 32 bit emul or a chroot?
Back to top
View user's profile Send private message
movrev
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2004
Posts: 114
Location: Berkeley, CA - USA

PostPosted: Sun Jul 31, 2005 3:04 pm    Post subject: Reply with quote

I do use 32 and 64 bits apps, but I don't do it with chroot...and I assume I have 32 bit emulation working good (e.g: firefox-bin and several other apps work well). I looked for the 32-bit emulation bit in the kernel, but I didn't find it in the ALSA section. I do have it enabled as a whole (binaries), but there doesn't seem to be an option there (Kernel 2.6.12-gentoo-r6). Any ideas? Thanks.
_________________
Shuttle SN25P - FN25 mobo nForce 4 - AMD Athlon 64 3500+ - nVidia GeForce 6800 - Maxtor 200Gb - 2x1024 Mb Corsair XMS RAM
Back to top
View user's profile Send private message
cdooley235
n00b
n00b


Joined: 31 May 2004
Posts: 6
Location: Boston

PostPosted: Tue Aug 02, 2005 12:11 pm    Post subject: Reply with quote

movrev wrote:
I do use 32 and 64 bits apps, but I don't do it with chroot...and I assume I have 32 bit emulation working good (e.g: firefox-bin and several other apps work well). I looked for the 32-bit emulation bit in the kernel, but I didn't find it in the ALSA section. I do have it enabled as a whole (binaries), but there doesn't seem to be an option there (Kernel 2.6.12-gentoo-r6). Any ideas? Thanks.


I'm having a similar issue to what you mentioned. I've just finished building my amd64 machine and have most everything working, including audio. However, when I thought I'd try a basic game to see how my new machine could handle it compared to my old 1998 Compaq en series machine , I got a similar sound issue as the one you are describing. The game works fine without the sound, but It'd be nice to get it working too.

Regarding the 32-bit emulation in alsa, I recently read in another forum post by mike4148 that the 32 bit emulation is built in to the kernel in this most recent 2.6 kernel (I'm using 2.6.12-gentoo-r6). You can see this post here: [Solved] (yet another) no sound in Doom3-demo

Sorry i've not got more to contribute than this. If i get anywhere, I'll make sure to let you know.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum