Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I can't Install xmms-aalsa
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
crevette
Guru
Guru


Joined: 21 May 2002
Posts: 543
Location: Chrooted in Nice, France

PostPosted: Fri May 24, 2002 9:51 am    Post subject: I can't Install xmms-aalsa Reply with quote

I had an error when I try to install xmms-alsa and so xmms is not working. I'm a bit disappointed.

Somebody can help me?
Perhaps I have forgotten to configure something??

This is the message I have when I merge xmms-aalsa
=======================================
checking for snd_cards in -lasound... no
configure: error: No linkable libasound was found.

!!! ERROR: the ./configure command did not complete successfully.
!!! ("./configure --prefix=/usr --host=i686-pc-linux-gnu")
!!! Since this is a critical task, ebuild will be stopped.

!!! emerge aborting on /usr/portage/media-sound/xmms-aalsa/xmms-aalsa-0.5.4-r3.ebuild .
========================================
Back to top
View user's profile Send private message
craftyc
Guru
Guru


Joined: 23 May 2002
Posts: 443
Location: Behind You.

PostPosted: Fri May 24, 2002 11:53 am    Post subject: Reply with quote

If you look at the desktop guide on Gentoos main site it will take you through all the steps necessary to get sound configured.
_________________
Postcount ++
Back to top
View user's profile Send private message
Mal Syned
Guest





PostPosted: Sat May 25, 2002 10:01 pm    Post subject: Same problem Reply with quote

I have the same problem, and the problem is not explained away in the Gentoo Desktop documentation. `strings /usr/lib/libasound.so` reveals that there is, infact, no such symbol (snd_cards) in the library. is there a newer version of xmms-aalsa? (I'm assuming that xmms-aalsa is the older program, since the config.log for it reveals that it's using a depricated version of the asoundlib.h)? If not, does anyone know of a workaround to this problem?

--Mal Syned
Back to top
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Sat May 25, 2002 11:29 pm    Post subject: Reply with quote

xmms-aalsa is for older alsa version (0.5). The new one is called alsa-xmms.
Back to top
View user's profile Send private message
S_aIN_t
Guru
Guru


Joined: 11 May 2002
Posts: 488
Location: Ottawa

PostPosted: Sun May 26, 2002 6:37 pm    Post subject: Reply with quote

thanks for the tip.. i didn't know that and was having the same problem..

i installed alsa-xmms and it is working just fine.. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum