Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -De world falha
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Fri Apr 01, 2005 12:14 pm    Post subject: emerge -De world falha Reply with quote

Estou a fazer um emerge -De world para actualizar gentoo de uma versão muito antiga para a actual, mas estou com um problema..

Quando chega à parte de compilar o alsa-driver isto falha por estar a usar um kernel 2.6... Como faço para isso não ter que compilar esse package? Um emerge inject n resulta :/
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Sat Apr 02, 2005 2:15 pm    Post subject: Reply with quote

qual é o erro ?

podes compilar o alsa no kernel <*> em vez de usar modules.
_________________
linux: #232767
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Mon Apr 04, 2005 9:04 am    Post subject: Reply with quote

O erro diz mesmo que tenho o kernel 2.6 e para esse kernel não devo usar o alsa-drivers, mas sim o alsa do proprio kernel (que até já estou a usar).

Mas não prcebo porque, o alsa-driver aparece-me sempre na lista de packages a compilar
Back to top
View user's profile Send private message
r3pek
Retired Dev
Retired Dev


Joined: 17 Sep 2003
Posts: 568
Location: Lisbon - Portugal

PostPosted: Mon Apr 04, 2005 10:40 am    Post subject: Reply with quote

Code:
emerge -C alsa-driver && emerge -De world
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Mon Apr 04, 2005 11:21 am    Post subject: Reply with quote

Por acaso já fiz isso, não tenho o alsa-driver instalado mas em algum ponto isto pede o alsa-driver



Parece-me que o problema é o alsa-utils, que tem o alsa-driver como dependencia...
Back to top
View user's profile Send private message
Mythos
l33t
l33t


Joined: 02 May 2004
Posts: 953
Location: Portugal

PostPosted: Mon Apr 04, 2005 3:46 pm    Post subject: Reply with quote

Eu uso o alsa-driver em kernel 2.6 sem qualquer tipo de problema, simplesmente no kernel ponho no quando chega à parte do alsa e do OSS ...

quanto a ele emergir o alsa

emerge -C alsa-driver alsa-utils alsa-tools

e apaga o que tiveres acerca de alsa no
/etc/portage/package.keywords

...
_________________
Best Regards,
Sérgio Henrique
Linux dune 3.0.6-gentoo #1 SMP Thu Oct 27 16:47:29 WEST 2011 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Mon Apr 04, 2005 9:40 pm    Post subject: Reply with quote

Vou experimentar :)

tkx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum