Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia + Xorg = лого ???
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
nnniner
n00b
n00b


Joined: 10 Dec 2004
Posts: 2

PostPosted: Tue Mar 29, 2005 8:24 am    Post subject: nvidia + Xorg = лого ??? Reply with quote

После установки драйвера emerge nvidia-glx и редактирования xorg.conf + действия описанные в соответствующем документе с gentoo.org получаю результат: при загрузке менеджера окон отображается лого nVidia ... но не более того. Меняю в xorg.conf драйвер на nv - все OK ... загружается оконный менеджер ... в логах в обоих случаях все гуд ... т.е. нет строк типа error бла бла бла ... ???
Заранее благодарен за помощь.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Tue Mar 29, 2005 8:31 am    Post subject: Reply with quote

попробуй так:
Code:
Section "Device"
   Identifier     "Device[0]"
   Driver          "nvidia"
   Option      "NoLogo"      "true"
   ...
Back to top
View user's profile Send private message
Double
Apprentice
Apprentice


Joined: 23 Apr 2004
Posts: 250
Location: Kislovodsk, Russia

PostPosted: Tue Mar 29, 2005 8:51 am    Post subject: Re: nvidia + Xorg = лого ??? Reply with quote

nnniner wrote:
После установки драйвера emerge nvidia-glx и редактирования xorg.conf + действия описанные в соответствующем документе с gentoo.org получаю результат: при загрузке менеджера окон отображается лого nVidia ... но не более того. Меняю в xorg.conf драйвер на nv - все OK ... загружается оконный менеджер ... в логах в обоих случаях все гуд ... т.е. нет строк типа error бла бла бла ... ???
Заранее благодарен за помощь.

что в /var/log/Xorg.0.log?
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Tue Mar 29, 2005 8:56 am    Post subject: Reply with quote

Перед установкой драйвера тебе стоило прочитать README от nVidia.
Back to top
View user's profile Send private message
Davidov
n00b
n00b


Joined: 27 Mar 2005
Posts: 52

PostPosted: Tue Mar 29, 2005 11:03 am    Post subject: Re: nvidia + Xorg = лого ??? Reply with quote

nnniner wrote:
После установки драйвера emerge nvidia-glx и редактирования xorg.conf + действия описанные в соответствующем документе с gentoo.org получаю результат: при загрузке менеджера окон отображается лого nVidia ... но не более того. Меняю в xorg.conf драйвер на nv - все OK ... загружается оконный менеджер ... в логах в обоих случаях все гуд ... т.е. нет строк типа error бла бла бла ... ???
Заранее благодарен за помощь.

Система зависает при этом? А иксы? Ctrl-Alt-BS? MagicKey?
Была проблема - зависал драйвер нвидийный. Вылечил перепрошивкой BIOS (M/B EPoX 8RDA+).
А вообще, стоит начать с чтения Readme.
_________________
BR,
Davidov.
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Tue Mar 29, 2005 12:29 pm    Post subject: Reply with quote

аналогичная ситуация на работе.
мать тоже EPoX (какая не помню).

даль logo не уходит. xfce сильно ругается(позже покажу), а X - молчат.
Back to top
View user's profile Send private message
alk
n00b
n00b


Joined: 13 Jul 2004
Posts: 52

PostPosted: Wed Mar 30, 2005 4:23 am    Post subject: Reply with quote

Code:

opengl-update nvidia

может поможет?
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Wed Mar 30, 2005 4:50 am    Post subject: Reply with quote

нет тут чего-то другое.
пробовал с ядрами 2.4.26 и 2.4.9 - эфект тотже
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Wed Mar 30, 2005 3:08 pm    Post subject: Reply with quote

ошибочка вышла, xfce тоже молчит

зато в syslog'е есть всему объяснение

Mar 30 19:04:16 linux Linux agpgart interface v0.99 (c) Jeff Hartmann
Mar 30 19:04:16 linux agpgart: Maximum main memory to use for agp memory: 941M
Mar 30 19:04:16 linux agpgart: unsupported bridge
Mar 30 19:04:16 linux agpgart: no supported devices found.
Mar 30 19:04:16 linux insmod: /lib/modules/2.4.26-imperiya/kernel/drivers/char/agp/agpgart.o: init_module: No such device
Mar 30 19:04:16 linux insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 30 19:04:16 linux insmod: /lib/modules/2.4.26-imperiya/kernel/drivers/char/agp/agpgart.o: insmod agpgart failed
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Wed Mar 30, 2005 3:11 pm    Post subject: Reply with quote

в dmesg'е тоже кое-что имеется
Back to top
View user's profile Send private message
nerff
n00b
n00b


Joined: 20 Feb 2005
Posts: 50
Location: Novosibirsk

PostPosted: Wed Mar 30, 2005 4:42 pm    Post subject: nvidia Reply with quote

Ну, я думаю, надо в ядре убрать agpart, а в xorg.conf поставить NvAGP "1"
У меня эти действия пофиксили кучу проблем
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Wed Mar 30, 2005 4:55 pm    Post subject: Reply with quote

Во-первых,
1. Какая видюха.
2. Какой чипсет.
3. Какие опции в конфиге ядра установлены (относительно agpgart).
4. Блин, ну хоть краем глаза глянули бы readme. Там чётко написано и про NvAGP, в каких случаях какие значения.
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Wed Mar 30, 2005 6:32 pm    Post subject: Reply with quote

YD, пока ничего ответить не могу.

помогает Option "NvAGP" "0" или "2"

только gtk-проги рисуют, на не стирают.

зы: поиграли в Q3, в нем все замечательно :)
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Wed Mar 30, 2005 6:33 pm    Post subject: Reply with quote

проблема в модуле agpgart. он почему-то ругется при загрузке
Back to top
View user's profile Send private message
sovchik
n00b
n00b


Joined: 22 Mar 2005
Posts: 30

PostPosted: Thu Mar 31, 2005 5:55 am    Post subject: Reply with quote

параметр NvAGP определяет какой модуль agp gart юзать. Если не путаю, 0 значит вообще без этого модуля, а 2 - использовать "родной", из ведра. С родным дрова от nvidia конфликтуют. У меня такое было при попытке собрать дрова от nvidia с исходниками ведра, ставящимися из портежей. Помогла только замена исходников на исходники с kernel.org.
траблы с gtk все из-за того же.
_________________
Вот.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum