Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openmotif and motif-config
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
imesg
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 275

PostPosted: Mon Mar 28, 2005 11:40 pm    Post subject: openmotif and motif-config Reply with quote

I think when I did an emerge -u world openmotif was updated to 2.2.3-r6.
Now openmotif libs are not found. I would think that motif-config would take care of that. However when I do 'motif-config -l' I get nothing.

Of course the libs are in /usr/lib/openmotif-2.2.

Anyone know what goes on here?

Thanks,

Gene
Back to top
View user's profile Send private message
Tsuki
n00b
n00b


Joined: 27 May 2004
Posts: 42
Location: Southampton, England

PostPosted: Tue Apr 26, 2005 4:23 pm    Post subject: Reply with quote

I'm not sure if it's any help, but the emerge sync && emerge -puD world that I just ran found an openmotif/motif-config problem (running ~x86):
Code:
[blocks B     ] =x11-libs/openmotif-2.2.3-r6 (is blocking x11-libs/motif-config-0.9)
Back to top
View user's profile Send private message
wdconinc
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2003
Posts: 80
Location: Ann Arbor, Michigan

PostPosted: Tue Apr 26, 2005 6:01 pm    Post subject: Reply with quote

Tsuki: try unmerging openmotif first and then upgrade openmotif and motif-config
Code:
emerge unmerge openmotif
emerge openmotif motif-config --update --oneshot
Back to top
View user's profile Send private message
Rafael Pinto
n00b
n00b


Joined: 12 Jan 2004
Posts: 22
Location: Brasil

PostPosted: Wed Apr 27, 2005 1:44 pm    Post subject: COOL Reply with quote

Thanks... this seems to work!! At least for me...
Back to top
View user's profile Send private message
CSllama
n00b
n00b


Joined: 28 Mar 2005
Posts: 5
Location: Bowling Green, KY

PostPosted: Thu Dec 29, 2005 3:30 am    Post subject: Yay! Reply with quote

Worked for me as well! Thanks!
Back to top
View user's profile Send private message
mlybarger
Guru
Guru


Joined: 04 Sep 2002
Posts: 421

PostPosted: Wed Jan 04, 2006 11:36 am    Post subject: Reply with quote

i got this openmotif blocks also. what a waste of time. glad there was this post on the forums. seems to work ok.
Back to top
View user's profile Send private message
Paulathome
n00b
n00b


Joined: 05 Jan 2006
Posts: 17

PostPosted: Thu Jan 05, 2006 8:16 pm    Post subject: Reply with quote

Also had this problem this afternoon and your workaround did the trick nicely!

cheers! 8)

Paul.
Back to top
View user's profile Send private message
gohmdoree
Guru
Guru


Joined: 12 Oct 2004
Posts: 533

PostPosted: Sat Apr 01, 2006 3:24 pm    Post subject: Reply with quote

had the same issue and it had worked for me just fine. thanks!
Back to top
View user's profile Send private message
orlot
n00b
n00b


Joined: 31 Jan 2004
Posts: 10
Location: Massachusetts

PostPosted: Tue Apr 18, 2006 4:12 am    Post subject: Reply with quote

I had this problem and the unemerge, remerge solved it for me. Thanks! But I am still puzzled. What actually caused this to happen? I thought portage was smart enough to get around problems like this.
Back to top
View user's profile Send private message
BarneyRubble
n00b
n00b


Joined: 20 Feb 2005
Posts: 51
Location: NSW,Australia

PostPosted: Wed Feb 13, 2008 5:47 pm    Post subject: Reply with quote

YibbideeYibida!- Work for me to
Back to top
View user's profile Send private message
aNoBody
Tux's lil' helper
Tux's lil' helper


Joined: 20 Nov 2005
Posts: 93
Location: Australia

PostPosted: Sun Feb 24, 2008 3:52 pm    Post subject: Reply with quote

I actually now have the oppisite & I am not sure which is the safe way around this.it may even seem obvious but I would like any advice
Thanks

Emerge pretend x11-libs/openmotif started...
These are the packages that would be merged, in order:
Calculating dependencies ... done!
[ebuild U ] x11-libs/openmotif [2.3.0-r1] [2.3.0] USE="jpeg png -doc -examples -xft" 0 kB
[blocks B ] x11-libs/motif-config (is blocking x11-libs/openmotif-2.3.0-r1)
Total: 1 package (1 upgrade, 1 block), Size of downloads: 0 kB
Back to top
View user's profile Send private message
V-Li
Developer
Developer


Joined: 03 Jan 2006
Posts: 601

PostPosted: Sun Feb 24, 2008 4:56 pm    Post subject: Reply with quote

Unmerge motif-config and openmotif itself...then remerge openmotif.

The old layout with a config utility to switch between lesstif and openmotif was just broken by design. As the original author vanished from Gentoo it hung around in limbo for some time. Some developers have joined forces to clean up the mess...some "breakage" by blockers was needed to actually accomplish a smooth transition. Now lesstif is gone and openmotif is the only implementation of that widget set in Portage. See bug 204249 for some information and follow the linked bugs.
_________________
Christian Faulhammer, Gentoo Lisp project, GNU Emacs wrangler
http://www.gentoo.org/proj/en/lisp/ #gentoo-lisp on FreeNode
Back to top
View user's profile Send private message
BarneyRubble
n00b
n00b


Joined: 20 Feb 2005
Posts: 51
Location: NSW,Australia

PostPosted: Mon Feb 25, 2008 1:10 pm    Post subject: Reply with quote

Seems to have done the trick, Its good to get confirmation on what is needed to be done.
Thanks
Back to top
View user's profile Send private message
aNoBody
Tux's lil' helper
Tux's lil' helper


Joined: 20 Nov 2005
Posts: 93
Location: Australia

PostPosted: Thu Feb 28, 2008 3:58 pm    Post subject: Reply with quote

Thanks, Worked Well.
Back to top
View user's profile Send private message
jice
n00b
n00b


Joined: 02 Jul 2006
Posts: 29

PostPosted: Mon Mar 03, 2008 10:08 pm    Post subject: No longer working Reply with quote

As of today, this no longer seems to be working. After removing, si see this:

emerge -av openmotif motif-config

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] x11-libs/openmotif-2.3.0-r1 USE="jpeg png -doc -examples -xft" 0 kB
[ebuild N ] x11-libs/motif-config-0.10-r2 0 kB
[blocks B ] x11-libs/motif-config (is blocking x11-libs/openmotif-2.3.0-r1)
Back to top
View user's profile Send private message
jice
n00b
n00b


Joined: 02 Jul 2006
Posts: 29

PostPosted: Mon Mar 03, 2008 10:09 pm    Post subject: Reply with quote

Yet, it still works for an older version of openmotif:

emerge -av =x11-libs/openmotif-2.3.0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] x11-libs/motif-config-0.10-r2 0 kB
[ebuild N ] x11-libs/openmotif-2.3.0 USE="jpeg png -doc -examples -xft" 0 kB
Back to top
View user's profile Send private message
hitachi
Guru
Guru


Joined: 20 Feb 2006
Posts: 466

PostPosted: Mon Mar 03, 2008 10:23 pm    Post subject: Reply with quote

well I just tried -DuavN world. Also hat the blocking motiv-config. Did an
Code:
# emerge -avC openmotif motivconfig
emerge -DuavN world

For me this is not bringing back motif-config again, too.
_________________
Athlon 64 X2 3800+
Micro-ATX-Mainboard in einer OEM-Version von Asus mit Nvidias nForce4 (A8NE-FM/S).
PEG-Grafikkarte von Leadtek mit Nvidia GeForce 6600
3 GB RAM
350-Watt-Netzteil (von Fortron/Source)
4 x 500GB S-ATA HDD (raid1 und raid5)
Back to top
View user's profile Send private message
ulm
Developer
Developer


Joined: 04 Oct 2004
Posts: 73
Location: Mainz, Germany

PostPosted: Tue Mar 04, 2008 7:43 am    Post subject: Re: No longer working Reply with quote

jice wrote:
As of today, this no longer seems to be working. After removing, si see this:

emerge -av openmotif motif-config

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] x11-libs/openmotif-2.3.0-r1 USE="jpeg png -doc -examples -xft" 0 kB
[ebuild N ] x11-libs/motif-config-0.10-r2 0 kB
[blocks B ] x11-libs/motif-config (is blocking x11-libs/openmotif-2.3.0-r1)


As Christian had written, you are not supposed to remerge motif-config:
V-Li wrote:
Unmerge motif-config and openmotif itself...then remerge openmotif.


The goal is to transit to a single, unslotted Motif implementation, which will no longer need x11-libs/motif-config. All applications in the Portage tree work with Open Motif 2.3.

If there is demand by users (not many voices so far ...), we may also add a compatibility package for Open Motif 2.2 later.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum