Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing gentoo 2005.0 stage1 NPTL on a stage3 error~~
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nathaniel
n00b
n00b


Joined: 13 Jul 2003
Posts: 42

PostPosted: Mon Apr 11, 2005 11:37 am    Post subject: installing gentoo 2005.0 stage1 NPTL on a stage3 error~~ Reply with quote

i follow this links to do
https://forums.gentoo.org/viewtopic-t-274968-postdays-0-postorder-asc-start-0.html

i have finish 7.2.4 Rebuilding the System Toolkit
# emerge glibc binutils gcc portage

and then go to
# emerge -e system

here comes the error now


"optimize='-O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe'" perlio.o` -fPIC perlio.c CCCMD = gcc -DPERL_CORE -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe -Wall `sh cflags "optimize='-O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe'" perlapi.o` -fPIC perlapi.c CCCMD = gcc -DPERL_CORE -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe -Wall `sh cflags "optimize='-O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe'" numeric.o` -fPIC numeric.c CCCMD = gcc -DPERL_CORE -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -march=pentium-m -mtune=pentium-m -fomit-frame-pointer -pipe -Wall numeric.c: In function `S_mulexp10': numeric.c:815: internal compiler error: in try_split, at emit-rtl.c:3343
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:https://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /var/tmp/portage/libperl-5.8.6/temp/ccXIrYHM.out file, please attach this to your bugreport.
make: *** [numeric.o] Error 1
!!! ERROR: sys-devel/libperl-5.8.6 failed.
!!! Function src_compile, Line 220, Exitcode 2
!!! Unable to make libperl.so
!!! If you need support, post the topmost build error, NOT this status message.


i try
fix_libtool_files.sh 3.4.3 --oldarch i686-pc-linux-gnu
and emerge -e system again, also display this error

what about i skip this step ???what will be happen when i skip this step? but i don't want to skip this~~please help me to fix this problem, thanks
Back to top
View user's profile Send private message
Enlight
Advocate
Advocate


Joined: 28 Oct 2004
Posts: 3519
Location: Alsace (France)

PostPosted: Mon Apr 11, 2005 11:47 am    Post subject: Reply with quote

Got ithreads in your USE flag? BTW there is a special thread to support this install on this page!
Back to top
View user's profile Send private message
nathaniel
n00b
n00b


Joined: 13 Jul 2003
Posts: 42

PostPosted: Mon Apr 11, 2005 1:49 pm    Post subject: Reply with quote

Enlight wrote:
Got ithreads in your USE flag? BTW there is a special thread to support this install on this page!


so have i remove ithread in USE??
Back to top
View user's profile Send private message
vipernicus
Veteran
Veteran


Joined: 17 Jan 2005
Posts: 1462
Location: Your College IT Dept.

PostPosted: Mon Apr 11, 2005 6:22 pm    Post subject: Reply with quote

Quote:
so have i remove ithread in USE??


No, and don't post this here, go to https://forums.gentoo.org/viewtopic-t-314985.html and post your issues.
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Mon Apr 11, 2005 6:40 pm    Post subject: Reply with quote

Yes, all 2005.0 stage 1/3 errors should be addressed to the support thread. I have a feeling it hast to do with the fact your compiling with the unstable -march=pentium-m flag though. Compiling libperl and perl with the ithreads useflag is only an issue with certain perl applications, such as net-irc/epic4, the ebuid displays a message when the flag is set, but other than that it makes no difference at compile time, and certainly shouldn't be giving you errors.
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
nathaniel
n00b
n00b


Joined: 13 Jul 2003
Posts: 42

PostPosted: Tue Apr 12, 2005 12:50 am    Post subject: Reply with quote

Sith_Happens wrote:
Yes, all 2005.0 stage 1/3 errors should be addressed to the support thread. I have a feeling it hast to do with the fact your compiling with the unstable -march=pentium-m flag though. Compiling libperl and perl with the ithreads useflag is only an issue with certain perl applications, such as net-irc/epic4, the ebuid displays a message when the flag is set, but other than that it makes no difference at compile time, and certainly shouldn't be giving you errors.


your mean is don't use -march=pentium-m??? what about -march=pentium3??
Back to top
View user's profile Send private message
Bob P
Advocate
Advocate


Joined: 20 Oct 2004
Posts: 3355
Location: Jackass! Development Labs

PostPosted: Tue Apr 12, 2005 12:52 am    Post subject: Reply with quote

nathaniel wrote:
Sith_Happens wrote:
Yes, all 2005.0 stage 1/3 errors should be addressed to the support thread. I have a feeling it hast to do with the fact your compiling with the unstable -march=pentium-m flag though. Compiling libperl and perl with the ithreads useflag is only an issue with certain perl applications, such as net-irc/epic4, the ebuid displays a message when the flag is set, but other than that it makes no difference at compile time, and certainly shouldn't be giving you errors.


your mean is don't use -march=pentium-m??? what about -march=pentium3??

try using the search feature. this problem is extensively documented in the forums.
_________________
.
Stage 1/3 | Jackass! | Rockhopper! | Thanks | Google Sucks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum