Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pppd dies immediately (wvdial+slmodem)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
hoernerfranz
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 135
Location: Baden

PostPosted: Fri Mar 25, 2005 5:30 pm    Post subject: pppd dies immediately (wvdial+slmodem) Reply with quote

I'm trying to get my AC97 based internal modem to work with wvdial.
I have kernel 2.6.10-r6, slmodem 2.9.9b, ppp 2.4.2-r10, wvdial 1.54.0
I know my wvdial.conf is ok (tested with external modem).
I've managed wvdial to recognize the modem, dial, connect and start pppd.
but pppd keeps dying directly with error 1.
the only logmessage I get from /var/log/everything/current is this:
couldn't set tty to PPP discipline: invalid argument
anyone know what this means/where to search ?
Back to top
View user's profile Send private message
hoernerfranz
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 135
Location: Baden

PostPosted: Sat Mar 26, 2005 11:49 am    Post subject: Reply with quote

just to comment on my own post:
meanwhile, I found another resource: http://synce.sourceforge.net/synce/qa.php
which gives the advice to compile the ppp_async kernel module.
I did that, but still no dice.
the logs now tell me that there is a prob wtih that kernel module:
error inserting module: unknown symbol ccitt_table.
so I'll try to solve this and hope pppd will work then :):)
Back to top
View user's profile Send private message
hoernerfranz
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 135
Location: Baden

PostPosted: Sat Mar 26, 2005 1:40 pm    Post subject: Reply with quote

ok, this seems to turn out to be more a kernel related issue -
as stated before, 'modprobe ppp_generic' is ok,
but 'modprobe ppp_async' gives me:

ppp_async: unknown symbol crc_ccitt_table

I also tried to compile ppp_generic and ppp_async directly into the kernel,
but then I get errors from pppd like '/dev/ppp not found'.
and, yes, I recompiled ppp everytime after having made changes to my kernel
(and also 'make clean' before each kernel/module recompile).
now I'm really out of ideas - maybe I'll repost this in the kernel list...
Back to top
View user's profile Send private message
hoernerfranz
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2004
Posts: 135
Location: Baden

PostPosted: Sat Mar 26, 2005 5:49 pm    Post subject: pppd dies immediately (wvdial+slmodem) - SOLVED Reply with quote

just for the record (in case anyone else stumbeles over this :) :

I obviously had crc-ccitt directly in the kernel, ppp_generic
and ppp_async as modules, so ppp_async obviously didn't recognize crc-ccitt.
now I compiled crc-ccitt as module and all works fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum