Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba Problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
tradergt
n00b
n00b


Joined: 22 May 2002
Posts: 1

PostPosted: Thu May 23, 2002 4:21 pm    Post subject: Samba Problem Reply with quote

I have compiled samba many times. But I installed gentoo, and tryied installing samba and have trouble.. I can just install without portage, but would rather figure it out.. Why is it not authenticating through unix(pam)?

Log:

May 22 07:29:55 kristy PAM_smbpass[16504]: Failed to find entry for user
smelser.
May 22 07:29:55 kristy smbd[16504]: [2002/05/22 07:29:55, 0]
passdb/pampass.c:smb_pam_passcheck(827)
May 22 07:29:55 kristy smbd[16504]: smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User smelser !

I don't want to use smbpasswd..
Thanks,
Jeff
Back to top
View user's profile Send private message
Vlad
Apprentice
Apprentice


Joined: 09 Apr 2002
Posts: 264
Location: San Diego, California

PostPosted: Tue Jun 04, 2002 6:02 am    Post subject: Pam and samba Reply with quote

I just wanted to say I'm having the same problem. It doesn't seem to effect anything (as far as I'm concerned, anyways), but it's really annoying to see it popup in my log file.

Code:
[2002/06/03 21:43:39, 0] passdb/pampass.c:smb_pam_passcheck(827)
  smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User smbuser !


That occurs everytime I access a share on the computer. I've scanned the internet, found other people with the same problem, but no solutions. If I ever find a solution (somehow I doubt I will), I'll be sure to post it.
Back to top
View user's profile Send private message
mcfish
n00b
n00b


Joined: 28 May 2003
Posts: 16
Location: Tampere, Finland

PostPosted: Wed May 28, 2003 4:38 pm    Post subject: Try this Reply with quote

The original /etc/pam.d/samba config looks something like this:

Code:

#%PAM-1.0
# pam_smbpass.so authenticates against the smbpasswd file
auth       required     pam_smbpass.so nodelay
account    required     /lib/security/pam_stack.so service=system-auth
session    required     /lib/security/pam_stack.so service=system-auth
password   required     pam_smbpass.so nodelay smbconf=/etc/samba/smb.conf


I changed it to look like this (actually copied it from redhats config file):

Code:

#%PAM-1.0
# pam_smbpass.so authenticates against the smbpasswd file

auth       required     pam_nologin.so
auth       required     pam_stack.so service=system-auth
account    required     pam_stack.so service=system-auth
session    required     pam_stack.so service=system-auth
password   required     pam_stack.so service=system-auth


and now I don't get any error messages, and I can access gentoo box from windows (btw. also make sure that you have proper setting in smb.conf for the crypted passwords)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum