Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
now: KDE sound problem /dev/dsp
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Turr-I-Can
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2003
Posts: 86

PostPosted: Tue Jan 21, 2003 6:32 pm    Post subject: now: KDE sound problem /dev/dsp Reply with quote

Hi there,

after configuring alsa (works) I tried sound in KDE 3.0.5a. At start I get:

Quote:

Sound server informational message:
Error while initializing the sound driver:

device /dev/dsp can't be opened (No such file or directory)

The sound server will continue, using the null output device.


there's no /dev/dsp or /dev/dsp* in /dev. The strange thing (to me) is that if I use my Suse Linux I find in /gentoo/dev/ (which is the root for gentoo) a dsp and a dsp1???
Back to top
View user's profile Send private message
garo
Moderator
Moderator


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Tue Jan 21, 2003 9:13 pm    Post subject: Reply with quote

Is arts running ?
(you can check it with :
Code:
ps ax | grep arts
)
_________________
My favorite links this month:
- Surf Random
- Web-based SSH
- Stop Spam
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7621
Location: Pelotas, BR

PostPosted: Tue Jan 21, 2003 9:15 pm    Post subject: Reply with quote

Have you loaded snd-pcm-oss, snd-mixer-oss?
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Turr-I-Can
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2003
Posts: 86

PostPosted: Tue Jan 21, 2003 10:21 pm    Post subject: Reply with quote

I got

Quote:

SPAWN root # ps ax | grep arts
995 ? S 0:00 //usr/kde/3/bin/artsd -F 10 -S 4096 -b 16 -s 60 -m artsmessage -l 3 -f
1090 pts/2 S 0:00 grep arts
SPAWN root #


This is what I found in the modules.conf:

Quote:

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss


So I'm not quite sure if the ps ax | grep arts output is okay. Any new suggestions? Anyway, thanks for your help.
Back to top
View user's profile Send private message
garo
Moderator
Moderator


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Tue Jan 21, 2003 10:43 pm    Post subject: Reply with quote

Quote:
So I'm not quite sure if the ps ax | grep arts output is okay.

It's normal.
What modules do you have loaded ("lsmod")
_________________
My favorite links this month:
- Surf Random
- Web-based SSH
- Stop Spam
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7621
Location: Pelotas, BR

PostPosted: Tue Jan 21, 2003 10:43 pm    Post subject: Reply with quote

Show us the output of "lsmod"
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Turr-I-Can
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2003
Posts: 86

PostPosted: Wed Jan 22, 2003 5:42 am    Post subject: Reply with quote

Here's the output:

Quote:

SPAWN root # lsmod
Module Size Used by Not tainted
snd-pcm-oss 39172 0 (autoclean) (unused)
snd-pcm 62016 0 (autoclean) [snd-pcm-oss]
snd-timer 11720 0 (autoclean) [snd-pcm]
snd-mixer-oss 13112 0 (autoclean) [snd-pcm-oss]
snd 27980 0 (autoclean) [snd-pcm-oss snd-pcm snd-timer snd-mixer-oss]
soundcore 3300 0 (autoclean) [snd]
SPAWN root #


EDIT:
/dev/sound /dev/snd (except for timer, controlC0) are empty.
Back to top
View user's profile Send private message
Turr-I-Can
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2003
Posts: 86

PostPosted: Wed Jan 22, 2003 8:14 am    Post subject: Reply with quote

Okay, I'm getting closer, pls have a look at my modules.conf:

Quote:


### modules-update: start processing /etc/modules.d/alsa
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf-rc,v 1.1 2002/12/21 06:31:52 agenkin Exp $

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
## ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
## OSS/Free portion
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1
##
alias snd-card-0 snd-cmipci

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
## OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

### modules-update: end processing /etc/modules.d/alsa

### modules-update: start processing /etc/modules.d/alsa.save
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /home/cvsroot/gentoo-x86/media-sound/alsa-driver/files/alsa-modules.conf-rc,v 1.1 2002/12/21 06:31:52 agenkin Exp $

# ALSA portion
alias char-major-116 snd
options snd snd_major=116 snd_cards_limit=1
# OSS/Free portion
alias char-major-14 soundcore

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
## ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
## OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
alias snd-card-0 snd-cmipci
alias snd-card-1 snd-cmipci
alias snd-card-2 snd-cmipci
alias snd-card-3 snd-cmipci
alias snd-card-4 snd-cmipci
alias snd-card-5 snd-cmipci
alias snd-card-6 snd-cmipci
alias snd-card-7 snd-cmipci
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
## OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

### modules-update: end processing /etc/modules.d/alsa.save


So alsa and alsa.conf are put into modules.conf. Anyway using these entries, I have a full /dev/sound directory, but still no sound. Next I will delete alsa.safe and see what happens.
Back to top
View user's profile Send private message
Turr-I-Can
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2003
Posts: 86

PostPosted: Wed Jan 22, 2003 8:36 am    Post subject: narrowing down Reply with quote

I deleted alsa.safe out of modules.d/ ( :oops: ).

Now modules.conf looks better. Now I have a full /dev/sound directory. Aplay works, mpg123 starts but after a second it starts again and again... I still get the arts error message: /dev/dsp.....
Back to top
View user's profile Send private message
Turr-I-Can
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2003
Posts: 86

PostPosted: Wed Jan 22, 2003 9:07 pm    Post subject: Reply with quote

I deleted all the alsa stuff, compiled the sound driver as module and works for mp3 . Maybe I don't have to use alsa after all.

..close
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum