Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nforce2 & Radeon9600 & xorg & ati-drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
FDK
n00b
n00b


Joined: 23 Mar 2005
Posts: 60
Location: ru

PostPosted: Thu Mar 24, 2005 7:45 am    Post subject: nforce2 & Radeon9600 & xorg & ati-drivers Reply with quote

Комп: AMD 2500+ 8RDA3I(nforce2) 512Mb Radeon 9600
Согласно faq поставил драйвер итп, возникали всевозможные ошибки, но часть из них решилось обновлением ядра на 2.6.11 потом переустановкой драйвера АТи,в итоге осталось только одна ошибка, которую выдает сам xorg в логе, при startx Хы начинают вроде бы грузиться, потом виснут:
Code:
(WW) fglrx: No matching Device section for instance (BusID PCI:2:0:1) found

При том в xorg.conf:
Code:

# === Misc Options ===
    Option "UseFastTLS"                 "2"
    Option "BlockSignalsOnLock"         "on"
    Option "UseInternalAGPGART"         "no"
    Option "ForceGenericCPU"            "no"
    Option "KernelModuleParm"           "agplock=0" # AGP locked user pages: disabled
    BusID "PCI:2:0:0"    # vendor=1002, device=4150
    Screen 0

а lspci:
Code:

0000:02:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
0000:02:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon 9600] (Secondary)

Заменял я BusID на 2:0:1 толку 0, так же подружены все необходимые модули fglrx и nvidia_agp...
Заранее большое спасибо за помощь.
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Thu Mar 24, 2005 12:50 pm    Post subject: Reply with quote

Это вторая голова твоей ATI. Забей - не ошибка.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Thu Mar 24, 2005 12:57 pm    Post subject: Reply with quote

rusxakep wrote:
Забей - не ошибка.

Он же говорит, что Хы виснут...
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Thu Mar 24, 2005 4:00 pm    Post subject: Reply with quote

Я только не понял, а при чём тут nvidia_agp?
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Thu Mar 24, 2005 6:02 pm    Post subject: Reply with quote

Я говорю не в этом ошибка.

YD: Где nvidia?? Покажите, порву :lol:
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Thu Mar 24, 2005 7:02 pm    Post subject: Re: nforce2 & Radeon9600 & xorg & ati-drivers Reply with quote

FDK wrote:

Заменял я BusID на 2:0:1 толку 0, так же подружены все необходимые модули fglrx и nvidia_agp...


[edit]
Ой, извини , походу я ступил, у тебя же nforce2. Видимо оттуда.
Back to top
View user's profile Send private message
FDK
n00b
n00b


Joined: 23 Mar 2005
Posts: 60
Location: ru

PostPosted: Fri Mar 25, 2005 8:47 am    Post subject: Reply with quote

ни у кого даже идей не появилось, в чем может быть дело?
Back to top
View user's profile Send private message
sovchik
n00b
n00b


Joined: 22 Mar 2005
Posts: 30

PostPosted: Fri Mar 25, 2005 10:45 am    Post subject: Reply with quote

убери из ведра поддержку nvidia agp gart - должно помочь
_________________
Вот.
Back to top
View user's profile Send private message
FDK
n00b
n00b


Joined: 23 Mar 2005
Posts: 60
Location: ru

PostPosted: Fri Mar 25, 2005 1:30 pm    Post subject: Reply with quote

Убирал уже - тогда не грузиться fglrx - а так сейчас выдает инфу хотя бы fglrxinfo ...
Ясно, что для функционирования необходимы эти модули...
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Mon Mar 28, 2005 5:52 am    Post subject: Reply with quote

AGPInternal чего-то там соответственно убери из xorg.conf тогда будет работать fgl....
Back to top
View user's profile Send private message
FDK
n00b
n00b


Joined: 23 Mar 2005
Posts: 60
Location: ru

PostPosted: Mon Mar 28, 2005 6:33 am    Post subject: Reply with quote

2rusxakep
невнимательно читаем - я же написал
Option "UseInternalAGPGART" "no"

а в без включения в ядре agp gart невозможно заставить работать fglrx
Back to top
View user's profile Send private message
FDK
n00b
n00b


Joined: 23 Mar 2005
Posts: 60
Location: ru

PostPosted: Tue Mar 29, 2005 7:36 am    Post subject: Reply with quote

Путем различных преобразование выпала такая ошибка:
Process 6169 using kernel context 0
Еще опишу каким образом висят Х - startX - начинается загрузка - меняется разрешение появляется курсор мыши и все пустой экран и работающая мышь завершаю все это безобразие ctrl+alt+backspace
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Wed Mar 30, 2005 8:38 am    Post subject: Reply with quote

это WM у тебя не запускается ... делов-то ....

запусти до Xов: /etc/init.d/xdm start
Back to top
View user's profile Send private message
FDK
n00b
n00b


Joined: 23 Mar 2005
Posts: 60
Location: ru

PostPosted: Thu Mar 31, 2005 7:37 am    Post subject: Reply with quote

а если fluxbox ? он же вроде стартует после запуска Х сервера
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Thu Mar 31, 2005 7:40 am    Post subject: Reply with quote

fluxbox стартует, если его запустить. надо править ~/.xinitrc или настраивать XDM (любой из них).
Back to top
View user's profile Send private message
FDK
n00b
n00b


Joined: 23 Mar 2005
Posts: 60
Location: ru

PostPosted: Thu Mar 31, 2005 7:42 pm    Post subject: Reply with quote

xdm стартует, но почему-то не могу печатать в окнах логин и пароль буквы - только цифры и символы ...
до этого настроил согласно faq святогора ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum