Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
/dev/hda* no such device?! [Solved]!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
mohamed_hagag
n00b
n00b


Joined: 23 Mar 2005
Posts: 56

PostPosted: Wed Mar 23, 2005 9:17 pm    Post subject: /dev/hda* no such device?! [Solved]!! Reply with quote

If U have the same problem ,PLZ See This Solution .
i have started with stage 3 after i faild to start with stage 1 " long time lost"
i have compiled 2.6.11.5 krnl nicely with genkernel & it boot'ed & the system started BUT WITH this error :
the system didnt detect any of my /dev/hda1 devices
i'm sure that it is the right partition it is ext3 & i made the kernel config manualy & it have ext3 built in the kernel " not module " my grub.conf is :
Quote:

title Gentoo (2.6.11.5smp)
root (hd0,0)
kernel /boot/vmlinuz root=/dev/ram0 real_root=/dev/hda1 init=/linuxrc
ramdisk_size=8192
initrd /boot/initrd-2.6.11.5
[/size]

when booting , the system asking me to specify the root partition or start shell with typing shell & while i enter the shell & try to mount any partition the system tells me that there is no block device with this name !!

i realy tired with all this time gone in to tring & i think this is the last error i'll face so thanks alot too every 1 that can help me start with it.
:( :( :(

mod edit: pruned some exclamation- and questionmarks from the subject. --Earthwings


Last edited by mohamed_hagag on Thu Mar 24, 2005 5:47 pm; edited 2 times in total
Back to top
View user's profile Send private message
thoughtform
Guru
Guru


Joined: 24 May 2004
Posts: 597
Location: east coast USA

PostPosted: Wed Mar 23, 2005 9:31 pm    Post subject: Reply with quote

try with a manual kernel config and a simpler boot option like this:
title=Gentoo Linux 2.6.11r4
root (hd0,0)
kernel /kernel-2.6.11r4 root=/dev/sda3

i would stop using the ramdrive and genkernel until you get a basic system up
Back to top
View user's profile Send private message
mohamed_hagag
n00b
n00b


Joined: 23 Mar 2005
Posts: 56

PostPosted: Thu Mar 24, 2005 12:20 am    Post subject: no ide devices detected Reply with quote

i found that the system couldnt detect /dev contents i wish that it is only kernel configration error becuase i reconfigured 2 kernels 1 with genkernel & 1 manualy & now they r cmopiling I hope that 1 of them will work
thanx for your tip but i tried it & the GRUB told me that this is unrecognized command " without ramdisk".
Back to top
View user's profile Send private message
mikejr
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2004
Posts: 107

PostPosted: Thu Mar 24, 2005 12:32 am    Post subject: Reply with quote

Make sure you have support in your kernel for the file system you are trying to mount.
Back to top
View user's profile Send private message
mohamed_hagag
n00b
n00b


Joined: 23 Mar 2005
Posts: 56

PostPosted: Thu Mar 24, 2005 1:38 am    Post subject: i swear ... Reply with quote

mikejr wrote:
Make sure you have support in your kernel for the file system you are trying to mount.

I swear that i configured it with built in support to ext2/3 ,xfs ,jfs , vfat, ntfs, ramdisk, all my drivers is built in too :roll: :roll: :cry: :cry: :cry:

.
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Thu Mar 24, 2005 10:33 am    Post subject: Reply with quote

Please stop typing your first post in all big and blue letters. It is very annoying.

Write down the exact error message and then post it here.
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum