Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
aumix make failed, pic USE flag problem?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
_mikec_
Guru
Guru


Joined: 22 May 2004
Posts: 386

PostPosted: Sun Mar 20, 2005 12:09 am    Post subject: aumix make failed, pic USE flag problem? Reply with quote

i am trying to prelink my system for better speed, i added pic USE flag and did emerge -auDv --newuse world ,it stopped on aumix-2.8-r2, here is the log,

aumix.txt:
Code:
Calculating dependencies  >>> Unpacking source...
>>> Unpacking aumix-2.8.tar.bz2 to /var/tmp/portage/aumix-2.8-r2/work
 * Applying aumix-2.8-nohome.patch ...
  [ ok ]
 * Applying aumix-2.8-close-dialogs.patch ...
  [ ok ]
 * Applying aumix-2.8-save_load.patch ...
  [ ok ]
 * Applying aumix-2.8-nls.patch ...
  [ ok ]
>>> Source unpacked.
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-nls --without-gtk1
creating cache ./config.cache
checking for a BSD compatible install... /bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking for mawk... no
checking for gawk... gawk
checking for gcc... gcc
checking whether the C compiler (gcc -march=athlon-xp -O3 -pipe -msse -m3dnow -mmmx -mfpmath=sse,387 -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=32 -maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays ) works... yes
checking whether the C compiler (gcc -march=athlon-xp -O3 -pipe -msse -m3dnow -mmmx -mfpmath=sse,387 -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=32 -maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /bin/install -c
checking whether ln -s works... yes
checking for _oss_ioctl in -lossaudio... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for ncurses.h... yes
checking for curses.h... yes
checking for fcntl.h... yes
checking for limits.h... yes
checking for malloc.h... yes
checking for strings.h... yes
checking for sys/ioctl.h... yes
checking for sys/time.h... yes
checking for unistd.h... yes
checking for sys/soundcard.h... yes
checking for initscr in -lncurses... yes
checking for getmouse in -lncurses... yes
checking for use_default_colors in -lncurses... yes
checking for private member _use_keypad in WINDOW... yes
checking for Gpm_Repeat in -lgpm... yes
checking for sys/consio.h... no
checking for machine/console.h... no
checking for CONS_MOUSECTL... no
checking whether built-in label text is requested... no
checking for sys/asoundlib.h... no
checking for snd_mixer_open in -lasound... yes
checking for pkg-config... yes
pkg-config found--compiling with GTK+ 2.0.
checking for pkg-config... /usr/bin/pkg-config
checking for GTK - version >= 2.0.0... yes
Compiling without GTK+ 1.2.
checking whether dummy mixer is requested... no
checking whether NLS is requested... yes
language catalogs: de el es fr gl ja nl pl pt_BR ru sv uk zh_CN
checking for msgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for locale.h... yes
checking for libintl.h... yes
checking for gettext... yes
checking for working const... yes
checking for inline... inline
checking for off_t... yes
checking for size_t... yes
checking whether time.h and sys/time.h may both be included... yes
checking for working alloca.h... yes
checking for alloca... yes
checking for unistd.h... (cached) yes
checking for getpagesize... yes
checking for working mmap... yes
checking return type of signal handlers... void
checking for getcwd... yes
checking for getwd... yes
checking for putenv... yes
checking for select... yes
updating cache ./config.cache
creating ./config.status
creating intl/Makefile
creating po/Makefile.in
creating doc/Makefile
creating data/Makefile
creating src/Makefile
creating Makefile
creating config.h
cd . && aclocal
cd . && automake --gnu --include-deps Makefile
cd . && autoconf
/bin/sh ./config.status --recheck
running /bin/sh ./configure  --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-nls --without-gtk1 --no-create --no-recursion
loading cache ./config.cache
checking for a BSD compatible install... (cached) /bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal-1.4... found
checking for working autoconf... found
checking for working automake-1.4... found
checking for working autoheader... found
checking for working makeinfo... found
checking for mawk... (cached) gawk
checking for gcc... (cached) gcc
checking whether the C compiler (gcc -march=athlon-xp -O3 -pipe -msse -m3dnow -mmmx -mfpmath=sse,387 -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=32 -maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays ) works... yes
checking whether the C compiler (gcc -march=athlon-xp -O3 -pipe -msse -m3dnow -mmmx -mfpmath=sse,387 -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=32 -maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for a BSD compatible install... /bin/install -c
checking whether ln -s works... (cached) yes
checking for _oss_ioctl in -lossaudio... (cached) no
checking how to run the C preprocessor... (cached) gcc -E
checking for ANSI C header files... (cached) yes
checking for ncurses.h... (cached) yes
checking for curses.h... (cached) yes
checking for fcntl.h... (cached) yes
checking for limits.h... (cached) yes
checking for malloc.h... (cached) yes
checking for strings.h... (cached) yes
checking for sys/ioctl.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for unistd.h... (cached) yes
checking for sys/soundcard.h... (cached) yes
checking for initscr in -lncurses... (cached) yes
checking for getmouse in -lncurses... (cached) yes
checking for use_default_colors in -lncurses... (cached) yes
checking for private member _use_keypad in WINDOW... (cached) yes
checking for Gpm_Repeat in -lgpm... (cached) yes
checking for sys/consio.h... (cached) no
checking for machine/console.h... (cached) no
checking for CONS_MOUSECTL... (cached) no
checking whether built-in label text is requested... no
checking for sys/asoundlib.h... (cached) no
checking for snd_mixer_open in -lasound... (cached) yes
checking for pkg-config... (cached) yes
pkg-config found--compiling with GTK+ 2.0.
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK - version >= 2.0.0... yes
Compiling without GTK+ 1.2.
checking whether dummy mixer is requested... no
checking whether NLS is requested... yes
language catalogs: de el es fr gl ja nl pl pt_BR ru sv uk zh_CN
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for gmsgfmt... (cached) /usr/bin/gmsgfmt
checking for locale.h... (cached) yes
checking for libintl.h... (cached) yes
checking for gettext... (cached) yes
checking for working const... (cached) yes
checking for inline... (cached) inline
checking for off_t... (cached) yes
checking for size_t... (cached) yes
checking whether time.h and sys/time.h may both be included... (cached) yes
checking for working alloca.h... (cached) yes
checking for alloca... (cached) yes
checking for unistd.h... (cached) yes
checking for getpagesize... (cached) yes
checking for working mmap... (cached) yes
checking return type of signal handlers... (cached) void
checking for getcwd... (cached) yes
checking for getwd... (cached) yes
checking for putenv... (cached) yes
checking for select... (cached) yes
creating ./config.status
  ...done!
>>> emerge (1 of 1) media-sound/aumix-2.8-r2 to /
>>> md5 src_uri ;-) aumix-2.8.tar.bz2


Code:
TB0x xb0x # USE="nls" emerge --oneshot aumix >> aumix.txt
automake: configure.in: required file `./config.guess' not found
automake: configure.in: required file `./config.sub' not found
make: *** [Makefile.in] Error 1
make: *** Waiting for unfinished jobs....

!!! ERROR: media-sound/aumix-2.8-r2 failed.
!!! Function src_compile, Line 63, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.

TB0x xb0x #


ldconfig, and USE="nls" emerge --oneshot aumix haven't work so far. Anyone recently had this problem? and hopefully found a fix?

thanks
_________________
(8 Mars 2005 - 07:52:46)
(18 September 2017 - 11:25:35)
Back to top
View user's profile Send private message
runlevel0
n00b
n00b


Joined: 09 Sep 2004
Posts: 67
Location: Mountains of Noord-Holland

PostPosted: Sun Mar 20, 2005 12:35 am    Post subject: Re: aumix make failed, pic USE flag problem? Reply with quote

_mikec_ wrote:
i am trying to prelink my system for better speed, i added pic USE flag and did emerge -auDv --newuse world ,it stopped on aumix-2.8-r2, here is the log,


Code:
TB0x xb0x # USE="nls" emerge --oneshot aumix >> aumix.txt
automake: configure.in: required file `./config.guess' not found
automake: configure.in: required file `./config.sub' not found
make: *** [Makefile.in] Error 1
make: *** Waiting for unfinished jobs....

!!! ERROR: media-sound/aumix-2.8-r2 failed.
!!! Function src_compile, Line 63, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.

TB0x xb0x #


ldconfig, and USE="nls" emerge --oneshot aumix haven't work so far. Anyone recently had this problem? and hopefully found a fix?

thanks


I have seen something similar but related to another config.xxx file, there are at least 3 open bugs within bugzilla, but the fix is quite
simple. In my case it was a complaint about a change in ./config.cache.

It's indeed just a silly syntax error in the CFLAGS variable because of an extra space between flags:

Code:

CFLAGS="-mtune=athlon  -pipe -fomit-frame-pointer"  <--- note the extra space between 'athlon ' ant '-pipe'
...
CFLAGS="-mtune=athlon -pipe -fomit-frame-pointer"  <---  OK


It's quite silly and it does not raise complaints most of the time until it does ;)
_________________
--
]:O <-[Mooooooooooo!]


Last edited by runlevel0 on Sun Mar 20, 2005 12:52 am; edited 1 time in total
Back to top
View user's profile Send private message
_mikec_
Guru
Guru


Joined: 22 May 2004
Posts: 386

PostPosted: Sun Mar 20, 2005 12:44 am    Post subject: Reply with quote

ok and the simple fix is?

got any links?

Thanks
_________________
(8 Mars 2005 - 07:52:46)
(18 September 2017 - 11:25:35)
Back to top
View user's profile Send private message
runlevel0
n00b
n00b


Joined: 09 Sep 2004
Posts: 67
Location: Mountains of Noord-Holland

PostPosted: Sun Mar 20, 2005 12:57 am    Post subject: Reply with quote

_mikec_ wrote:
ok and the simple fixe is?

got any links?

Thanks


Remove the extra spaces, it's this simple. It's sometimes not obvious at a first glance, so better check moving the cursor thru the line.

https://bugs.gentoo.org/show_bug.cgi?id=75538
_________________
--
]:O <-[Mooooooooooo!]
Back to top
View user's profile Send private message
_mikec_
Guru
Guru


Joined: 22 May 2004
Posts: 386

PostPosted: Sun Mar 20, 2005 1:26 am    Post subject: Reply with quote

i only have 1 space between my CFLAGS options, there's no double space

Code:
CFLAGS="-march=athlon-xp -O3 -pipe -msse -m3dnow -mmmx -mfpmath=sse,387 -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=32 -maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays"

_________________
(8 Mars 2005 - 07:52:46)
(18 September 2017 - 11:25:35)
Back to top
View user's profile Send private message
_mikec_
Guru
Guru


Joined: 22 May 2004
Posts: 386

PostPosted: Sun Mar 20, 2005 3:01 am    Post subject: Reply with quote

btw i dont need aumix, without it i can listen to my music with no problem.
_________________
(8 Mars 2005 - 07:52:46)
(18 September 2017 - 11:25:35)
Back to top
View user's profile Send private message
_mikec_
Guru
Guru


Joined: 22 May 2004
Posts: 386

PostPosted: Mon Mar 21, 2005 3:59 am    Post subject: Reply with quote

where it fails is in

Code:
checking whether build environment is sane... automake: configure.in: required file `./config.guess' not found
automake: configure.in: required file `./config.sub' not found
make: *** [Makefile.in] Error 1
make: *** Waiting for unfinished jobs....
yes


i really need to fix this, i can confirm i have no double space within my CFLAGS, somebody else had this similar problem before?
_________________
(8 Mars 2005 - 07:52:46)
(18 September 2017 - 11:25:35)
Back to top
View user's profile Send private message
runlevel0
n00b
n00b


Joined: 09 Sep 2004
Posts: 67
Location: Mountains of Noord-Holland

PostPosted: Mon Mar 21, 2005 10:25 am    Post subject: Reply with quote

_mikec_ wrote:
where it fails is in

Code:
checking whether build environment is sane... automake: configure.in: required file `./config.guess' not found
automake: configure.in: required file `./config.sub' not found
make: *** [Makefile.in] Error 1
make: *** Waiting for unfinished jobs....
yes


i really need to fix this, i can confirm i have no double space within my CFLAGS, somebody else had this similar problem before?


Check this out:
https://bugs.gentoo.org/show_bug.cgi?id=70379

It resembles very much to your problem, it had been fixed for 2.8-r4
the workaround would be to edit the ebuild and remove this text:

Code:

use_enable nls


There are not many bugs related to aumix in bugzilla and all of them are long fixed.
_________________
--
]:O <-[Mooooooooooo!]
Back to top
View user's profile Send private message
_mikec_
Guru
Guru


Joined: 22 May 2004
Posts: 386

PostPosted: Mon Mar 21, 2005 5:43 pm    Post subject: Reply with quote

THANK YOU!

removing the following worked for me.

Code:
use_enable nls

Code:
IUSE="nls"

Code:
epatch ${FILESDIR}/${P}-nls.patch

removing everything with " nls "

Regards.
_________________
(8 Mars 2005 - 07:52:46)
(18 September 2017 - 11:25:35)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum