Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
jpeg com problema naum permite instalar kde (resolvido)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
fabiano_almeida
n00b
n00b


Joined: 19 Jan 2005
Posts: 35

PostPosted: Wed Mar 16, 2005 5:50 pm    Post subject: jpeg com problema naum permite instalar kde (resolvido) Reply with quote

Bom pessoal estou tendo um pouco de problema para instalar o kde, o jpeg esta dando erro sempre na compilação...aqui o final é o seguinte:
Code:
mmgr.o .libs/jmemnobs.o  -L/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4 -L/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/crtendS.o /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/../../../crtn.o  -Wl,-soname -Wl,libjpeg.so.62 -o .libs/libjpeg.so.62.0.0
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/../../../crti.o: No such file or directory
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/crtbeginS.o: No such file or directory
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/crtendS.o: No such file or directory
g++: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/../../../crtn.o: No such file or directory
make: ** [libjpeg.la] Erro 1

!!! ERROR: media-libs/jpeg-6b-r4 failed.
!!! Function src_compile, Line 43, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.


aqui a ebuild:

Code:
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-6b-r4.ebuild,v 1.5 2005/01/30 21:06:16 j4rg0n Exp $

inherit flag-o-matic libtool eutils toolchain-funcs

MY_P=${PN}src.v${PV}
DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
HOMEPAGE="http://www.ijg.org/"
SRC_URI="ftp://ftp.uu.net/graphics/jpeg/${MY_P}.tar.gz"

LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ppc-macos s390 sh sparc x86"
IUSE=""

RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
        >=sys-apps/sed-4"

src_unpack() {
        unpack ${A}

        # allow /etc/make.conf's HOST setting to apply
        cd ${S}
        sed -i 's/ltconfig.*/& $CHOST/' configure
        uclibctoolize
        use ppc-macos && darwintoolize
        epatch ${FILESDIR}/${P}-gentoo.patch
}

src_compile() {
        replace-cpu-flags k6 k6-2 k6-3 i586
        econf --enable-shared --enable-static || die "econf failed"
        if use ppc-macos; then
                cd ${S}
                sed -i -e 's:LIBTOOL = libtool:LIBTOOL = /usr/bin/glibtool:' Makefile
        fi
        emake \
                CC="$(tc-getCC)" \
                AR="$(tc-getAR) rc" \
                AR2="$(tc-getRANLIB)" \
                || die "make failed"
}

src_install() {
        dodir /usr/{include,$(get_libdir),bin,share/man/man1}
        make \
                prefix=${D}/usr \
                libdir=${D}/usr/$(get_libdir) \
                mandir=${D}/usr/share/man/man1 \
                install || die
        insinto /usr/include
        doins jpegint.h

        if ! use ppc-macos ; then
                dosym libjpeg.so.62.0.0 /usr/$(get_libdir)/libjpeg.so.62
                dosym libjpeg.so.62.0.0 /usr/$(get_libdir)/libjpeg.so
        fi

        dodoc README install.doc usage.doc wizard.doc change.log \
                libjpeg.doc example.c structure.doc filelist.doc \
                coderules.doc
}


em uma outra instalação do gentoo a partir do stage 3 naum tive nenhum problema...estou tendo esse problema a partir do stage 2...

se ajuda minhas uses:
Code:

USE="X -gnome qt kde dvd alsa oss cdr 3dnow aac arts cdparanoia crypt cups divx4linux ftp gphoto2 icq java
jpeg joystick mozilla msn nas netboot javascript nptl opengl pdflib python samba vcd videos xine xinerama xmms"


se precisar de mais alguma coisa estou posta aew :D


Last edited by fabiano_almeida on Thu Mar 17, 2005 1:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
marcolovato
n00b
n00b


Joined: 13 Sep 2004
Posts: 39
Location: Porto Alegre/RS/Brasil

PostPosted: Wed Mar 16, 2005 8:13 pm    Post subject: Reply with quote

Do you have that folder?

/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4

I dont... I have only 3.3.5.

So, just make a soft link

Code:
cd /usr/lib/gcc-lib/i686-pc-linux-gnu/
ln -s 3.3.5 3.3.4


This solved for me.
Back to top
View user's profile Send private message
nafre
Guru
Guru


Joined: 27 Dec 2003
Posts: 388

PostPosted: Wed Mar 16, 2005 9:58 pm    Post subject: Reply with quote

o erro esta na gcc-lib tenta fazer o que o marcolovato falou.

entrar em /usr/lib/gcc-lib/$ARCH/

e cria um link para a versao que vc esta usando com a 3.3.4

Code:
ln -s 3.3.5 3.3.4

_________________
Nome- Felipe
Nick- Nafre
Idade- 25
Salvador - Bahia - Brasil
Back to top
View user's profile Send private message
fabiano_almeida
n00b
n00b


Joined: 19 Jan 2005
Posts: 35

PostPosted: Thu Mar 17, 2005 1:14 pm    Post subject: Reply with quote

thanks people, this solved for me too :wink: :) !!!!!!!!!!
Back to top
View user's profile Send private message
marcolovato
n00b
n00b


Joined: 13 Sep 2004
Posts: 39
Location: Porto Alegre/RS/Brasil

PostPosted: Tue Mar 22, 2005 6:45 pm    Post subject: Reply with quote

Please, edit the topmost subject, and add a [SOLVED] tag.

See ya
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum