Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Stort Problem Med Emerge "masked"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
inkazeus
n00b
n00b


Joined: 18 Oct 2004
Posts: 18
Location: Sweden

PostPosted: Wed Mar 16, 2005 5:12 am    Post subject: Stort Problem Med Emerge "masked" Reply with quote

Tjenare!
Jo jag har precis blivit klar med min forsta egna installation
stage1, "lite stolt" :) Och nar jag kort emerge system sa kom
jag pa att jag inte hade ACCEPT_KEYWORDS="x86" i make.conf.
Nu nar jag ska installera tex kmix, ar alla versioner masked.

Nogon som har en bra losning eller maste jag kora emerge --deep --newuse system igen.
_________________
-=zeus=-
Back to top
View user's profile Send private message
Fanatic
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 173
Location: Stocktown

PostPosted: Wed Mar 16, 2005 5:25 am    Post subject: Reply with quote

Har du lagt in ACCEPT_KEYWORDS="~x86" i /etc/make.conf så avmaskas alla filer. Ifall du inte redan uppgraderat allting så är det bara att ta bort ACCEPT_KEYWORDS från /etc/make.conf, och att använda /etc/portage/package.keywords istället ifall du vill avmaska enskilda paket.
Back to top
View user's profile Send private message
inkazeus
n00b
n00b


Joined: 18 Oct 2004
Posts: 18
Location: Sweden

PostPosted: Wed Mar 16, 2005 5:58 am    Post subject: Reply with quote

Ok, Funkade inte. ska nu kora emerge --sync utan ACCEPT_KEYWORDS="~x86"
i make.conf. Far se om det funkar efter det.
Tack for ditt snabba svar.
_________________
-=zeus=-
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Stockholm, Sweden

PostPosted: Wed Mar 16, 2005 12:13 pm    Post subject: Reply with quote

Det finns en liten grej man bör tänka på när man använder "ACCEPT_KEYWORDS="~x86"" och det är att även de program som grundprogrammet, det man vill installera, är beroende av och som installeras samtidigt kommer att bli av en maskad, kanske instabil version. Många gånger är det inte så man vill ha det.
Jag har inte lärt mig något smart sätt att lösa detta på men ett osmart men användbart knep är väl att köra emerge med -p och se vilka beroenden som finns och installera dessa först och sen göra en "ACCEPT_KEYWORDS="~x86" emerge" efteråt.
Back to top
View user's profile Send private message
Fanatic
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 173
Location: Stocktown

PostPosted: Wed Mar 16, 2005 5:33 pm    Post subject: Reply with quote

MagnusBerg wrote:
Det finns en liten grej man bör tänka på när man använder "ACCEPT_KEYWORDS="~x86"" och det är att även de program som grundprogrammet, det man vill installera, är beroende av och som installeras samtidigt kommer att bli av en maskad, kanske instabil version. Många gånger är det inte så man vill ha det.
Jag har inte lärt mig något smart sätt att lösa detta på men ett osmart men användbart knep är väl att köra emerge med -p och se vilka beroenden som finns och installera dessa först och sen göra en "ACCEPT_KEYWORDS="~x86" emerge" efteråt.


Nej nej och återigen nej ;) Du löser det där problemet genom att göra som jag tidigare nämnde, dvs:

Code:

echo programkategori/program ~x86 >> /etc/portage/package.keywords
emerge program


När du lägger till programmen i package.keywords bestämmer du själv vilka paket som är ~, och du löser problemet med att alla programmets dependancies är också omaskade.
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Stockholm, Sweden

PostPosted: Wed Mar 16, 2005 5:43 pm    Post subject: Reply with quote

Fanatic wrote:
Nej nej och återigen nej ;) Du löser det där problemet genom att göra som jag tidigare nämnde, dvs:

Code:

echo programkategori/program ~x86 >> /etc/portage/package.keywords
emerge program


När du lägger till programmen i package.keywords bestämmer du själv vilka paket som är ~, och du löser problemet med att alla programmets dependancies är också omaskade.


Visst fan, så gör man ju. Jag måste ha drabbats av en minnesläcka. Och när jag tittar i min egen package.keywords och package.unmask så upptäcker jag att där ligger hela Xfce4, ca:40 paket, kvar sen tiden innan den blev stabil d.v.s. version 4.1.99.3 :-)
Back to top
View user's profile Send private message
inkazeus
n00b
n00b


Joined: 18 Oct 2004
Posts: 18
Location: Sweden

PostPosted: Thu Mar 31, 2005 7:21 am    Post subject: Masked Reply with quote

Tack for att ni besvarat, men problemet ligger
nog snarare i /usr/portage/kde Alla ebuilds filer ar for kde 3.4.
sa klart att de ar masked for 3.3. testade att gora som ni beskrev ovan
men da ville den installera kde-base 3.4 och det vill inte jag.
nagon som vet varfor jag bara har 3.4 ebuilds i min kde katalog?
_________________
-=zeus=-
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Stockholm, Sweden

PostPosted: Thu Mar 31, 2005 1:03 pm    Post subject: Re: Masked Reply with quote

inkazeus wrote:
nagon som vet varfor jag bara har 3.4 ebuilds i min kde katalog?


Det har jag med. ;-) Gentoo delade nyligen upp KDE i cirka 1000 olika delar och av någon anledning verkar det som om de då tog bort äldre ebuild versioner än 3.4 och den versionen är ju maskad. Vore det jag som skulle installera KDE på min burk skulle jag ta och köra in den maskade 3.4:an i väntan på att den blir stabil.
Back to top
View user's profile Send private message
inkazeus
n00b
n00b


Joined: 18 Oct 2004
Posts: 18
Location: Sweden

PostPosted: Fri Apr 01, 2005 3:42 pm    Post subject: Reply with quote

Ok! hm det va ju inte bra. Men tack for din
replay. Det maste ju ga att fa tag pa 3.4 ebuils
nagonstans.:)
_________________
-=zeus=-
Back to top
View user's profile Send private message
patrix_neo
Guru
Guru


Joined: 08 Jan 2004
Posts: 372
Location: Svedala

PostPosted: Wed Apr 06, 2005 4:52 pm    Post subject: Reply with quote

Fanatic wrote:
MagnusBerg wrote:
Det finns en liten grej man bör tänka på när man använder "ACCEPT_KEYWORDS="~x86"" och det är att även de program som grundprogrammet, det man vill installera, är beroende av och som installeras samtidigt kommer att bli av en maskad, kanske instabil version. Många gånger är det inte så man vill ha det.
Jag har inte lärt mig något smart sätt att lösa detta på men ett osmart men användbart knep är väl att köra emerge med -p och se vilka beroenden som finns och installera dessa först och sen göra en "ACCEPT_KEYWORDS="~x86" emerge" efteråt.


Nej nej och återigen nej ;) Du löser det där problemet genom att göra som jag tidigare nämnde, dvs:

Code:

echo programkategori/program ~x86 >> /etc/portage/package.keywords
emerge program


När du lägger till programmen i package.keywords bestämmer du själv vilka paket som är ~, och du löser problemet med att alla programmets dependancies är också omaskade.


Har själv kört denna modell, och fick just problemet som MagnusBerg visade på. Man måste oftast eller till slut avmaska underliggande dependency packages. Fick ett rent h#¤e efter ett halvår med ett föga stabilt system. Så jag gick snällt tillbaka till stabila paket. Vilket jag inte ångrar. Men, lycka till.
_________________
update world set ignorance=off where religion=on
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum