Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
followed utf8 guide: problem with loadkeys at boot
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 342
Location: Berlin

PostPosted: Sun Mar 13, 2005 9:36 pm    Post subject: followed utf8 guide: problem with loadkeys at boot Reply with quote

Hi,

I followed http://www.gentoo.org/doc/en/utf-8.xml. Now, however, in the terminals pressing german umlaut keys on the keyboard lead to 2-byte strange symbols.

At boot time I get this message:
Code:
* Loading key mappings...
loadkeys: warning: this map uses Unicode symbols
    (perhaps you want to do `kbd_mode -u'?)


Any idea what went wrong here?


Last edited by f.kater on Tue Mar 15, 2005 10:19 am; edited 1 time in total
Back to top
View user's profile Send private message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 342
Location: Berlin

PostPosted: Sun Mar 13, 2005 10:20 pm    Post subject: Reply with quote

Meanwhile I added
Code:
/usr/bin/kbd_mode -u
at the right place in
Code:
/etc/init.d/keymaps

The error message at boot is gone. However, in the terminals I still get strange symbols when pressing the umlaut keys on the keyboard.

FYI: I am getting right sybols when using X applications like sylpheed, scite; openoffice however has the same problem like the terminals. The use flags and all config files are set according to the utf8 manual mentioned above.

How do I make xterm and openoffice display the umlaut keys correctly?


Last edited by f.kater on Tue Mar 15, 2005 10:20 am; edited 1 time in total
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Mon Mar 14, 2005 12:47 am    Post subject: Reply with quote

try cheking your xorg.conf or your
Code:
/etc/rc.conf

_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 342
Location: Berlin

PostPosted: Mon Mar 14, 2005 7:13 am    Post subject: Reply with quote

mascanho wrote:
try cheking your xorg.conf or your
Code:
/etc/rc.conf


Thanks.

AFAIK the entries in rc.conf are obsolete?
And, I am having these keyboard problems also in a non-X console, so xorg.conf won't help here, I beleve.

Hm...
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Mon Mar 14, 2005 11:04 am    Post subject: Reply with quote

If it only happens on X its either xorg.conf or your Desktopk manager keybord settings, try checking if you use gnome check fgnome-conctrl-center, if kde check kcontrol you may find there the solution .
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 342
Location: Berlin

PostPosted: Mon Mar 14, 2005 10:19 pm    Post subject: Reply with quote

mascanho wrote:
If it only happens on X its either xorg.conf or your Desktopk manager keybord settings, try checking if you use gnome check fgnome-conctrl-center, if kde check kcontrol you may find there the solution .

Thanks, but it is *NOT* only happening in X. It also happens on the login console before X is started . So, it must be a general thing...

Still no idea.
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Tue Mar 15, 2005 12:16 am    Post subject: Reply with quote

so wich keyboard layout do you want ??
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 342
Location: Berlin

PostPosted: Tue Mar 15, 2005 7:50 am    Post subject: Reply with quote

I need the "de" layout, but with utf8 support.

Like it is said in the mentioned gentoo utf8 manual I set KEYBOARD="-u de" in /etc/conf.d/keymaps, no success...
Back to top
View user's profile Send private message
UB|K
l33t
l33t


Joined: 27 May 2004
Posts: 786
Location: Villeurbanne, France

PostPosted: Tue Mar 15, 2005 9:39 am    Post subject: Reply with quote

Code:
locate .map.gz | grep de
/usr/share/keymaps/i386/qwertz/de_CH-latin1.map.gz
/usr/share/keymaps/i386/qwertz/de-latin1.map.gz
/usr/share/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gz
/usr/share/keymaps/i386/qwertz/de.map.gz

Have you tried with:
Code:
KEYMAP="de-latin1"

?

edit: wiki made with de example
_________________
Reality is that which, when you stop believing in it, doesn't go away.
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Tue Mar 15, 2005 12:40 pm    Post subject: Reply with quote

have you tried
Code:
loadkeys de-latin1


or
Code:
loadkeys "your_layout"
??
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 342
Location: Berlin

PostPosted: Thu Mar 17, 2005 9:30 pm    Post subject: Reply with quote

Thanks to both of you, however de-latin1 is even worse. At boot it tells me that this keymap would be not valid for uft8 (I don't remember the exact words)... So, maybe this is I hint for you: If I use my 3 umlaut keys right here in my browser window, I get:
Code:
äöü
which is correct. If I then do the same in xterm
Code:
echo "äöü" > test.txt # umlauts are not ok, I can't show you the effect
and paste text.txt here in the message board I get again the right umlauts:
Code:
äöü

What does that mean?? It must be something trivial I think! :?
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Thu Mar 17, 2005 11:04 pm    Post subject: Reply with quote

what do you have on your
Code:
/etc/rc.conf
??
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
f.kater
Guru
Guru


Joined: 23 May 2002
Posts: 342
Location: Berlin

PostPosted: Fri Mar 18, 2005 11:16 am    Post subject: Reply with quote

/etc/rc.conf
Code:
# /etc/rc.conf: Global startup script configuration settings
# $Header: /var/cvsroot/gentoo-src/rc-scripts/etc/rc.conf,v 1.30.4.1 2005/02/10 01:11:52 vapier Exp $

UNICODE="yes"
EDITOR="/bin/nano"
DISPLAYMANAGER="xdm"
XSESSION="icewm"

/etc/conf.d/keymaps
Code:
# /etc/conf.d/keymaps
# $Header: /var/cvsroot/gentoo-src/rc-scripts/etc/conf.d/keymaps,v 1.1.4.1 2005/02/19 02:13:53 vapier Exp $

KEYMAP="-u de"
SET_WINDOWKEYS="no"
EXTENDED_KEYMAPS=""
DUMPKEYS_CHARSET=""

Meanwhile I recompiled glibc (there was an update in portage): Now, in xterm I have the strange situation that *typing* the umlaut keys work now :!: , however if I do
Code:
echo "1" > äää.txt
ls
I get this filename
Code:
???.txt
So, what programm does actually list the files? This component probably still has got a problem with de.utf8...:?
Back to top
View user's profile Send private message
strerror
Retired Dev
Retired Dev


Joined: 16 Jan 2004
Posts: 24

PostPosted: Sat Apr 23, 2005 4:36 pm    Post subject: Reply with quote

have you checked your /etc/conf.d/consolefont ?
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Sat Apr 30, 2005 5:05 pm    Post subject: Reply with quote

i get this warning message too:
Code:
loadkeys: warning: this map uses Unicode symbols
    (perhaps you want to do `kbd_mode -u'?)


this is my /etc/conf.d/keymaps file:
Code:
# /etc/conf.d/keymaps
# $Header: /var/cvsroot/gentoo-src/rc-scripts/etc/conf.d/keymaps,v 1.1.4.1 2005/02/19 02:13:53 vapier Exp $

# Use KEYMAP to specify the default console keymap.  There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.

#KEYMAP="us"
KEYMAP="-u it"


# Should we first load the 'windowkeys' console keymap?  Most x86 users will
# say "yes" here.  Note that non-x86 users should leave it as "no".

#SET_WINDOWKEYS="no"


# The maps to load for extended keyboards.  Most users will leave this as is.

EXTENDED_KEYMAPS=""
#EXTENDED_KEYMAPS="backspace keypad euro"


# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set UNICODE="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`

DUMPKEYS_CHARSET=""


this is my /etc/conf.d/consolefont file:
Code:
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-src/rc-scripts/etc/conf.d/Attic/consolefont,v 1.1.2.1 2005/02/09 16:54:46 vapier Exp $

# CONSOLEFONT specifies the default font that you'd like Linux to use on the
# console.  You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).

#CONSOLEFONT="default8x16"
CONSOLEFONT="lat9w-16"

# CONSOLETRANSLATION is the charset map file to use.  Leave commented to use
# the default one.  Have a look in /usr/share/consoletrans for a selection of
# map files you can use.

#CONSOLETRANSLATION="8859-1_to_uni"


this is my /etc/rc.conf file:
Code:
# /etc/rc.conf: Global startup script configuration settings
# $Header: /var/cvsroot/gentoo-src/rc-scripts/etc/rc.conf,v 1.30.4.1 2005/02/10 01:11:52 vapier Exp $

# UNICODE specifies whether you want to have UNICODE support in the console. 
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
# KEYMAP in the /etc/conf.d/consolefont and /etc/conf.d/keymaps config files.

UNICODE="yes"

# Set EDITOR to your preferred editor.
# You may use something other than what is listed here.

EDITOR="/bin/nano"
#EDITOR="/usr/bin/vim"
#EDITOR="/usr/bin/emacs"

# What display manager do you use ?  [ xdm | gdm | kdm | entrance ]
#DISPLAYMANAGER="xdm"

# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit.  The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
# value that XSESSION is set to.  The support scripts are smart enough to
# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
# so setting it to "enlightenment" can also work.  This is basically used
# as a way for the system admin to configure a default system wide WM,
# allthough it will work if the user export XSESSION in his .bash_profile, etc.
#
# NOTE:  1) this behaviour is overridden when a ~/.xinitrc exists, and startx
#           is called.
#        2) even if ~/.xsession exists, if XSESSION can be resolved, it will
#           be executed rather than ~/.xsession, else KDM breaks ...
#
# Defaults depending on what you install currently include:
#
# Gnome - will start gnome-session
# kde-<version> - will start startkde (ex: kde-3.0.2)
# Xsession - will start a terminal and a few other nice apps

#XSESSION="Gnome"
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 594
Location: Almeria, Spain

PostPosted: Fri Sep 23, 2005 9:42 am    Post subject: Reply with quote

Same here as fctk but for a Spanish keyboard layout. My configuration files look exactly like his', but with "es" instead of "it".

In my case, I get no accented letters (like áéíóú) in Konsole, not Kate, nor KWord, nor any other KDE program.

However, I can type them in Firefox (from where I'm wrting this), or AbiWord, or even xterm.
Regarding xterm, when I typed this:
Code:
~/Desktop $ cat áéíóú > áéñ.txt
cat: áéíóú: No existe el fichero o el directorio

I got an *empty* file named áéñ.txt in my desktop, even though xterm says the file does not exist.

Does anyone know what is happening?
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 594
Location: Almeria, Spain

PostPosted: Fri Sep 23, 2005 11:56 am    Post subject: Reply with quote

f.kater wrote:
Meanwhile I added
Code:
/usr/bin/kbd_mode -u
at the right place in
Code:
/etc/init.d/keymaps


I don't understand what you mean by that. I already have "/usr/bin/kbd_mode -u" in my /etc/init.d/keymaps:
Code:
...
        # Set terminal encoding to either ASCII or UNICODE.
        # See utf-8(7) for more information.
        local termencoding="" termmsg=""
        if [[ ${UNICODE} == "yes" ]] ; then
                local dumpkey_opts=""
                [[ -n ${DUMPKEYS_CHARSET} ]] && dumpkey_opts="-c ${DUMPKEYS_CHARSET}"

                /usr/bin/kbd_mode -u
                dumpkeys ${dumpkey_opts} | loadkeys --unicode
                termencoding=$'\033%G'
                termmsg="UTF-8"
        else
                termencoding=$'\033(K'
                termmsg="ASCII"
        fi
...


but the error at boot time
Code:
loadkeys: warning: this map uses Unicode symbols
    (perhaps you want to do `kbd_mode -u'?)
still springs up.

BTW, I can type accented characters at the KDM login window, but not inside KDE programs once I'm logged in, as I stated in my previous post.
Back to top
View user's profile Send private message
Ibn al-Hazardous
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 133
Location: Somewhere deep in the desert.

PostPosted: Fri Sep 23, 2005 6:42 pm    Post subject: Reply with quote

I use swedish fonts and keymaps with utf-8 without trouble. Here is my config:
/etc/conf.d/consolefont
Code:
CONSOLEFONT="lat0-16"
CONSOLETRANSLATION="8859-1_to_uni"

/etc/conf.d/keymaps
Code:
KEYMAP="sv-latin1"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS=""
DUMPKEYS_CHARSET=""

/etc/rc.conf
Code:
UNICODE="yes"

/etc/env.d
Code:
LANG="sv_SE.UTF-8"
LC_ALL="sv_SE.UTF-8"

/etc/X11/xorg.conf
Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbModel" "pc105"
   Option      "XkbLayout" "se"
EndSection

And my /etc/init.d/keymaps is completely unchanged. Relying on changing it may break stuff if you're not very carefull with rc-update.

Does your config differ? If it does, would you try to change into settings similar to mine - and see what they yield?
_________________
/Ibn
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 594
Location: Almeria, Spain

PostPosted: Mon Sep 26, 2005 7:43 am    Post subject: Reply with quote

Thanks, Ibn al-Hazardous. I've been out of town for the weekend.

I checked my files. Here are the results.

My /etc/con.d/consolefont:
Code:
CONSOLEFONT="lat9w-16"
CONSOLETRANSLATION="8859-1_to_uni"


My /etc/con.d/keymaps:
Code:
KEYMAP="es"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS="backspace keypad euro"
DUMPKEYS_CHARSET=""


My /etc/rc.conf:
Code:
UNICODE="yes"


My /etc/env.d/02locale:
Code:
LC_ALL="es_ES@euro.UTF-8"
LANG="es_ES@euro.UTF-8"
LINGUAS="en es"


My /etc/X11/xorg.conf:
Code:
Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "es"
    Option "XkbVariant" "extended"

EndSection


My /etc/init.d/keymaps is also unchanged.

As you can see, they don't differ significantly from yours. However, I still can't type accented letters. The problem itself is with deadkeys in KDE applications and StarOffice.

As I said, I can type deadkeys in xterm and non-KDE applications. In fact, I've just started xterm and typed the following:
Code:
cat áéúñ.txt >> áñ~ü.txt

But to type that inside Konsole is impossible right now for me. However, If I drag the áñ~ü.txt file inside Konsole and choose paste, I get this:
Code:
'/home/user/Desktop/áñ~ü.txt'


As you can see, the application is able to correctly display the characters, as well as the other KDE applications. I just can't type the accented characters inside them, nor in StarOffice.

Any help is greatly appreciated.
Back to top
View user's profile Send private message
Ibn al-Hazardous
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 133
Location: Somewhere deep in the desert.

PostPosted: Mon Sep 26, 2005 8:10 am    Post subject: Reply with quote

Well, it seems to me your settings are as they should, so the next step is probably to check the misbehaving programs.

If you start a KDE-program from a terminal, you'll get your error messages/warnings there. Check if you get any messages regarding locale, also check if you get any error output when you use dead keys.

Also, it might be a good idea to check Xorg.0.log - if you haven't already.

HTH
_________________
/Ibn
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 594
Location: Almeria, Spain

PostPosted: Mon Sep 26, 2005 5:04 pm    Post subject: Reply with quote

Well, it seems I finally figured it out thanks to your suggestions.

When I started a KDE app from Konsole, I could see some complaints about the X server not supporting the locale. Same for StarOffice. As a side note, the output of a "locale -a" command is:
Code:
$ locale -a
C
en_IE@euro
en_US
en_US.utf8
es_ES
es_ES@euro
es_ES@euro.UTF-8
es_ES.utf8
es_ES.utf8@euro
POSIX
$


As you can see, I have both es_ES@euro.UTF-8 and es_ES.utf8@euro. Since I had chosen es_ES@euro.UTF-8 for my /etc/env.d/02locale, and it seemingly was not working, I decided to give es_ES.utf8@euro a shot. And I chose wisely :)

With es_ES.utf8@euro in my LC_ALL I could finally type accented characters inside KDE apps. However, there were still some drawbacks. StartOffice was still moaning about i18n not recognizing the locale. Also, three locales set through LC_ALL were still having problems: LC_CTYPE, LC_MESSAGES and LC_COLLATE. They just couldn't be set to es_ES.utf8@euro

So, I finally decided to try just es_ES@euro, without any utf8 in its name definition, the way it was before following the Gentoo guide to change my system to UTF-8 . This time, I chose even wiselier :D (can I say that? :?: ) Now, I'm able to type deadkeys in every program I've tried, including StarOffice. No more complaints about locales.

But I have some questions:
1) What's the difference between es_ES.utf8@euro and es_ES@euro.UTF-8?
2) Why did es_ES.utf8@euro partially work, whilst es_ES@euro.UTF-8 failed?
3) Why does es_ES@euro work better than es_ES.utf8@euro?
4) Why does the guide suggest to choose an aa_AA.UTF-8 as the value for LC_ALL?
5) Is my system really using UTF-8?

I really don't know what's really going on here. Any explanation will be greatfully received.
Back to top
View user's profile Send private message
Ibn al-Hazardous
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 133
Location: Somewhere deep in the desert.

PostPosted: Mon Sep 26, 2005 9:42 pm    Post subject: Reply with quote

urcindalo wrote:

So, I finally decided to try just es_ES@euro, without any utf8 in its name definition, the way it was before following the Gentoo guide to change my system to UTF-8 . This time, I chose even wiselier :D (can I say that? :?: ) Now, I'm able to type deadkeys in every program I've tried, including StarOffice. No more complaints about locales.

But I have some questions:
1) What's the difference between es_ES.utf8@euro and es_ES@euro.UTF-8?
2) Why did es_ES.utf8@euro partially work, whilst es_ES@euro.UTF-8 failed?
3) Why does es_ES@euro work better than es_ES.utf8@euro?
4) Why does the guide suggest to choose an aa_AA.UTF-8 as the value for LC_ALL?
5) Is my system really using UTF-8?

I really don't know what's really going on here. Any explanation will be greatfully received.


I don't have answers for all of your questions - I'll give it a shot:
1-2) No idea. Developer/standards confusion maybe?
3) IIRC the .utf8 version is mangled the way glibc wants it. It's not standard - but since glibc will mangle it that way even if you write UTF-8 (which is standard notation), it sometimes work.
4) Probably the guide is not euro aware?
5) I don't think so.

I have a suggestion. Try es_ES.UTF-8@euro and see if that works better (the difference is that the utf-part is left unmangled).

Anyway, if that doesn't work - you're probably better off waiting for a more mature unicode implementation. :(
_________________
/Ibn
Back to top
View user's profile Send private message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 594
Location: Almeria, Spain

PostPosted: Tue Sep 27, 2005 9:07 am    Post subject: Reply with quote

Ibn al-Hazardous wrote:
4) Probably the guide is not euro aware?
...
I have a suggestion. Try es_ES.UTF-8@euro and see if that works better (the difference is that the utf-part is left unmangled).


4) I didn't explain it very well, it seems. I wanted to know why the guide recommended xx_XX[@euro].UTF-8 instead of xx_XX.utf8[@euro], that is, why UTF-8 over utf8, but you clarified this to me with the answer to 3).

I tried your new suggestion. It seems to work, except for StarOffice, and I get a confusing answer from a "locale" command:
Code:
$ '/home/user/staroffice7/program/swriter'
I18N: Operating system doesn't support locale ""
$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=es_ES.UTF-8@euro
LC_CTYPE="es_ES.UTF-8@euro"
LC_NUMERIC="es_ES.UTF-8@euro"
LC_TIME="es_ES.UTF-8@euro"
LC_COLLATE="es_ES.UTF-8@euro"
LC_MONETARY="es_ES.UTF-8@euro"
LC_MESSAGES="es_ES.UTF-8@euro"
LC_PAPER="es_ES.UTF-8@euro"
LC_NAME="es_ES.UTF-8@euro"
LC_ADDRESS="es_ES.UTF-8@euro"
LC_TELEPHONE="es_ES.UTF-8@euro"
LC_MEASUREMENT="es_ES.UTF-8@euro"
LC_IDENTIFICATION="es_ES.UTF-8@euro"
LC_ALL=es_ES.UTF-8@euro
$


So, the behavior is the same as that for es_ES.utf8@euro. It seems the @euro tag must be attached after the UTF 8 indication.

Finally, it does not matter if I set my LC_ALL to es_ES.euro or es_ES.[UTF 8 whatever]@euro. When the system is booting, I can see this:
Code:
* Setting terminal encoding to UTF-8 ...      [ ok ]


That's why I think my system is using UTF 8 even if I set LC_ALL to es_ES.euro. Besides, I have UTF-8 as default in my kernel, as well as userlocales, utf and unicode as USE flags.
Am I wrong?
Back to top
View user's profile Send private message
Ibn al-Hazardous
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 133
Location: Somewhere deep in the desert.

PostPosted: Tue Sep 27, 2005 11:13 am    Post subject: Reply with quote

urcindalo wrote:
Ibn al-Hazardous wrote:
4) Probably the guide is not euro aware?
...
I have a suggestion. Try es_ES.UTF-8@euro and see if that works better (the difference is that the utf-part is left unmangled).


4) I didn't explain it very well, it seems. I wanted to know why the guide recommended xx_XX[@euro].UTF-8 instead of xx_XX.utf8[@euro], that is, why UTF-8 over utf8, but you clarified this to me with the answer to 3).

I tried your new suggestion. It seems to work, except for StarOffice, and I get a confusing answer from a "locale" command:
Code:
$ '/home/user/staroffice7/program/swriter'
I18N: Operating system doesn't support locale ""
$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
...
So, the behavior is the same as that for es_ES.utf8@euro. It seems the @euro tag must be attached after the UTF 8 indication.




I'm a bit puzzled about what file or directory it is complaining about. If you check in /usr/lib/locale/es_ES[.utf8] you should have LC_MESSAGES and LC_CTYPE, but I don't know about LC_ALL. Are you sure you got the same output with es_ES.utf8@euro for these three messages?

Quote:

Finally, it does not matter if I set my LC_ALL to es_ES.euro or es_ES.[UTF 8 whatever]@euro. When the system is booting, I can see this:
Code:
* Setting terminal encoding to UTF-8 ...      [ ok ]


That's why I think my system is using UTF 8 even if I set LC_ALL to es_ES.euro. Besides, I have UTF-8 as default in my kernel, as well as userlocales, utf and unicode as USE flags.
Am I wrong?


Well, I am some way out on thin ice now. ;) But I think these messages are supposed to mean that you have unicode support, not unicode locale. It could be that es_ES defaults to UTF-8 when unicode support is enabled, instead of ISO-8859-1 - but I'm not quite sure.

Lastly, I'm not sure about staroffice settings. Could it be that it is just staroffice that is confused, and need some extra attention?
_________________
/Ibn
Back to top
View user's profile Send private message
rofro
Apprentice
Apprentice


Joined: 21 Jun 2004
Posts: 234
Location: Piaseczno, Poland

PostPosted: Wed Sep 28, 2005 5:10 pm    Post subject: Reply with quote

similar topic https://forums.gentoo.org/viewtopic-p-1528086.html#1528086
_________________
Linux #358594
gentoo bug comment 175808#c26
You either must have patience or contribute to open source. There is only one guaranteed way to have open source do what you want it to do, and that's write it yourself.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum