Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Problem mit udev und Alsa
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
pawlak
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2005
Posts: 139

PostPosted: Sun Mar 13, 2005 1:05 pm    Post subject: [gelöst] Problem mit udev und Alsa Reply with quote

Hi!

Ich bin letzte Woche mal auf udev umgestiegen, seitdem hab ich folgendes Problem: Es wird beim Booten nicht mehr angezeigt welche Dienste gestartet werden, also quasi

Code:

* Starting Samba [OK]
* Starting CUPS [OK]
...


Die Dienste werden aber gestartet. Normal ist das ja denke ich nicht, was kann ich da machen? Bei demsg kommt

Code:
Warning: unable to open an initial console.


Ich kann auch die Rechte von /dev/console ändern wie ich will, nach nem Neustarte ist wieder

crw------- 1 pawlak tty 5, 1 Mär 13 13:44 /dev/console

eingetragen. Das komplette dmesg könnt ihr hier ansehen.


Ok nun zum 2. Problem: ich hab ne 2. Soundkarte eingebaut, welche auch wunderbar funktioniert, allerdings wird sie nicht als primäre Soundkarte genommen. Wenn ich später ein /etc/init.d/alsasound restart durchführe, dann klappt es und die Soundkarte wird als primäre Soundkarte genommen. Beide Soundkarte funktionieren, sind allerdings vertauscht. Ich will auch nicht die 2. Soundkarte deaktivieren, da ich diese benutzen will, wenn ich auf den TV-Out umschalte.
in /etc/modules.d/alsa steht:

Code:
alias snd-card-0 snd_emu10k1
alias sound-slot-0 snd_emu10k1

alias snd-card-1 snd-intel8x0
alias sound-slot-1 snd-intel8x0


und die emu10k1 soll die primäre Soundkarte sein.


Hoffe ihr könnt weiterhelfen!


Last edited by pawlak on Mon Mar 14, 2005 10:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
pawlak
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2005
Posts: 139

PostPosted: Mon Mar 14, 2005 6:31 pm    Post subject: Reply with quote

keiner ne ahnung? nicht mal beim alsa Problem? :/
Back to top
View user's profile Send private message
ZX-81
Guru
Guru


Joined: 23 Jul 2003
Posts: 355
Location: Germany

PostPosted: Mon Mar 14, 2005 6:58 pm    Post subject: Reply with quote

Bei udev tappe ich auch teilweise noch im Dunkeln, aber vielleicht solltest Du einfach eine neuere Version von udev ausprobieren.

Vielleicht kannst Du ja auch auf coldplug verzichten und Deine alsa-module in der richtigen Reihenfolge aus /etc/modules.autoload.d/kernel-2.6 laden

Weiterer denkbarer Versuch, compiliere Deine erste Soundkarte doch einfach fest in den Kernel.

Mehr als ein paar Tips zum rumprobieren kann ich Dir aber leider auch nicht geben.

ZX
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Mon Mar 14, 2005 7:03 pm    Post subject: Reply with quote

hi
Quote:

keiner ne ahnung? nicht mal beim alsa Problem? :/


Wenn du das module "snd-emu10k1" in die datei "/etc/modules.autoload.d/kernel-2.6" einträgst so das es vor dem module
von der ander Soundkarte geladen wird was bei start von alsasound eigentlich automatisch passiert solte es funktionieren.

mfg
Back to top
View user's profile Send private message
Fauli
l33t
l33t


Joined: 24 Apr 2004
Posts: 760
Location: Moers, Germany

PostPosted: Mon Mar 14, 2005 7:19 pm    Post subject: Reply with quote

Hast du das schon probiert? http://www.gentoo.org/doc/de/udev-guide.xml#doc_chap3_sect1
_________________
Do your part to beautify the web! Turn off link underlining!
Back to top
View user's profile Send private message
pawlak
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2005
Posts: 139

PostPosted: Mon Mar 14, 2005 9:12 pm    Post subject: Reply with quote

thx leute :)

Zwar hab ich wohl noch teilweise nen paar fehler bei der Anzeige beim booten, aber das ist nicht so schlimm! Es funktioniert wenigstens wieder :>

Auch das mit alsa geht. Werd aber wohl die primäre Soundkarte fest in den Kernel einkompiliern!

Dann kann ich ja ins bett gehn ;)
Back to top
View user's profile Send private message
lukaz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2004
Posts: 103
Location: europe.old.ch

PostPosted: Wed Mar 16, 2005 1:27 pm    Post subject: Reply with quote

auf der ccrma mailing-liste war vor einiger zeit folgendes zu lesen... habe es selber nicht probiert, weil ich auch die in den kernel gebackene loesung gewaehlt hatte. durch den kopf ging mir auch die idee einer udev-regel aber leider kenne ich mich damit noch nicht aus, von der grundsatzidee von udev denke ich allerdings es sollte moeglich sein. grtz lukaz

> where do I place the options
> statements to make sure the Intel chip is hw:0 and the USB device is
> hw:1?
>
> [root@dragonfly root]# cat /proc/asound/cards
> 0 [ICH5 ]: ICH4 - Intel ICH5
> Intel ICH5 with ALC655 at 0xfa081000, irq 17
> 1 [default ]: USB-Audio - USB Audio CODEC
> Burr-Brown from TI USB Audio CODEC
> at usb-0000:00:1d.1-2, full s
> [root@dragonfly root]#
>
> It seems that if I boot with this device plugged in it comes up as
> hw:0 and I'd like it to be hw:1.

I think the thing to do is to add a line like this:
options snd_intel8x0 index=1
to modprobe.conf, do a "/sbin/depmod -a" and reload alsa (or reboot)
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Wed Mar 16, 2005 5:59 pm    Post subject: Reply with quote

hi
Quote:

auf der ccrma mailing-liste war vor einiger zeit folgendes zu lesen... habe es selber nicht probiert, weil ich auch die in den kernel gebackene loesung gewaehlt hatte. durch den kopf ging mir auch die idee einer udev-regel aber leider kenne ich mich damit noch nicht aus, von der grundsatzidee von udev denke ich allerdings es sollte moeglich sein. grtz lukaz

> where do I place the options
> statements to make sure the Intel chip is hw:0 and the USB device is
> hw:1?
>
> [root@dragonfly root]# cat /proc/asound/cards
> 0 [ICH5 ]: ICH4 - Intel ICH5
> Intel ICH5 with ALC655 at 0xfa081000, irq 17
> 1 [default ]: USB-Audio - USB Audio CODEC
> Burr-Brown from TI USB Audio CODEC
> at usb-0000:00:1d.1-2, full s
> [root@dragonfly root]#
>
> It seems that if I boot with this device plugged in it comes up as
> hw:0 and I'd like it to be hw:1.

I think the thing to do is to add a line like this:
options snd_intel8x0 index=1
to modprobe.conf, do a "/sbin/depmod -a" and reload alsa (or reboot)


Beim mir funktioniert das mit index=X ohne Probleme :). Wenn man die
Soundkarten nach der gentoo Dokumentation eingerichtet hat solte
man es aber in die Datei "/etc/modules.d/alsa" eintragen.

So schauts nun bei mir aus:
Code:

....
....
# Set this to the correct number of cards.
options snd cards_limit=2

# Set this for the first ID for card #1
options snd-card-0 index=0

# Set this for the second ID for card #2
options snd-card-1 index=1
....
....


Danach natürlich noch ein "modules-update" ausführen.

mfg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum